Micro Stutter Fix



  • Well gang, I have have been working on solving several graphics issues with chiv. One is of course micro stuttering, screen tearing, others include anti aliasing and the horrible shimmering of distant objects along with jumping graphics while standing still. So far it seams I have resolved the micro stuttering.

    Much of this will apply to Nvidia as that is the card I have. So here is the deal after many trials and errors I figured out that unlocking your FPS gives you lots of FPS but it increases screen tearing and increases micro stutter. So the clear choice was turning on Vsync but that has its drawbacks and really increases the micro stuttering specially in swing and movement animations but there is virtually no screen tearing and you get solid FPS performance and the only excuses you have is real lag.

    SO the solution?

    1. Turn off Vsync in game - it is jsut badly coded within the engine.
    2. Turn on Vsync in Nvidia Control Panel - test on and adaptive to see which you prefer.
    3. Nvidia Control Panel - set render frames ahead to 1 or 2 max to limit mouse input delay
    4. Use Nvidia Inspector ( http://www.guru3d.com/files-details/nvidia-inspector-download.html )

    • download and install, click the little Tool Icon in the middle right of the program
    • This will open the Nvidia flags. You can tweak a lot more than in the Nvidia control panel
    • Look for the Frame Rate limiter and set it to 60, hit Apply. This will prevent your GPU from rendering more frames and creating the micro stuttering
    • save and close.
      5. Then goto UDKEngine.ini and set all of your FPS settings to 60
    • This includes: smooth frame rate = true fps min/max= 60 and Desired frame rate = 60

    Now play with very smooth graphics, silky smooth mouse input without screen tearing!

    But Ret! What about maxing and unlocking your FPS? Well this will always be a personal preference but I suggest trying this as it really smooths out the FPS to almost perfection (unless you have a potato GPC/CPU). Screen tearing is gone along with the majority of micro stuttering animations. (lag still has it’s effects but you can clearly see the difference and who is actually laggin)
    –------------------------------------------------------------------------------------------------------------------------------
    Anti Aliasing - Close / Midrange / Distance / texture twinkling

    These are still a work in progress. Much of it has to do with the DEVS not appling the proper anti aliasing to rendered objects within the engine. I have found out that Anisotropic filtering in both game settings and Nvidia make the twinkling worse as well as turning on the Anisotropic Optimization (Nvidia Control Panel). For my GPU a GTX 560TI, I find that the Nvidia texture settings over ride the game settings so I set that those to performance or high performance and set the in game settings to med.

    The biggest issues I struggle with is the anti aliasing. I have tried every setting in game and every setting in the Nvidia Control Panel with little to no success. Up close I get get things almost perfect but distant objects are horrific. SO any suggestions are welcome.



  • I’m trying it but didn’t notice any changes yet. But it seems like I’m the only one who has almost never FPS issues with this game anyway.



  • what if you have amd



  • @Monsteri:

    what if you have amd

    Then you have bigger worries.



  • @Monsteri:

    what if you have amd

    Do you get micro stutters?



  • @lemonater47:

    Do you get micro stutters?

    Game is one big stutter here on pub TO :(

    Wish chivalry 2 is more potato-friendly…



  • It is not necessarily an FPS issue. It is a micro stuttering issue of player animations and movement stuttering. What is happening is that your CPU and GPU are producing more FPS than is needed and with smoothframerate=true and vsync it tries to sync the left over FPS and ends up creating stuttering. By turning off the ingame vSync, nvidia capping the FPS and using Nvidia’s vSync you are manually force syncing your FPS so that it can go no higher or lower and no extra frames are being rendered.

    If you have AMD you find the equivalent version of Vsync and force it on while turning off the VSync in game. The INI setting changes will be the same.

    I am running an I7 but my GPU is only a GTX560TI so making all those changes gave me a silky smooth frame rate and mouse movement. I still have not figured out how to fix the shimmering/dancing of textures of distant objects. Stairs and any objects that have paralleled textures or edges are horrific in the distance and they dance and alias as you move closer to them, then at a close range they look like they should.

    Still tweaking….



  • what if you have a 144hz monitor?

    what do?



  • @zombojoe:

    what if you have a 144hz monitor?

    what do?

    Are you getting micro stutter on a 144hz monitor? I would look at your GPU if it can actually produce frame rates to match your refresh rate then try and set all of your setting to 144 or even 120. Disable all vsync and use Nvidia Inspector to cap the frames to 120



  • game feels like it stutters when my frame rate dips to 50 sometimes



  • @zombojoe:

    game feels like it stutters when my frame rate dips to 50 sometimes

    Well that makes sense if you think about it but if you do not have Vsync turned on or smooth frame rate to true along with a few other settings set to the same, you will get huge swings in FPS. The idea is to find the correct consistent fps rate under every condition so that the only stuttering would be caused by lag at that point. So you do not want your cpu or gpu producing more frames than the other only to have the software/driver settings try to compensate for the differences.

    What is your average FPS? Do you have your FPS cap unlocked? Do you have a consistent FPS during all maps, player numbers and pings? The last one is the goal.



  • my fps is a hit or a miss

    battlegrounds can dip to 30 fps

    but dark forest i get 80 fps



  • That is some pretty radical swings in FPS. Sounds like you have you fps unlocked and vSync off. I would like to know your specs. But have you tried the settings/tweaks I originally posted? Currently I am getting solid stable 59.9 FPS no matter what map or how many players. The only real time it dips is if there is bad lag.



  • My game stutters a ton. I have fps capped at 75 on 60hz monitor. My mouse input also stutters. It’s hard to describe it, it’s almost like a subtle lag, as if the mouse stops movement in mid motion for a split second then continues moving. I’ll try this fix, thanks.



  • on a lot of maps i manage to run the game at almost 120fps constantly with lowered settings…

    then again on maps like battleground i even get dips below 60 nowadays… runs extremely horrible for me, especially when playing mason and looking down the hill, observed with better hardware and strongly reduced graphic settings compared to a few month ago.
    some of the newly added community maps like the one that starts in the swamp also run utterly bad for the most part.

    get the performance at least back to where it has been already TB pls, also i wish i could go over 120 just like in offline mode but that’s a different kind of topic and probably unnecessary to demand when it already fails at 60fps right now.



  • This fix worked for me, perfect 60fps always (except for battlegrounds). However, I reverted the changes because gameplay just didn’t feel right…idk, placebo effect probably. Whatever floats your boat, I guess. I’m very superstitious when it comes to chivalry, even going so far as to change my emblem when I’m playing like shit…yeah…



  • @parkrangerstan:

    This fix worked for me, perfect 60fps always (except for battlegrounds). However, I reverted the changes because gameplay just didn’t feel right…idk, placebo effect probably. Whatever floats your boat, I guess. I’m very superstitious when it comes to chivalry, even going so far as to change my emblem when I’m playing like shit…yeah…

    I know what you mean. The first few days of playing with the tweaks, it was so smooth that it felt weird because I was used to the massive swings in FPS from 120 down to 45 on some of the maps. But with these tweaks, smooth fps and zero screen tearing. IF you get any stuttering or delay it is caused by lag from the server and the bad netcoding and usually there is little you can do about that.

    While everyone assumes that more FPS = better game play, with Chiv, I have found that if you can get and maintain a solid 60 FPS in sync with your 60Hz monitor the game is smooth as silk with no screen tearing. The only issue is possible mouse delay, but that is why you set your Render Frames Ahead (Nviidia control panel) to 1 or 2 max to limit that delay.

    Give it a go for a week or so and see if you dont see a dramatic change to how the game plays because you are used to the game being choppy and when it doesnt happen it feels weird. Once you get used to the smooth play, drags are so much more effective and gratifying.



  • Found another possible Micro stutter fix and testing it now.
    UDKEngine.ini
    bUseTextureStreaming=False (default is True)
    This will make larger maps load longer but it might stop the streaming in of new textures



  • @filthypeasant:

    on a lot of maps i manage to run the game at almost 120fps constantly with lowered settings…

    then again on maps like battleground i even get dips below 60 nowadays… runs extremely horrible for me, especially when playing mason and looking down the hill, observed with better hardware and strongly reduced graphic settings compared to a few month ago.
    some of the newly added community maps like the one that starts in the swamp also run utterly bad for the most part.

    get the performance at least back to where it has been already TB pls, also i wish i could go over 120 just like in offline mode but that’s a different kind of topic and probably unnecessary to demand when it already fails at 60fps right now.

    60fps is a failure, lol you are spoilt. I cant wait until I get a constant 60fps.



  • 144 hz monitor here, I turn on blur busters strobelight beta app to remove all motion blur (feels like a CRT) and run it at 120 hz since that’s the max frames per second that chiv will allow. Turning on adaptive vsync through nvidia control panel, as well as 2 frame render ahead limit and turning texture streaming off has done wonders for the performance of my game. Thanks a bunch for the suggestions Retsnom.


Log in to reply