Server shows on LAN not on broadcast server - ports forwarded - closed???



  • I did read through the FAQ, the setup guides, youtube videos and none are answering the issue unfortunately. Also a Unix and PC Admin guy and I have Win 2008 Server training so not a brain at this stuff but not a dolt either.
    Looking for some help please.

    1. What the issue is. (be as descriptive as possible)

    Created new server from the STEAM download. Modified the config files for my own server name, logins etc. All seems to start up fine and it shows on the “LAN Tab” and I can join and play on the same PC the Server is set up on. It does NOT show up on the Servers “tab”.
    I have ports 7777/7778 and 27015 UDP and TCP forwarded. I tested using TightVNC and changing the listening port on TightVNC to confirm no firewall bocking or other issues. Works fine. Start up the server and probing the 3 port numbers report back as being “Closed” implying the game is not listening on those ports??? I am not using any custom ports and no other forwarding other than TightVNC 5900 just for more testing stuff.
    I am going to also try the Steam Friend List option but would like to host a server for the community as well.

    1. Attach your DxDiag.txt file (In Windows, press Start, type DxDiag in the search bar and open up the program it shows. Click run then save results as .txt file and add it to your thread.)

    Attatched
    DxDiag.txt
    DxDiag64.txt DxDiag using the 64bit option

    1. Attach your Launch.Log file (To find your launch file, go to My Documents then to My Games then to Chivalry then UDKGame then go to Log folder.)

    Attached
    UDKLogger.txt - log file from the launching of the game
    Launch.txt - as per request above as step 3 had to rename it as it said invalid file to upload. Original name was “Launch.log”

    1. Post any screenshots if you think it may be relevant to your issue and easier to explain.

    Nothing fancy here… it shows in the LAN folder but not in the broadcast “Servers” tab.

    Attached
    Ports.jpg screen shot of forwarded ports

    This is a 64bit system and has a couple of network cards. I disabled IPv6 on all connections just in case. I put my LAN connection (wired connection) to be the top most available network connection.

    I verified the windows firewall (private, public and domain) were all turned off but when testing the Windows firewall with the rules to enable the ports I was able to connect to TightVNC using the specific ports as listening ports (ie remapped the listening port within TightVNC server to be 7777, 7778, 27015 ) one at a time and all connected with TightVNC.

    I used a couple of port sniffers from the outside and when

    • Ports not forwarded = “timed out”
    • TightVNC was connected = open and ready
    • Launch the game = ports closed
    • Launch the game and join the LAN connector locally just in case it needed some traffic = no change

    Tested the ports with Telnet (the more typical option but I wanted to use TightVNC as then I could see if it would actually talk back and forth fine).

    The 64bit install offers both 32 and 64 bit options. I tried both - no difference.

    Think that is it??? Any help would be appreciated. I understand it does not test the UDP and etc but figured if the ports were at least getting through then it would not care re TCP or UDP since I have both defined.

    I also tried mapping my server as the DMZ as well my ISP offers the option of “Advanced DMZ” which ignores the rest of the network (my family was not happy when I dumped all their connections including TV and youtube links LOL) and makes the destination PC (ie my PC) to end up having the outside IP address.

    Again none of it seemed to matter.

    It is almost as if there is an issue with the port listening on the server software. I have spent HOURS on this as you can tell from above and the above doesnt include the head banging saying 'it should not be this difficult!" as we were also able to get it working fine for an XP machine.

    I am running Windows 7 Pro SP 1 as per DxDiag.

    Not a honken machine… it is the spare one I was going to use for my server for the game. Sigh…

    thanks
    Schumway



  • Your UDKlogging.log is incomplete for some reason.

    Looking at your commandline…

    • If you’re on a network with many PCs make sure to add a -multihome parameter, which seems to be missing on your command line. Based on your log, add -multihome: 192.168.2.20 or whatever LAN IP the host has.
      Even if port redirections are properly set, that parameter seems to fix most of the “sv is running but not showing up on Steam” issues.

    • I think numplay sets the number of bots on your server and not how many slots it will have. At any rate, I always use _-maxplayers=_n instead. Maybe try that just in case.



  • Thank-you for your response.

    Interesting enough… I had a friend try to connect and he can see it and connect.

    Odd… I still can not see it in the server list… but he can.

    Not a huge deal because I can (yes) see it in the LAN… and even easier to find.

    thank-you for the info but it seems to be something with the server list.

    Thank-you for your assistance. I am okay with having to go to the LAN to play and others can use the server list.

    Thank-you Alphonse as well!!! Appreciate your time reading the request.



  • i have same problem
    i see lan list but
    im not see server lists why please help me


Log in to reply