Chivalry won't start because Directx wont install properly



  • Basically, I downloaded and installed the game and everything was fine, then I started the game for the first time and it started installing prerequisites and when it got to directx9.0c an error popped up (as attached image). I hit OK and everything keeps going like usual and when it’s finished it tries to start the game (My status changes from “Online” to in game Chivalry for about 3 seconds then changes back to online) but nothing seems to happen.
    Every time I try to run the game nothing happens other then changing my status for a couple seconds.
    I have tried many times to fix this registry key error for .net framework, but nothing I have tried has had any effect.
    The only thing I can think of is reinstalling windows, but I have many things on my computer I need, and I don’t want to reinstall windows.

    Specs:
    Windows 7 64-bit.
    8 GB RAM
    AMD FX 8150 EightCore Processor 3.60GHz
    AMD Radeon HD 6850 (Graphics Card)

    I will also attach my DxDiag.



  • Try installing it manually?
    http://www.microsoft.com/en-us/download … aspx?id=35
    http://www.microsoft.com/en-us/download … x?id=17851

    To be honest, you should be able to skip over the .NET install w/o any issues.



  • I tried installing those files, but both said I have a newer version, i checked and i have version 4.5
    Maybe there is some other reason that my game wont start?
    I have looked in other threads and their game at least pops up and black screens…
    Mine nothing at all happens when i try open it.


Log in to reply