My server keeps crashing.



  • I removed all custom maps from my server. I recently, again, had my host do a server reinstall. It seems nightly that the server crashes. Here is my maplist:

    Maplist=AOCTO-Battlegrounds_v3_P
    Maplist=AOCCTF-Moor_p
    Maplist=TO2-crypts
    Maplist=AOCTO-Belmez-CM_p
    Maplist=AOCFFA-Darkforest_Valley_p
    Maplist=AOCTD-ThroneRoom_P
    Maplist=AOCTO-Hillside_P
    Maplist=AOCFFA-Ruins_P
    Maplist=AOCTO-Darkforest_p
    Maplist=AOCFFA-Shipyard_p
    Maplist=AOCLTS-ArgonsWall_p
    Maplist=AOCFFA-Cistern_p
    Maplist=AOCTO-CastleAssault-CM_P
    Maplist=AOCCTF-Ruins_P
    Maplist=AOCFFA-ThroneRoomXL_P
    Maplist=AOCTD-Frigid_p
    Maplist=AOCTO-Citadel_p
    Maplist=AOCFFA-Darkforest_Cistern_p
    Maplist=AOCTO-Hillside_P
    Maplist=AOCFFA-Mines_p
    Maplist=AOCTO-Cove-CM_p
    Maplist=TO2-crypts
    Maplist=AOCLTS-Moor_p
    Maplist=AOCFFA-Arena3_p
    Maplist=AOCTD-ArgonsWall_P
    Maplist=AOCTO-Darkforest_p
    Maplist=AOCFFA-HillsidePyre_P
    Maplist=AOCTO-DrunkenBazaar-CM_p
    Maplist=AOCTD-Courtyard_p
    Maplist=AOCFFA-Cistern_p
    Maplist=AOCTO-Stoneshill_P
    Maplist=TO2-crypts
    Maplist=AOCFFA-Bridge_p
    Maplist=AOCLTS-ThroneRoom_P
    Maplist=AOCTO-Coldfront_p
    Maplist=AOCFFA-Moor_p
    Maplist=AOCTO-KingsGarden-CM_p
    Maplist=AOCLTS-Arena3_p
    Maplist=AOCTO-Outpost_p
    Maplist=AOCFFA-Hillside_P
    Maplist=TO2-crypts

    Here is what NFO script repairs and then reboots the server:
    Our repair script ran on your server and gave the following output:

    Processing kila:
    Refreshing hardlinks:
    Engine/Shaders/WorkingDirectory/UDK/1104/0 was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/2416/0 was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/2560/0 was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/3064/0 was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/3064/1/WorkerLog.txt was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/3064/2/WorkerLog.txt was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/3064/3/WorkerLog.txt was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/7992/0 was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/8388/1/WorkerLog.txt was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/8388/2/WorkerLog.txt was missing or corrupted and was replaced.
    Engine/Shaders/WorkingDirectory/UDK/8388/3/WorkerLog.txt was missing or corrupted and was replaced.
    UDKGame/Logs/Launch-backup-2013.03.28-10.22.07.log was missing or corrupted and was replaced.
    UDKGame/Logs/Launch.log was missing or corrupted and was replaced.
    UDKGame/Logs/Launch_2.log was missing or corrupted and was replaced.

    Why are these shaders consistently being deleted and or corrupted? When I goto those locations on the server there is nothing in the Engine/Shaders/WorkingDirectory/UDK. I am assuming that certain maps create those shaders and use them in the working directory while the map tries to load. I tried to catch it when those files are imported there and I thought that adding Read only might solve this but have not been able to test it yet as they are gone.

    Not sure what is up with the log files disappearing as well. I do use the Chiv Rcon Tool Quite a bit to remote admin the server. Not sure if that would effect the logs.



  • I wouldn’t imagine it would effect the logs by using the rcon tool. I’ve seen that mine goes down after about a day of uptime unexpectedly. Still haven’t determined if those shaders are causing it or not though.



  • LOLS instead of responding to this issue in the Official Tech Support: server thread. they moved it here…. wow and of course no help or response…



  • Don’t think RCon tool would affect it at all.

    Do you have access to Steam Update with their services?
    If so; just remove all your files and let Steam download them anew.
    It may be possible that their install files are corrupt. Can happen to anybody.
    Or that the check misses some new files.



  • If you have that maplist you deserve a crash.



  • and what is so wrong with that maplist? It is a good mix of fun maps without repeating the same mode back to back

    Yeah I am having them look into it further. I dont understand after a fresh vanilla install it keeps crashing….



  • Both the rcon tool and B3bot are confirmed to cause the server to crash btw



  • @MonkeyFiend:

    Both the rcon tool and B3bot are confirmed to cause the server to crash btw

    SO whos fault is this? The Devs did not supply a remote admin of any type other than to port it…… It still doesnt explain why it would lock up every 20th map


Log in to reply