Game crashes and takes steam with it.



  • I’m gonna copy-paste text from my reddit thread: http://www.reddit.com/r/ChivalryGame/comments/2suoe5/chivalry_crashes_steam/

    Chivalry basically crashes steam and freezes because steam isn’t running. Maybe it’s the other way around, I don’t know.

    It can happen at level load or 10-20 minutes into the game, seems completely random. I tried verifying game cache and removing chivalry settings in “My Games” folder. Also tried running 64-bit and 32-bit version. I don’t have any workshop content installed.

    System specs:
    AMD FX-8320
    8gb of ram
    Nvidia GT 440
    Windows 10 preview.

    After that I tried every possible solution in sticky thread and it still crashes.



  • Since steam crashes too you may be able to find a record of it in “Event Viewer”. Start > search “Event Viewer” > Look in Window Application and Custom Administrative.

    A GT440 though, I wonder if the card can’t handle it.



  • This card can easily handle it. I mean it already runs it, anything else isn’t important. I’m sure it’s no the reason for crashes.



  • I have the same exact issue but with different specs:
    AMD-FX6100
    16GB of RAM
    Nvidia GTX 970
    Windows 10 preview 64-bit

    Because we are both running win10 I would assume the issue is related to that. I didn’t have the issue until I recently installed the most recent build with Cortana and all the new updates. Could it be related to the fact that I’m running dx12?
    Using the event viewer, I see this error that coincides with each crash, each with the same exception code. The error, I think, is actually steam related (but it only occurs in this game for, so far).

    Faulting application name: SteamService.exe, version: 2.59.12.64, time stamp: 0x54c2c151
    Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
    Exception code: 0xc0000005
    Fault offset: 0x00000000
    Faulting process id: 0x2180
    Faulting application start time: 0x01d0385f04772e70
    Faulting application path: C:\Program Files (x86)\Common Files\Steam\SteamService.exe
    Faulting module path: unknown
    Report Id: b426dd84-a453-11e4-95d8-902b34a1db55
    Faulting package full name:
    Faulting package-relative application ID:

    EDIT:

    I found a solution!
    Navigate to C:\Program Files (x86)\Common Files\Steam (or equivalent) and rename SteamService.exe to SteamServiceBAK.exe
    After doing so, I get weird stutters and freezes on occasion but it seems that crashing is almost nonexistent! Hopefully a better solution is found, or the problem gets fixed though, since the service itself is rather useful for computers that need UAC.


Log in to reply