Torn banner…. what hardware should i buy?



  • Torn banner, forever in this game… about 3800 hours now, i have been plagued by your games inability to animate swings, constantly flutter of fps every single patch, weapons showing one thing and doing another, models skipping across the map like a rock across the pond. Animations going from frame one to frame 10 in a matter of a half a second.

    What hardware should I buy to make this game work on my pc? What kind of equipment do i need to handle its depth? I work near a lot of supercomputers, who knows they may auction off at some point. What equipment do you guys test chivalry on, maybe i can replicate it so i can play this game properly. I have no idea at this point how this game runs this bad after what? 2 years? over 2 years?

    please just give me a hint at how i can play this game stable and things are the same when i play them. What kind of budget am I looking at, i don’t want to exceed$ $5000 but damn i’ve already put 2+ years into it i better commit now or get out right?

    WHAT THE FUCK!?

    hey but i got some new skins so it’s allllll goooooooooooooooooooood.



  • Root king has like 2 gtx 790’s, the best i-7 money can buy, as well as 64 gb of ram. He basically bought the best PC money could buy and his game runs just fine. That’s all you have to do Clay.



  • ok br0 heres what u do

    1. sell ur pc (pc is bad)
    2. buy xbox 360 (bes console)
    3. game on bro!


  • I’m honestly interested to hear a dev respond to this. Do you guys test at 120 fps? If so what are you using to get a steady 120 fps on all of the TO maps? I don’t even care how much it cost I just want to know if it’s actually possible.



  • the thing is i was finally getting 120fps stable on MOST of the maps with a few exceptions. Streamed tourney everything fine last week. Now i come back a week later after the patch ( i didn’t play since patch till last night ). Boom, dropping to like 60-70-80 fps in certain areas of the map, really choppy animations again, people moving around looking like i’m missing like 5 frames of their animations, even just movement animations i’m missing frames of.

    What hardware do you guys use to test on, maybe i’ll just build a replica system of whatever you guys use. Apparently i have some piece of hardware that chivalry doesn’t get along with. I may not have “the best pc money can buy”, but it manages to play every other game I want to play on max settings. BTW, i run chivalry on the LOWEST settings, except for the resolution because i’m not going to play at lower res.

    ^theres another good question up there as to whether the game is tested at 120 fps or not. If i drop it down to 60 I can get a stable 60fps constantly, but 60fps is garbage after playing 120. It’s like taking it back to the stone age. (Cavemen hue)



  • @50ShadesofClay:

    It’s like taking it back to the stone age. (Cavemen hue)

    Heh. I get it.



  • @Dire:

    I’m honestly interested to hear a dev respond to this. Do you guys test at 120 fps? If so what are you using to get a steady 120 fps on all of the TO maps? I don’t even care how much it cost I just want to know if it’s actually possible.

    The online game is hard limited to 90 FPS I get that on all maps and 120 to 180 FPS locally with this laptop

    http://ca.msi.com/product/nb/GS70-2PE-211US-Stealth-Pro.html#hero-specification

    and it was only 2200 dollars.



  • To be fair Clay, this patch seriously borked animation frames up for almost everyone, so I wouldn’t make drastic edits or purchases based solely on this issue.

    For now.



  • I always get a constant 120 fps on all maps with my 900 dollar at the time 2 year old PC. I guess I’m lucky. The animations do look very strange though. I remember the animations being drastically easier to read like 4 months ago. Even if I have 120 fps, the game still looks strange. I can watch Youtube videos of Chivalry and it looks soooooo much smoother than what I’m playing.



  • I turn off everything feature wise, use low textures and get 120 all the time. I have 8gb ram, 79703gb and i5 3570k (oc’d 3.6ghz)



  • currently stay away from the GTX900 series as the drivers are all borked. I have serious micro stuttering even scrolling while browsing. It is all over Nvida and Evga forums as well as many others. They still havent figured out what is causing it.



  • Just turn off everything. Only way to get the consistent 120.



  • @gregcau:

    The online game is hard limited to 90 FPS I get that on all maps and 120 to 180 FPS locally with this laptop

    http://ca.msi.com/product/nb/GS70-2PE-211US-Stealth-Pro.html#hero-specification

    and it was only 2200 dollars.

    I could be wrong but I was under the impression that keeping smoothframes set to true in the UDKEngine file you could get 120 fps online. I know that whenever I check stat FPS in console it’s reading 120 fps when I play online but I don’t know anything about programming or how the UDK Engine actually works so maybe it’s inaccurate.

    As far as the few people who said they can get 120 on all of the maps are you suggesting you never have frame drops on any maps? Even certain spots of Coldfront, Citadel, and Cove? I mean I can get a steady 120 on most maps but definitely not the three I mentioned above and I built my comp for about $700. I just always assumed that the game wasn’t optimized well enough to get 120 on some maps regardless of how good your computer was.



  • @Sir:

    Just turn off everything. Only way to get the consistent 120.

    Speaking of which, fucking vignette. I’ve gone into the .ini file and changed the line to “False” and it still keeps coming back on by itself.



  • Also, doesn’t bsmoothframes just sync the frames er…I forget. Is bsmoothframes actually beneficial if you’re playing @ ~ 60 fps?



  • can only confirm… once again i have less fps than pre patch and the html menu hasn’t changed anything about that even if the patch notes would like to indicate that, the newly added skins from the fantasy contest surely don’t help much either.
    i have even tried turning the basic shadows off but even after that i struggle to get 120fps i got 120 straight before with big margins partially, on classic maps already… ffs, excluding battlegrounds.
    basically already having everything set to low but only character models to high which in some regards already makes it look like a good n64 game xD. sometimes i open the game and it is smooth. not only does every patch make it worse, it feels like everytime i start the game i either get it working or not.
    no placebo, it is pretty borked and tb should seriously release a real performance patch to clean up the junk…



  • for those of you saying to turn everything off…

    I DO

    http://steamcommunity.com/sharedfiles/filedetails/?id=381323198

    3770k, gtx680, ssd, 8gb ram. Can’t run chivalry with good frames on low.

    Again, not the top of the line pc, but can’t run chiv on low? please. I was perfect before the patch man, well almost. Now frame drops a LOT and it’s worse on certain maps than others. Yet again, darkforest is probably the best frame wise but I’m even getting drops on there which was flawless before. I’d say that drunken bazaar has to be the worst for frames. Then again pre-this patch belmez i had frame drops in certain areas but I hear a lot of people did in certain spots on that map so i write that one off.

    I know everyone has different hardware and such, and maybe the game just likes certain shit more than other shit.

    and thanks Ret, i was actually considering getting a 980 soon but maybe i’ll wait for the driver issues to subside first ;)



  • This post is deleted!


  • The only time I get consistent 120 FPS no drops is on tavern.



  • @50ShadesofClay:

    for those of you saying to turn everything off…

    I DO

    http://steamcommunity.com/sharedfiles/filedetails/?id=381323198

    man, your field of view is on max, thats clearly the cause of your problems


Log in to reply