Optimus does not switch video cards.



  • Optimus will not switch to my GTX 840m when I play Chivalry. I have tried to change the default videocards of both 64 bit and 32 bit UDK.exe but it still does not switch. All other games I have played do switch to the nvidia card, these included: Planetary Annihilation, GTA IV, Space Engineers, War Thunder, Natural Selection 2 and AoE2 HD.

    My laptop is a Acer V3-572G-54S6



  • wait…. what? You have a laptop with two videocards? This makes no sense. Your GTX 840 is the integrated GPU and is the only GPU that it will play on. If you are referring to which Drivers a game uses then uninstall all the drivers, in safe mode using GPU Driver Sweeper. http://www.guru3d.com/content-page/guru3d-driver-sweeper.html Reboot and only install the Optimus drivers. Do not install 3D vision, Nvidia Experience or even PrecisionX. Then test run the games.

    Once everything is running correctly, then you can install the others if you like except 3D vision unless you have the glasses and the monitor to do it but you don’t, so don’t.



  • My laptop has an integrated intel hd 4000 and a dedicated 840m. What Optimus does is that it switches to the dedicated card each time I run a demanding application(To save power and heat).

    So no, it is not the driver. You should look up Nvidia Optimus in wikipedia and you will see that yes, it is for laptops with two cards.



  • The 840M is his dedicated graphics card in that laptop. Pretty much all laptops these days also have an integrated card as well probably Intel integrated graphics. All laptops have two graphics cards these days lol. One dedicated one integrated.

    Chivalry likes to use the Intel graphics over the dedicated graphics in laptops. No idea why you usually have to end up disabling it in the bios.



  • “Chivalry is only detecting and using the integrated intel GPU on your i7 CPU, instead of the dedicated GT 540m. Go into the Nvidia Control Panel, and make a profile for Chivalry(locate the game’s UDK.exe in your steam folder) and choose to use your Geforce GPU and that should solve your problem.”



  • If you look at my first post, I stated that I have tried that with both the 32 and 64 bit versions. It still starts with the intel hd card.



  • This post is deleted!


  • I see that, but other people with the exact same card used that fix and worked for them, leading me to believe you may have inputted something wrong since the logs show it is still trying to find the integrated graphics.
    http://steamcommunity.com/app/219640/discussions/0/864951657951746711/

    I could be wrong though and you could have an anomaly, which our only other option other then setting it to use the Nvidia GPU is to outright disable the integrated graphics before playing.



  • Who are the people who it worked for? Who should I contact nvidia or acer?



  • @fran4x:

    Who are the people who it worked for? Who should I contact nvidia or acer?

    Honestly neither of those companies will care since their hardware is working as intended. You could try nvidia support and claim that a game’s profile is not using the GPU selected.



  • Have you tried disabling the bloody thing in the Bios. Then it just won’t show up at all and will use your 840M.

    Chivalry is neutral weird and likes using your integrated graphics over your dedicated. Only with laptops though.



  • Exactly, just disable your Intel GPU in bios and make sure you have PCIE if that is your only option available instead of integrated. Then go to the device manager and disable it there as well. This should force everything to run of off GTX840. You may also want to look at your power settings as well in both the OS and the Nvidia Control Panel and make sure they are on maximum



  • I have found the solution! Oddly, it is not UDK.exe but CMW.exe one must change the profile of.



  • @fran4x:

    I have found the solution! Oddly, it is not UDK.exe but CMW.exe one must change the profile of.

    Oddly?

    Its the name of the executable when you launch lol.

    Then again reading back Amish told you UDK.exe. Didn’t notice that.



  • It is also the exe nvidia detects by default.


Log in to reply