The Big Stutter Thread



  • The game is riddled with bugs, sure, but this has got to be the most ridiculous problem I’ve found with the game so far;
    Every animation seriously lags/stutters/skip frames and it still hasn’t been fixed for whatever reasons. There’s plenty of threads about this going around but apart from a few dev responses (read below) there’s yet to be any confirmation whatsoever.
    Since none of these threads have found themselves being resolved over time, nor have I found any fixes myself, I’m gonna approach this topic differently.

    To the developers:
    Inb4 “We can’t reproduce this issue” –- Bullshit.
    Have you considered joining any server? I know, I know. You’d have to stop testing on your superb LAN branch for a moment, but you’ll see.

    Steps to reproduce:
    1. Start the game. Such complication.
    2. Join a server.
    3. Watch people swing around and combo.
    4. Watch people riposte with fast weapon setups.
    5. Watch backswing combos become one big Powerpoint slideshow.

    I don’t know how you guys somehow got a DLC addition update to fug up animations, but you did.
    That doesn’t mean we don’t care how you did it. Just tell us what changes you made. We might be able to fix it with a mod and then let you guys know which bits of code are the culprits.

    To the community:
    Has anyone, anyone at all, found themselves facing this issue concerning laggy and stuttering animations/movement and have a solution? Or heck, maybe you made some .ini edits and only managed to reduce the occurences a little bit.
    Let me know! The game is unbearable like this. It’s ruining scrims, other competitive matches and even barely populated pub servers. It occurs in every imaginable form and there seems to be no way around it.
    I wanna say trying to parry polearm and bastard sword swings is a big joke now, but it’s like that for every weapon. At the moment I consider myself lucky after having read even the most simple Zwei drag.

    My entire PC hardware setup meets the minimum requirements and is running every map at at least 90 FPS.
    Average ping in servers ranges from 16 to 44. Download speed is at 28Mbps, upload at 7.5Mbps. 0% packet loss.
    Not to mention I’ve been able to run this game just fine for the most part for the past 2 years.



  • Capslock to become a divine being, an entity wiser than the human race combined, you must only quit Chivalry. Join me in the havens and become a God.

    Also wait for Slasher, TBS wont fix this shit ever



  • i dont see any difference now from before.



  • @gregcau:

    i dont see any difference now from before.

    Same here. Probably just like the last stutter issue where a few people had it. Spook’s had it every time. So it’s something TBS did that just doesn’t sit right with certain players’ configs.



  • I also haven’t experienced any stutters, desyncs or any other bullshit - Chiv is super smooth for me.

    I hope you guys will get this fixed/resolved soon :/



  • @Karasu:

    Same here. Probably just like the last stutter issue where a few people had it. Spook’s had it every time. So it’s something TBS did that just doesn’t sit right with certain players’ configs.

    That’s what I hoped for at first.
    Sadly, a full reinstall of both the program files and config files didn’t do the trick.

    It’s weird but interesting how such a small margin of players is experiencing the problem - but those who do can’t exactly figure it out.
    Most likely I’d want to point the finger at using a wireless connection for gaming, but up to this point I’ve had no issues whatsoever with not using my ethernet cable and I doubt it’s actually related to the problem at hand…



  • I sincerly don’t care too much about the stuttering atm, it’s the 57 crashes in the last 48 hours that pissed me off.



  • @Rickvs:

    That’s what I hoped for at first.
    Sadly, a full reinstall of both the program files and config files didn’t do the trick.

    It’s weird but interesting how such a small margin of players is experiencing the problem - but those who do can’t exactly figure it out.
    Most likely I’d want to point the finger at using a wireless connection for gaming, but up to this point I’ve had no issues whatsoever with not using my ethernet cable and I doubt it’s actually related to the problem at hand…

    I use wireless. I get 40 ping on the right server.

    If someone is getting stuttering it could be there general internet (I know for example recently my router acted up and I was seeing bad ping lag and a reboot fixed it).

    I think if you run the game locally and it is smooth as pie, then that would rule out your graphics card or general configuration and you have to focus on your internet. The bottom line is if you share your internet with other programs, or even people on the same cable on the street you could get a slow down but you should be able to see that by pinging the server constantly.



  • @Xylvion:

    I sincerly don’t care too much about the stuttering atm, it’s the 57 crashes in the last 48 hours that pissed me off.

    On the bright side, many people admire one’s quality of not knowing when to give up. :)

    @gregcau:

    I think if you run the game locally and it is smooth as pie, then that would rule out your graphics card or general configuration and you have to focus on your internet. The bottom line is if you share your internet with other programs, or even people on the same cable on the street you could get a slow down but you should be able to see that by pinging the server constantly.

    I see. I wish it were that easy.

    Normally I got multiple users on the modem but even when I’m the only user the problem persists. Chivalry’s offline game with bots is a much smoother experience for everyone btw, wireless or not.

    I’m afraid I’m gonna have to rule out the wireless connection being a possible culprit. Sure, it might be 1 of multiple factors that in the end cause this bug, but Chivalry has performed just fine for too long to suddenly add cable to the minimum requirements.
    If using a wireless connection would really cause such a severe issue then I’d say it’s still Chivalry that needs fixing instead of my modem or adapter.
    You say you use wireless but don’t notice a difference so I’m gonna go ahead and conclude my internet setup is not the direct cause of this problem.
    I’d love to investigate further into what else is causing this because obviously it’s rendering the game unplayable for me and many others, but with 0 effort from TB’s end it’s not really that easy.

    But as if I’m one to complain if Xylvion seriously can barely keep the game running. Imo the game is in the exact opposite right now of a state TB can abandon it in.
    I’ve had some crashes and many other various misc. bugs as well in the last week, but I’m too scared of reporting them for the fear of giving TB an excuse not to look into this first.



  • Apart from poor animations, I attribute any mishaps that occur to my wonky graphics card or wireless internet.



  • @Rickvs:

    walloftext.

    My friends keep laughing at me as I try to start the game for the tenth time in a row and it still doesn’t work. Best thing is that I’m not getting any crash reports.
    Going to reinstall for the third time this week, not superfun with 8MB download speed, I hope it might work decent this time. If I get rid of the constant crashes I’m happy.



  • https://www.youtube.com/watch?v=pv0x0Sgb7QM&feature=youtu.be

    This is what’s been happening to me a lot since the last mini patch



  • @Kim:

    https://www.youtube.com/watch?v=pv0x0Sgb7QM&feature=youtu.be

    This is what’s been happening to me a lot since the last mini patch

    Oh wow. Nothing micro about that. I thought it was just choppiness kinds of stutters. That’s pretty disruptive.



  • my aiming feels super choppy its really hard to shoot nerds from across the map when none of my mouse movements match ffs



  • I have been experiencing extreme frame rate drops out of no where in Chiv. I’m not sure what’s causing it, I was going to attribute it to my HDD being slightly older than 4 years now and maybe shitting the bed. However these micro / macrostutters that occur in Chiv are not happening in Battlefield 4, Hardline, Insurgency, Dota 2, Metro Last Light, Civ V, Evolve or any other game I own both demanding and non-demanding. I wish we had a stat graph to better observe what was being impacted on the system (CPU / GPU performance graphs).

    For reference my system specs are the following:
    mobo: z87-hd3
    cpu: i7-4770k 3.6 ghz
    memory: 8 gb ram
    gpu: GTX 780 4gb
    I run chiv on a regular HDD that’s slightly old. I’ll be replacing it soon to see if that changes anything.



  • Evolve is a nice game :)
    I’ll never defend the game’s ridiculous DLC structure, nor have I found either the official servers or official 2K support very reliable so far, but the class diversity and gameplay is just spot on.

    Let me know if that HDD replacement solves anything. Mine’s aging as well.



  • So… just did my final attempt at playing Chivalry in this patch.
    Animations still broken as fuck, apparently everyone’s having different problems with this patch so I’ll guess it’s just unstable as fuck. It took me 6 attempts in total to join a server without one problem or the other.
    Let’s not even get started with the flood of minor bugs that got introduced in that 1 match.

    This is it. 2 years of my life wasted. Game is broken beyond belief and Torn Banner just abandons it; I have yet to receive any help on this matter. Sent 2 PM’s to different devs; only got 1 half-ass response back worth nothing.

    I’m done. I’ll try it again after a long-ish while, see if Chivalry has improved. But for now I’m absolutely done.
    Over the last 2 years I’ve done my absolute best in this game and spent many hours on it, and now finally thinking back with some honesty made me realize just how many more times I’ve left this game raging due to utter bullshit happening than closing the game down with a smile.
    Those years spent were in a different game for the most part, as well. Animations are so laggy right now, I literally can’t rely on any of the basic mechanics I’ve trained for so long. Over time, Chivalry has become a completely different game (all for the worse), with different system requirements it seems.
    Nah, that’s too easy.
    Over time, Chivalry has become the most unstable mess imaginable and has continually fucked its playerbase over and over.

    Any other human being would know this but apparently Torn Banner members do not, so here it is;
    It’s not okay to completely break a product people have paid money for, and then abandon it. But thank god there are new fantasy helmets that fix everything.
    If Chivalry were to be professionally reviewed at this point of its lifespan it’d be declared one of the biggest Steam game scams, and rightfully so.

    I hope you all get aids and die. At the very least, I hope you get flooded with negative responses and go bankrupt 5 minutes after the launch of whatever your next moneygrabbing project may be.

    Hue Rickvs QQ RQ.
    Inb4 mods edit/remove this post.



  • This post is deleted!


  • This post is deleted!


  • @Kim:

    https://www.youtube.com/watch?v=pv0x0Sgb7QM&feature=youtu.be

    This is what’s been happening to me a lot since the last mini patch

    THIS. THIS IS MY JAM. I hate it so much. My lady and I play together on the same connection and she doesn’t get any stutters, so I know it’s not the internet. I’ve got a 760GTX and 16 GB of the rams and I have no idea why this game is causing so many problems.


Log in to reply