Mac Version Doesn't Load and Resolution Problem



  • The Problem:

    When I run the game on Mac OS X Yosemite the game opens with resolution were i can only see the lower left corner but MORE importantly the game doesn’t even load :hopelessness:. Many other mac users have the same problem.

    You really shouldn’t release the mac version with such an obvious bug BUT i respect it has only just been released.

    Could you please let me know of a fix of this or when you plan to fix the problem?

    System specs:
    OSX Yosemite Version 10.10.2
    MacBook Pro (13-inch, Mid 2012)
    Processor 2.5 GHz Intel Core i5
    RAM 8 GB 1600 MHz DDR3
    Graphics
    Intel HD Graphics 4000 1024 MB



  • Maybe 10.9.5 is the only version is works with rather than the minimum operating system. Who knows.

    Anyway torn banner is notorious for having something working in beta and breaking it at release. Happens so often you can bet money on it. The nature of the engine and the original code apparently being as tidy as a bombed spaghetti factory.

    Then again mate even if you do get it to run you won’t have an enjoyable experiance with specifications like that. Graphics scraping the bar and a processor that goes under.



  • On the steam forums rome of people have this issue.

    Funnily enough if they opt into the Mac/Linux beta it works. But there’s no servers obviously.

    If they try to play it normally it doesn’t work.

    Maybe you should make the whole game beta torn banner. As everything in beta works but when you release it it breaks.



  • Im on 10.9.5 and it won’t get past the loading screen - just makes my computer overheat.



  • same here…



  • Oh hey Lemonater :D.



  • I am having to deal with the exact same problem, it’s really annoying!



  • I was having no isssues with this game for weeks, save for it being very very framey at times and also it would require me to change resolution everytime I re-open Chiv to get it down to a graphic setting that wouldn’t make the game chug, but will never save that settting. Also, audio settings were unable to be dialed in, like all sorts of static chirps. But other than that, I was having a grand ole time, and logged more than 70 hours, and was hoping to log many more…

    Now I am experiencing the same thing you all are. I hear like 2 seconds of audio, the torn banner splash, and then this zoomed in version of the keyboard controls that only shows the lower left-hand corner of that window and my rainbow loading wheel that spins until I can watch it spin no more. I also get a Chiv message: ?INT? Engine.Errors.FailedMapload_NotFound?

    Again, this game was working fine enough two days ago and now it will not open, and I have tried FAQng and searching for answers but it has all led me here. I’ll add that I was one of the fools who bought this on PS3 (goodluck fixing that) so I don’t want to make this about a money thing, but I have purchased the game twice now, re-installed it and steam several times to no avail. So anything you guys could do to remedy this Mac issue would help all of us out, as I have also gotten several other people to purchase your game, I know that I am doing my part as a patron of this amazing world you’ve created. I am a devout fan and love playing this game. I just want to lop off some heads and Thank my brothers. Please help TB!!!



  • Also stuck at the loading screen. Hope TB fixes this one soon. Very frustrating.


Log in to reply