Joystick being counted as controller?



  • So when I bought Chivalry today, and finally got it loaded up. It is seeming to think that my joystick is classed as a controller? Seeing as you can hold a mouse button to see where the mouse, it is not that much of an issue. But when I go into a match, the camera just decided to spin round in circles.

    Is there any way to make Chivalry see I just have a mouse activated to play, and not register my joystick?

    Thanks in advance for any help given.


  • Developer

    Sorry this isn’t exactly helpful, but I just always plug my joystick into a front usb port and unplug it whenever I play unreal games. That seems to happen more or less across the board in unreal games. :/

    edit: Ok, so, we’ll look at adding a config option to just disable controllers and joysticks for a future patch.



  • Open in Notepad the UDKEngine.ini, located C:\Users\YOUR NAME\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config
    Scroll down till you see the following:

    [WinDrv.WindowsClient]
    AudioDeviceClass=XAudio2.XAudio2Device
    MinAllowableResolutionX=0
    MinAllowableResolutionY=0
    MaxAllowableResolutionX=0
    MaxAllowableResolutionY=0
    MinAllowableRefreshRate=0
    MaxAllowableRefreshRate=0
    ParanoidDeviceLostChecking=1
    AllowJoystickInput=0 - CHANGE THE 1 TO 0 - This disables the joystick.

    Save and close.


Log in to reply