Setting up a dedicated server



  • Hi

    I am trying to set up an online dedicated server, but I can’t get the server to show on steam, and I am my wits end:

    Server configuration:

    Online FFA, with Black Knight mod, 5 bots, 20 player max, red wedding map and 6 standard maps, dynamic external IP.
    Starter-bat: “C:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win64\UDKLogging.exe” AOCFFA-RedWedding?numplay=5?steamsockets -Port=7777 -QueryPort=27015 -modname=BlackKnight -sdkfileid=232823090 -dedicated=true -seekfreeloadingserver
    (i have tried using multihome too, with the same result)

    I am using a fixed internal IP for the server (a dedicated computer, not the computer i am gameing on) and i have forwarded ports 7777, 7778 and 27015 to my server. I have pluged the server directly in the modem so it does not run on my router. The server is running and I can join it using the open XXX command from the same Network, but i cannot join from a different internet connection.

    I have tried setting it up as LAN and that Works fine (shows in steam as LAN too), but when i try to host online it does not show up.

    I have appended the server log and PCServer-UDKGame.ini

    Please help I am all out of ideas here.



  • God knows. Server problems are random. I can’t for the life of me get my server start start up with Black Knight, even though it’s sitting there in the SDK folder just like all the other mods (which do work).

    Given that you cannot connect to it from outside it would certainly appear to be a port/firewall problem though.



  • I thought the player amount variable was -maxplayers rather than -numplayers?

    Anyhoo if the server is working locally but not on public, what happens when you try and open the public IP:port?

    Next up… plugging the server directly into the modem? setup port forwarding? If you’re setting up port forwarding you’ll be using the router to do so, so really not sure what the score is here. You could however put the server within the DMZ of the router, but I wouldn’t connect it to a modem directly.

    Assume as well that the machine running the dedi server is not using it’s own software firewall (like windows firewall)?

    When you’ve forwarded ports, are you forwarding UDP or TCP or both?



  • ^^ -numplayers is the target player count, below which it will populate with bots, I think.



  • <small>@dudeface:</small><br><blockquote>^^ -numplayers is the target player count, below which it will populate with bots, I think.</blockquote><br />First off, thank you both for the quick replys!<br />to answer your questions:<br />1) the numplay is just for adding a fixed number of bots that does not affect the max players (i defined max players in the ini file)<br />2) the modem has a built in basic router, but all other computers are connected via a second router to allow for more advanced rules<br />3) I have farwarded both UDP and TCP in the modem-router <br />4) just as for info: I am running the server on a freshly formatted win7 pro 64bit that only runs steam and one instance of the chivalry dedicated server (no other steam apps are installed)<br /><br />based on your replys I tried setting the server up like this:<br />1) removed Black Knight, custom maps and numplay from the starter.bat to eliminate those factors, the starter looks like this: “C:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win64\UDKLogging.exe” AOCFFA-Arena3_p?steamsockets -Port=7777 -QueryPort=27015 -dedicated=true -seekfreeloadingserver<br />2) switched off windows firewall, the setting I was using should not be the problem though, as I have opende all ports for TCP/UDP for UDK, UDKLogging and the Chivalry .exe files, both externally and internally<br />3) Tried connecting to the server from my brother-in-laws house usig open IP:Port<br /><br />I agree with Dudeface that this looks like a problem with the ports, but I just can´t figur out why. Do you know if there is some problem with using a dynamic external IP?<br /><br />I tried looking through the logs again and found this (still nothing of interest in the windows-logs):<br /> <br />Loading Areana:<br />[0019.65] Init: WinSock: Socket queue 131072 / 131072 <br />[0019.65] Init: WinSock: Socket queue 131072 / 131072<br />[0019.66] Log: Initialized RedirectNetDriver, for redirecting IP connections to Steam sockets<br />[0019.69] Log: NetMode is now 1<br /><<< nothing wrong here NetMode=1 should be online as far as I know>>><br />[0019.69] Log: Primary PhysX scene will be in software.<br />[0019.69] Log: Creating Primary PhysX Scene.<br />[0019.70] Log: Bringing World aocffa-arena3_p.TheWorld up for play (60) at 2015.05.19-08.58.49<br />[0019.95] Log: ########### Finished loading level: 0.392911 seconds<br />[0019.97] Log: Flushing async loaders.<br />[0020.46] Log: Flushed async loaders.<br /><<<Level seems to load fine>>><br />[0020.63] DevDlc: Shipping Level: aocffa-arena3_p<br />[0020.63] Log: Steam game server UID: 90095591687814152<br />[0030.72] DevPhysics: Error (1) in file …\Physics\src\NpActor.cpp, line 272: Actor::setLinearVelocity: Actor must be (non-kinematic) dynamic!<br />[0030.72] DevPhysics: Error (1) in file …\Physics\src\NpActor.cpp, line 287: Actor::setAngularVelocity: Actor must be (non-kinematic) dynamic!<br /><<<Physics errors, I think this is due to left overs from UT, does not seem to cause problems for the game>>><br />[0030.73] Log: StartOnlineGame() LAN Match: 0<br />[0030.73] Log: StartInternetGame() 1<br />[[1513.57] Log: FSocketWin::Close<br /><<< If I read this right, the game should now be online and the loading done (since the socket is closed again)>>><br />[1537.23] NetComeGo: Close IpNetDriverSteamworks_2 IpNetConnectionSteamworks_2 3.127.37.232:4353 05/19/15 09:24:07<br />[1702.29] NetComeGo: Close IpNetDriverSteamworks_3 IpNetConnectionSteamworks_1 192.168.1.226:63537 05/19/15 09:26:52<br /><<<This is wat i don’t understand, closing steam connections? and those IPs? the external IP is for a server in Georgia (in easteren europe, not US) and the internal must be for the Georgian servers network (I do not have any device on my network with that ip)>>><br />could this be a torn banner server for authendication, and if so could this be the problem?<br /><br />any help is much apriciated :-)



  • Thank you for the help, Please se the reply I made for Dudeface, it is ment for both of you



  • I forgot to say that the problem is still the same, so for me at least, Black Knight does not seem to be the problem



  • btw that georgia IP is a steam socket, not an IP :)

    Just to appease my curiosity, can you try running the startup command with -multihome then the internal Ip of the server?



  • @MonkeyFiend:

    btw that georgia IP is a steam socket, not an IP :)

    Just to appease my curiosity, can you try running the startup command with -multihome then the internal Ip of the server?

    Hi MonkeyFiend, I tried using multihome, but still no change. A friend of mine Works at my ISP and he told me that our dynamic IP was essentially an internal IP on a giant WLAN (they are running out of IPv4 adresses or some thing) so I have switched to a static IP. I am currently trying out all the advice you gave me again on the new IP… I´ll let you know how it turns out.



  • As you requested AmishInsurgent, here is my Engine.ini



  • Hi All

    Now it works, i would like to thank you all for helping, and in case anyone is having the same problem, here is what I have done:

    As I mentioned earlier my ISP is using a sort of WLAN for all dynamic IPs, so my server would never be able to Work without an external static IP. So I changed to static IP, ask your ISP how they handle dynamic IPs if you are having similar problems.

    my starter ( witch now Works :-) ): “C:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win64\UDKLogging.exe” AOCFFA-RedWedding?numplay=5?steamsockets -multihome=192.168.1.119 -Port=7777 -QueryPort=27015 -modname=BlackKnight -sdkfileid=232823090 -dedicated=true -seekfreeloadingserver

    some good advice:

    • when testing, try removing all custom content (maps and mods) that will help eliminate a lot of posible errors
    • remember to use a static IP on your internel Network for your server and forward the ports: 7777, 7778, 27015 to this IP.

    Sorry for my broken English, and thanks for all the help:glee:



  • Glad you got it working :)


Log in to reply