Chivalry Linux Client - Terrible FPS drop in Coldfront



  • I don’t really get it. Chivalry runs great for me on every map except Coldfront. Once the catapults start chucking away, my fps drops to around 15. I don’t have a low-end system. On every other Chivalry map, and regardless of how many players are running around, I get a solid 60FPS.

    But on Coldfront, it’s a slideshow. I tried lowering ALL of my settings with zero effect.

    My system specs:

    Linux Mint 17.1 “Rebecca” Cinnamon 64bit upgraded to Kernel 3.19.0-21 (but I’ve tried Kernels as far back as 3.13 with no luck)
    Intel Core i5-4690 Haswell 3.5Ghz Quad Core
    ASRock H87M-ITX LGA 1150 Intel H87 MOBO
    Nvidia Geforce GTX 760 4GB w/ Proprietary Binary 352.21 drivers
    16GB System RAM
    250GB Samsung EVO SSD (where OS/STEAM/GAME install paths are)

    Funny thing is my friend was over and his system is decent too but slightly less-so than mine:

    Linux Mint 17.2 Cinnamon 64bit w/ 3.16 Kernel (default for 17.2)
    AMD FX-6350 Hex-Core 3.9Ghz
    Nvidia Geforce GTX 660 2GB w/ Proprietary Binary 352.21 drivers
    8GB System RAM
    7200RPM WD Hard Drive

    He did not have any issues with Coldfront whatsoever. Ran at a solid 60fps.

    Strangely enough, on other maps, he got 45-55ish, with fluctuations, where I got 60 on those maps.

    I’ve tried to eliminate variables, figure out what is it about this map that doesn’t like my Intel i5. At first I thought it was just not multi-thread supported and only using one core, but after a few more CPU tests, in game (during actual gameplay, not a menu) it was using all 4 cores just fine.

    Can anyone here shed a little insight as to why Coldfront, and only Coldfront runs so terribly on my machine (and not my friend’s)?


Log in to reply