WEAPON: Sling returns error when equip event ends.



  • After playing around a little with hordetown and a dedicated server i have managed to get it how i want after almost an entire 24 hours of problems, mistakes and surplus tears.
    There is only 1 thing though. It is Bizarre. As soon as i equip, or more specifically “finish equipping” a purchased Sling, it becomes a useless sort of “missing” weapon slot.
    it cannot be equipped, but it is not dropped either.
    I have edited the TO2-HordeTown map ( I simply increased the money per kill, nothing more at all. )
    I saved it, renamed it to have a suffix “1” and cooked the package.
    after cooking it i took the UDK files it provides as a result and pasted them into both the ChivalryMedievalWarfare and Chivalry-ded-server’s

    UDKGame\CookedPC{Server}\AOC\Levels
    Directory
    I then verified the local game content of both the Ded server and the full game too.

    I confirmed that the issue does not occur if i “create match” -> “Other” -> “HordeTown” -> NO MODS

    the error that is occuring (full Log attached) shows:
    [0120.91] Warning: GetSocketWorldLocationAndRotation : Could not find socket ‘SightLocation’ in ‘WEP_sling’
    [0122.96] Warning: GetSocketWorldLocationAndRotation : Could not find socket ‘SightLocation’ in ‘WEP_sling’
    [0125.04] Warning: GetSocketWorldLocationAndRotation : Could not find socket ‘SightLocation’ in ‘WEP_sling’
    [0186.13] Warning: GetSocketWorldLocationAndRotation : Could not find socket ‘SightLocation’ in ‘WEP_sling’
    [0189.18] Warning: GetSocketWorldLocationAndRotation : Could not find socket ‘SightLocation’ in ‘WEP_sling’
    [0195.08] Warning: GetSocketWorldLocationAndRotation : Could not find socket ‘SightLocation’ in ‘WEP_sling’

    Given that all i modified in HordeTown, was a property of “customScoring”, this logically has contributed nought to the issue, the cause must be elsewhere.

    I am very willing to fix this myself, i am fairly knowledgable in UE (mainly UnrealTournament99GOTYE though :$ ) and i work in IT as a second line analyst, so i know i am not being dense.

    Already tried to make everything matching in terms of files, so only what needs to be different, is.

    I am not sure if the Ded server and Client are currently not of a matching version, i seem to recall (IMMEDIATELY AFTER LOCAL FILE VALIDATION) different build numbers on each, or even if that matterss.

    This could very well be a local GPU issue or something similar. but i am currently unable to test on another device, and changing resolution/ dissplay settings (i’m nearly always on lowest anyway) mhas made a difference.

    Always just as it is almost in your hand it vanishes and you are left with just a secondary. If you buy a primary weapon, it does return the slot (you may have to buy two times one for the weapon slot, one for the weapon as a result of the error)

    Appreciate any feedback you provide and hope to hear a suggestion or two. Thank you in advance.

    //=======As i wrote this, an unprovoked screw fell out of the sorry melting case of a laptop i have=======//


Log in to reply