Scroll wheel left/right brings up a console prompt?



  • Hi, Just a noob question,

    When I’m playing chivalry if I happen to inadvertently press left or right on the scroll wheel of my mouse (which happens a fair amount during my play) it brings up a prompt at the bottom of the screen similar to the console. This instantly kills my footwork and keyboard input as it all just types at the prompt - and tends to get me killed.

    I can’t seem to find anywhere in the control configuration to turn it off or unbind left and right scroll wheel buttons.

    how do I stop left and right on the scroll wheel from bringing up a prompt?



  • What is the make/model of your mouse?



  • @Caliko:

    What is the make/model of your mouse?

    Logitech cordless desktop MX3000 mouse



  • You could try to rebind some random key with your left/right scroll wheel buttons to get the key codes.
    Then search for them in the config and unbind them.

    My mouse’s scroll wheel has those too, but I don’t have that problem.

    (Shouldn’t this be in Techincal Support?)





  • By default the mini-console at the bottom of the screen is accessed with the Scroll Lock key. I assume this is what the mousewheel left/right is doing behind the scenes (e.g. scroll lock + left or whatever). I dunno. It’s one of those entirely outdated and archaic keyboard features like pause/break so it’s weird.

    You can change this in your UDKInput.ini (located in your _Documents\My Games\Chivalry MW\UDKGame\Config_ folder):

    [Engine.Console]
    ConsoleKey=Tilde
    TypeKey=ScrollLock
    ```Find the Engine.Console section and change _ScrollLock_ to something else. _SemiColon_ or something (the names of special characters are spelled out like that for the purpose of these configs).


  • @MuzMuzMuz:

    Logitech cordless desktop MX3000 mouse

    There is a Logitech program called SetPoint from the official Logitech website for your mouse.

    http://support.logitech.com/product/cordless-desktop-mx-3000-laser#download

    You could download that application and try unbinding the left/right scroll wheel function. If you can’t unbind or set them to ‘nothing’ set them to a key that has no effect on your game play. (NOTE: You might have to keep the application running in the background for the changes to remain effective.)

    If that doesn’t work, alternatively you could try to edit your registry files which also might work. Assuming you are on windows.

    1. Open Run or Search.
    2. Type in ‘regedit’ (Registry Editor)
    3. Follow this folder path under Registry Editor. HKEY_CURRENT_USER > Control Panel > Desktop
    4. In the Desktop folder of Registry Editor you should find ‘WheelScrollChars’, double click this and set the value to 0.



  • Thanks Caliko, INerevar, Loin & Dudeface for your replies,

    • Dudeface’s advice fixed it for me,

    Although, I edited the settings below in:
    program files (x86)\Steam\steamapps\Common\chivalrymedievalwarfare\Engine\Config\BaseGame.ini

    @dudeface:

    By default the mini-console at the bottom of the screen is accessed with the Scroll Lock key. I assume this is what the mousewheel left/right is doing behind the scenes (e.g. scroll lock + left or whatever). I dunno. It’s one of those entirely outdated and archaic keyboard features like pause/break so it’s weird.

    You can change this in your UDKInput.ini (located in your _Documents\My Games\Chivalry MW\UDKGame\Config_ folder):

    [Engine.Console]
    ConsoleKey=Tilde
    TypeKey=ScrollLock
    ```Find the Engine.Console section and change _ScrollLock_ to something else. _SemiColon_ or something (the names of special characters are spelled out like that for the purpose of these configs).