Game freezes for a split second upon killing a player



  • Something that I’ve noticed lately is that my game occasionally freezes whenever I kill somebody. The freeze only lasts for a split second, but it definitely can be enough to throw off a potential 1v2 situation or a swift arrow dodge.

    Anybody else have a similar problem and/or a solution?

    My graphics are all on lowest settings with Dynamic Lights turned on. Enabling/disabling this feature does not seem to fix this.

    I have tried enabling/disabling ragdolls and decals, but this doesn’t seem to fix the problem either.

    Turning off console damage does not seem to fix this.

    The problem seems to persist more frequently on servers with higher ping, although my observations of this are not yet extensive.



  • Does this only happen when killing players like title says, or does this actually occur offline when killing bots as well?



  • Beware the packet vans. Why I recently even reported one rank 60 plus troll van. By some fluke his ping just as I am about
    to engage or hit back jumps up to 100 briefly from 70. Add that to his other exploits with fov 150 dancing instant kill
    rubbish. I noted he had added that packet drop script to his already nasty inventory of exploits. Despite reporting
    him 5 times now over the months. It amazes me the lengths some rank 60 plus vans go to simply to cheat farm kill.

    Just beware and also consider the player you thought at that time, does he name re occur often in a combat freeze?



  • if you run the command “stat unit” (in the console) do you see any major changes when the lag occurs?



  • @MonkeyFiend:

    if you run the command “stat unit” (in the console) do you see any major changes when the lag occurs?

    I’ll try that later today. So far, however, after restarting my computer completely (shutdown>rest>boot, rather than “restart”), I haven’t noticed the problem reoccur yet. I have not played very much today, however.

    I’ll update when I find anything of note.



  • I think I’ve seen Spook post a video about this, maybe he fixed it somehow.

    Edit: here you go.
    @Kim:

    https://www.youtube.com/watch?v=pv0x0Sgb7QM&feature=youtu.be

    This is what’s been happening to me a lot since the last mini patch



  • What’s your CPU? Maybe try setting all sound options to the minimum



  • @Alphonse:

    What’s your CPU? Maybe try setting all sound options to the minimum

    This is actually a pretty good tip; I found it reduced the CPU load somewhat and gave me an extra ~3-5fps on my old system (in addition to running everything else at min).

    I would also suggest turning off Dynamic Lights to gain a few more FPS. You’ll find that Vignette is probably still on; you have to disable it in the .ini to keep it turned off or it keeps turning back on at the beginning of every match;
    Find the UDKSettings.ini file under <user>\Libraries\Documents\My Games\ChivalryMedievalWarfare\UDKGame\Config</user> and change bEnableVignette=True to False, then Save the file.



  • @Reithur:

    This is actually a pretty good tip; I found it reduced the CPU load somewhat and gave me an extra ~3-5fps on my old system (in addition to running everything else at min).

    I would also suggest turning off Dynamic Lights to gain a few more FPS. You’ll find that Vignette is probably still on; you have to disable it in the .ini to keep it turned off or it keeps turning back on at the beginning of every match;
    Find the UDKSettings.ini file under <user>\Libraries\Documents\My Games\ChivalryMedievalWarfare\UDKGame\Config</user> and change bEnableVignette=True to False, then Save the file.

    Just to add to that; I have found that disabling motion bluring while playing on a laptop helps a lot too, might be something worth trying.


Log in to reply