Huge fps drops



  • I know this game is poorly optimized but i get 10-20 fps on citadel, battlegrounds and belmez maps with this system;
    win 8 64 bit
    intel i7 4960x 6 core 3.60 ghz
    evga gtx 970 4gb
    8 gb ram

    i still get very low fps with lowest settings. i need help.

    edit: also game crashes often in loading screen.



  • Does you get these kinds of fps in the other maps & other games?
    Maybe try to check the game cache
    Also check what your system resources are going - like is cpu/ram maxed out when have these fps
    How are your temps?


  • Mod

    @Keykrion:

    I know this game is poorly optimized but i get 10-20 fps on citadel, battlegrounds and belmez maps with this system;
    win 8 64 bit
    intel i7 4960x 6 core 3.60 ghz
    evga gtx 970 4gb
    8 gb ram

    i still get very low fps with lowest settings. i need help.

    edit: also game crashes often in loading screen.

    That doesn’t sound right at all. Any idea if your system has an integrated GPU as well? It may be automatically selecting that instead of your nvidia card. I had this issue on my laptop and I had to manually go into the nvidia control panel and choose for chivalry to be ran using my nvidia 555m.



  • Do you have the GeForce Experience? It can optimize a lot of games for you and update drivers to enhance gameplay.

    Check it out for yourself :) Link > : http://www.geforce.com/geforce-experience



  • Might also be worth running a free 3rd party benchmark such as 3dmark - at this point you’ll need to narrow it down to an issue with the system or an issue with chivalry.

    Out of curiosity can you post the output from running dxdiag?



  • Dont install the GeForce Experience, It is bloatware and has no mods for Chiv.

    Get on EVGA’s site and get the latest drivers http://www.evga.com/support/download/default.aspx
    lso pic up Evga PrecisionX http://www.evga.com/precision/.
    When you do your driver update, do a clean install from save mode using driver sweeper. http://www.guru3d.com/content-page/guru3d-driver-sweeper.html

    Then delete your UDKEngine.ini and your UDKsystemsettings.ini and then verify the integrity of your game cache and start the game going back to default graphic settings.
    In the graphics menu in game, turn off vsync and turn down all AntiAliasing as well as depth of field, light beams,
    In the Nvidia settings also turn off Vsync and set it to render 1 frame ahead

    See if that helps at all


Log in to reply