Better gpu, less fps?wtf?



  • Chivalry is pretty messed up. Sometimes I get really bad performance no matter my settings and I have to restart the game a few times before i can play. My settings keeps resetting also. I’m able to play this game on highest settings without it drops below 62fps but those 62fps doesn’t even feel smooth. To get this game to a playable lvl I have to put everything on low and unlock fps to 120.

    I put my only hope on chiv2. Hopefully UE4 and DX12 will be used.



  • Your help is much appreciated, sadly rolling back my gfx driver did not change anything.



  • So apparently it is not the sound. Changing ANY settings in the video settings increases my fps from 22 to 62 in the menu. When my fps are at 62 in the menu and I open the server browser my fps drop down to 22 again. Scrolling in the server browser further decreases my fps to as low as 15 fps. The faster I scroll the lower the fps. Does anyone have any idea how to fix this bug or what could be causing it? Want to play chiv :(



  • Ok so i tried A LOT of stuff by now, if anyone has the same problem, i got a bandaid fix: do this: http://pastebin.com/T5iAmE9C . Makes chiv look really bad but atleast I get somewhat stable (capped) 62 fps this way. (But honestly, what do i expect with a 960 GTX and a 3 year old game? ;P). Opening the configuration still drops my fps to 20 instantly. Chiv is the only game which performs way better ingame than in the settings :D Never had that one before… Interestingly, my game also no longer freezes during mapchange.



  • On my latest laptop I have a Nvidia geforce gtx 870M and a built in integrated card.

    But chivalry does not use the graphics card by default - I had to go into the settings, specifically select the cmw.exe and tell the system to use that specific card. If you get 21 fps it cant be using it.



  • I dont have an onboard gfx card. I assume it is some kind of bug/driver/compatibility issue, because it does not make ANY sense that a better GPU gives worse performance (only in this game) on an otherwise identical pc.

    Just look at the screenshots I have attached, taken from the very same spot. 60 fps without anything (which is way too low, but atleast its somewhat playable) and the other screenshot: 20 fps, simply because the configuration tab is open…. Fun fact: just pressing ESC does not do anything to my fps, but the instant I click on configuration my fps drops… almost like the game is trying to annoy me -.-’



  • @Falc:

    I dont have an onboard gfx card. I assume it is some kind of bug/driver/compatibility issue, because it does not make ANY sense that a better GPU gives worse performance (only in this game) on an otherwise identical pc.

    Just look at the screenshots I have attached, taken from the very same spot. 60 fps without anything (which is way too low, but atleast its somewhat playable) and the other screenshot: 20 fps, simply because the configuration tab is open…. Fun fact: just pressing ESC does not do anything to my fps, but the instant I click on configuration my fps drops… almost like the game is trying to annoy me -.-’

    Ahh but you do have onboard graphics. Your CPU. It’s an Intel i5 2500k. Which means you have Intel HD 3000 integrated graphics which is capable of running the game. “Running” used in its broadest possible meaning of course but your symptoms reflect it using that. As with a GTX 960 you should be able to max the game no questions. I mean it trying to use the integrated graphics would explain everything.

    Chivalry does have the strange tendency to try and use the integrated graphics instead. No idea why. Does it with AMD too.

    You can disable it in the Nvidia control panel or in the Bios. Don’t ask me how I don’t know past that. Google probably knows though.



  • hm thanks for the idea, I will look into that….I discarded the idea, that chiv is doing any such nonsense, because my nvidia control panel doesn’t even let me switch between GPU and CPU for anything except PhysX. Are you sure you can do that in the Nvidia control panel? I found no such option… Also my GPU is at a 100% performance during chiv, which makes me confident that the poor thing is doing its best at whatever chiv is throwing at it.

    Anyway thanks for the idea, right now I am grateful for any new idea how could fix this…



  • @Falc:

    hm thanks for the idea, I will look into that….I discarded the idea, that chiv is doing any such nonsense, because my nvidia control panel doesn’t even let me switch between GPU and CPU for anything except PhysX. Are you sure you can do that in the Nvidia control panel? I found no such option… Also my GPU is at a 100% performance during chiv, which makes me confident that the poor thing is doing its best at whatever chiv is throwing at it.

    Anyway thanks for the idea, right now I am grateful for any new idea how could fix this…

    This option is only available on laptops and is not included in pc drivers since pcs always use PCI card if installed



  • @burza:

    This option is only available on laptops and is not included in pc drivers since pcs always use PCI card if installed

    This is from my desktop PC: http://i.imgur.com/efBy3qA.png


Log in to reply