Chivalry (Medieval & Deadliest) won't launch.



  • Hi! I recently bought Chivalry (both DLC and main game) and I encountered something that, after searching, seems fairly common. However, even after trying all recommended solutions, the games still refuse to launch. I have tried all the solutions provided on this forum as well as a few on Steam Discussions. I have attached the files requested in the [READ FIRST] Support Forum info post but unfortunately my post won’t allow me to attach my launch.log file. Apologies if I’m missing something, I’m quite new to this :).

    Anywho, as said, I am able to select Chivalry in my steam library and after a few seconds, it asks me whether I want to load Medieval, Deadliest Warrior, Medieval 32-bit, Deadliest Warriror 32-bit or Launcher. Regardless of which one I choose, the game will not launch. For the first four, absolutely nothing happens but selecting Launcher opens the launcher but if I then try to open the game from there, the launcher closes and the game still doesn’t launch.

    Obviously I searched for solutions to this and I thought it might be helpful to note down which solutions I had tried. The more info the better, you know?

    1. Go to Steam\SteamApps\common\chivalrymedievalwarfare\commonredist\vcredist\2010 and run the application. Afterwards go to “…\DirectX\2010” and run the “DXSETUP” application.

    See at bottom.

    2. Verify game cache

    Done, no change.

    3. Go to properties then set launch options as -resx=1920 -resy=1080

    Done, no change.

    4. Run UDK.exe as administator

    See at bottom.

    5. Run UDK.exe in compatibility mode Windows XP S3

    See at bottom.

    6. Try to reinstall Chivalry

    Done twice, no change.

    7. Restart Steam

    Done multiple times, no change.

    8. Update graphic drivers and make sure Direct X is up to date.

    Done, no change.

    9. Close any programs you have running including firewall, antivirus programmes etc.

    Done, no change.

    10. Nvidia control panel.

    N/A

    11. Running SLI or Crossfire could cause problems. Disable one video card and try the game

    I don’t think I use either.

    12. Go to My Documents\My Games\ and delete the CMW folder and then verify cache.

    Done multiple times, no change.

    12. Run the game from the UDK.exe file itself

    See below.

    You might have noticed for a few of these solutions I said ‘See below’ and that’s because whilst searching for solutions, I noticed something about my computer. While it isn’t specific to Chivalry, it still may be a reason behind the game not loading. If I go to Steam\SteamApps\Common I’m confronted by a single folder called ‘Team Fortress’ (I’m sure you’ve figured out that means I played TF2 in the past). This may be a reason behind my problem since it means I lack certain .exe files e.g. UDK.EXE.

    Thanks in advance for any help you give. Sorry if I missed anything.


  • Global Moderator

    Seems like you did a nice google search and tried most of the solutions out there, which is nice. Sad to see that non of these worked.

    Looks like you’re runing on a laptop, looking at dxdiag? Your specs seem fine for Chivalry however.

    Regarding the missing .exe files; they shouldnt be missing if you verified your steam cache, which you did.

    I’ve asked some other admins and here’s the result. Cant guarantee anything unfortunately.
    _MsKitty: "he should maybe try reinstalling steam completely by doing a steamflush or just delete everything in his steam folder except steam.exe, steamapps and userdata. https://support.steampowered.com/kb_article.php?ref=3134-TIAL-4638 "

    _EDIT: The option above serves the purpose that you do not need to re-download steam or any of the games. You just need to launch the steam.exe after completing all the steps and steam should reinstall itsself. Your games should not be lost!