2 Issues driving me nuts….



  • Ok I have two issues that have been driving me crazy for will over a year or more and I have not been able to resolve or find a fix. This may also read like a book.

    The first issue is pretty straight forward and it is about auto ripostes and an occasional auto attack. So what is happening is that about 1 out of ten(ish) parries will have an unintended riposte when no button was pressed and it typically will happen in the most inopportune moments (of course). It is pretty random when it happens and I have been unable to recreate the conditions when it happens. I can riposte when I want but it is these random auto ripostes that are driving me nuts, potentially killing teammates and have me running out of stamina.

    In addition, I can also get an occasional random weapon attack when no button is pressed. Now this part I think I may have figured it out. Sometimes if I do not have my mouse wheel locked, the wheel will rotate and initiate an attack. Other times it appears that if I slightly lift my mouse off the deck and smack it back down, an attack can happen. So maybe that is what is happening with the random auto ripostes. but most of the time lifting the mouse off the deck did not happen. So with the random auto riposte, I don’t have a clue what is causing it. Additionally I use a Nostromo N52 game pad and always have. I also do not use default keybinds either as that may be the cause.

    –------------------------------------------------------------------

    The second issue is the main one that is driving me insane. So let me preface this with my Computer stats: Win7 Ultimate(64), i7-4770 (over clocked to 4300), GTX980 - main monitor, GTX560ti - second monitor, 32 GB of DDR3 Ram, Asrock Z87 Extreme4 - mobo, Asus VG248QE 144hz - 120fps (on most maps), Logitech G502 gaming mouse, Razor Nostromo N52 Game pad, and the kicker, Goggle fiber internet access - 1 GB up 1 GB down. I also have over 4000 hours in the game so don’t waste our time with the “get good” comments.

    As you can see it is a pretty fast system with super fast internet. For reference: for the first year+ when I first started playing Chiv, it was on a potato PC with shitty internet and my average ping then was 90-120 ping and I did much better. So here is the problem: On most all Central servers I have 16-20 ping on East and West coast servers 50-75 ping and with zero packet loss, always and very stable ping. So typically when I play and my ping is around 20 or lower, almost every other player has a ping 3x higher than mine. While this maybe great for some online games it is horrible for Chiv due to it’s lag compensation and client side hit detection that tends to favor the higher ping players. So if you normally play with 60-80 ping, for you it would be like playing someone with 120-160 ping or higher.

    So I really struggle with hit detection and lag attacks going through my parries and hits way out of range as players morph in and out of range. I also have a high tendency to ghost stab and ghost swinging through the enemy where my accuracy can go as low as 40% at the end of the game. Don’t get me wrong, I still end up in the top 5 typically, due to my high output and objective whoring, but at the end of a map the KDR is horrific as well as the hit accuracy. Where I really notice the difference and it becomes an issue is when the ping gap between me and the enemy is 50-60 ping points (me 20, them 60-80) which is pretty average to have players 2x - 3x pings higher than mine. I know that everyone gets the occasional ghost stab or swing but this is beyond occasional. In heavy combat it can be almost every swing is a ghost swing or a hit through my parry.

    So here are the things I have tried:

    Tweaking my network card settings
    TCP Optimizer - http://www.speedguide.net/downloads.php
    HitReg Fix - https://www.youtube.com/watch?v=gvOHx2lJXIQ - download is in the description of the video
    Tried tweaking the network game settings

    Nothing has seemed to resolve the ghosting and hit detection. I think much of it may have to do with the fiber upload speed being so great that players get a better more accurate location for me from the server while I am waiting for the server to download their actual position and or correction. Typical cable internet is 7MB down and only 2 MB up. I have 1 GB up/down which is radically different.

    So needless to say, this is and has been driving me insane for almost 2 years now since I got Google fiber. I am at my wits end to get this hit detection fixed or at least improved. Any real suggestions would be greatly appreciated. Thanks for taking the time to read all of this and really an looking for a different point of view on these issues.
    Thanks |ĶأĻă|Ʀε†s†rumpMcBøøgerballs



  • Can you buy Google Fiber for everyone else? Win-win. We get good internet, you don’t have to deal with ghost hits.



  • I also have the issue with the riposes but i convinced myself that i pressed the button with muscle memory.
    But then again sometimes i can make a ripose on getting hit.

    The ghost hits are much more complicated to troubleshoot. Are you talking about close misses or the classical ghost attack which is more like an illusionary attack?

    To my knowlegde classic ghost attack can be provoked by doing certain combos that may or may not have to start with an alt attack. It has been some time since i have seen someone do them consitently.
    But i am pretty sure that they are unrelated to connection.

    If you are having problems with missing but its not a ghost attack then:

    -if you play in first person and if you are standing on an elevation your 1rst person weapon and the the 3rd person weapon dont line up

    • are you maybe using weapons that have their tracer butchered ?

    can you provide some video material?



  • @Retsnom:

    In addition, I can also get an occasional random weapon attack when no button is pressed. Now this part I think I may have figured it out. Sometimes if I do not have my mouse wheel locked, the wheel will rotate and initiate an attack. Other times it appears that if I slightly lift my mouse off the deck and smack it back down, an attack can happen. So maybe that is what is happening with the random auto ripostes. but most of the time lifting the mouse off the deck did not happen. So with the random auto riposte, I don’t have a clue what is causing it. Additionally I use a Nostromo N52 game pad and always have. I also do not use default keybinds either as that may be the cause.

    I’m pretty sure it’s the game.

    It never happened to me in other applications than Chivalry and moreover I bought a new mouse but the problem remained.
    Best wtf moment was when I’d won a fight and reached for a drink with my character just staying there, idling.
    Then out of the sudden my character started an overhead, while my hands were off the keyboard & mouse.
    Had it already happen several times while my hand wasn’t even laying on my mouse.