Chivalry Launches To Black Screen



  • When I try to launch Chivalry: Medieval Warfare or Chivalry: Deadliest Warrior, it boots to this screen after the splash screen and the audio stutters.
    Specs: i5 4690k 3.5 ghz
    Zotac GTX 980
    8GB RAM
    Windows 10 Home 64-bit
    0_1459307581249_Launch.log
    0_1459307147333_Launch.log !
    0_1459307705350_blackscreen.png
    0_1459307722299_DxDiag.txt (/uploads/files/1459307295478-dxdiag.txt) 1459307252133-blackscreen.png)



  • Isn’t that out of date dx9? I recall a long while back also using the minus dx 9 switch on a command line in the steam chivalry exe.
    DX11 could be what you need. What is your nvidia driver 3.64?



  • @loin My nvidia driver version’s 364.72. I don’t think I need to update directx because I’ve tried running the setup tool and it says a newer version is already installed.



  • That might be the case but your blank screenie shows DX9



  • chiv runs awful in dx11. you will get about 5 FPS in the menus, so don’t do that.



  • Well you must validate it all , even reinstall . A system like yours should not have that problem. Did you actually allow windows
    to update your video drivers before installing the Nvidia ones? I did report a bug before with allowing windows 10 to update
    any drivers online prior to finding the better drivers. If I remember after I got into Chivalry suddenly I was back at the desktop
    with no way into Chivalry even via task swopping. Then any right click on properties of shortcuts brought back desktop
    even disabling the explore applet from working correctly.



  • @loin I’ve tried validating and reinstalling Chivalry multiple times. What do you mean when you ask if I’ve allowed windows to update my video drivers? Searching the internet for new drivers from Device Manager? If it helps, Chivalry was working fine when I was on Windows 8.1, but I haven’t been able to play ever since I upgraded to Windows 10.



  • I have many pc’s here from xp upto win 10. I noted on one of my computers with win 7 the same screen as yours just yesterday with
    the same windowed dx9. What it did was reset my video settings, note it was just after I validated my chivalry files via steam that
    my video settings were reset as was my console key lost. This does look like a nviidia driver issue to me. Acc to your logs
    it couldn’t load sounds at an early stage. When you upgraded to W10 did you update nvidia drivers or W10 do it first?
    I would either suggest going back to w8 or reinstalling Nvidia a driver below 3.6 but completely remove prior drivers
    as in do a Fresh install of any Nvidia driver below 3.6

    do note I was on a 4790 system with gtx980ti yesterday so I always have a computer similiar to any user here or access to one
    regardless of what operating system or specs they have, I have it here due to a flat full of computers .



  • @loin Well this is embarrassing; I uninstalled my Nvidia driver with DDU and did a clean reinstall, and now it’s working. Looked like a driver issue to me at first, but I thought just updating my drivers would fix it. Guess not. Thanks for the help though.



  • @Cyrillic good stuff tbh at least you managed to sort that out. I mostly build pc’s every day or swop between various ones with
    any version of windows to hand. Free ales on Cyrillic at the tavern in the village if we meet.


Log in to reply