Game won't launch on OSX (stuck on blue screen with keyboard commands)



  • Re: [Mac OS X] Game hangs indefinitely on initial loading screen on Retina Macbook

    Hello,

    It looks like a lot of users are having this issue but I cannot find a way to solve it.
    I just bought the game but just can’t go further than the keyboard commands screen with the sword spinning (when the game actually wants to launch) I have to Force Quit because the game seems stuck and marked as (not responding)

    imac 27inch late 2012
    i7 3.4Ghz 32Gb RAM DDR3
    NVIDIA GeForce GTX 675MX 1024 MB
    El Capitan 10.11.5

    Thanks for your help!



  • Anyone…?



  • @kevkey Can you please attach your crash logs?

    Chivalry Medieval Warfare\UDKGame\Logs



  • @Reithur When I browse local files I don’t see any Logs folder. I find a “UDKGAME” folder when I right click Chivalry icon and select “Show package content” but no “Logs” folder there either.
    Can you please tell me where I can find this “Logs” folder on OSX?



  • This post is deleted!


  • THANKS A LOT FOR YOUR HELP…! LOVE THE SUPPORT AND THIS GAME I CAN’T PLAY…!



  • @kevkey Sorry for the delay; I’ve been intermittently trying to get answers.

    We are unable to reproduce this issue on our end and we’re concerned that it’s other programs running that are affecting the game’s ability to run.

    I’ll try to find a solution for you. In the meantime, can you please try turning off all of the apps running in the background and run only Steam with Chivalry?



  • @Reithur Just tried that with no success on both “Chivalry: Medieval Warfare” and “Past testing for Chivalry” in Steam.
    When I plug another screen via thunderbolt (HD TV) I actually manage to see the keyboard commands screen with the sword spinning but it stays stuck there.
    But right now I just tried on iMac without the other screen plugged. I don’t think I ever saw the keyboard commands screen with the sword spinning without plugging the external screen to the iMac. I can only hear the first two sounds of the game but nothing else happens and I don’t actually see anything on the screen, except the Chivalry icon in the dock.
    I tried to download the Nvidia Web Driver as well and tried both with “OSX default graphic drivers” and “NVIDIA Web Driver”.



  • @kevkey can you please try using starup properties to force your native resolution? Go to your Chivalry properties from your Steam Library list > General > Set Launch Options

    Example to force 1920x1080
    -resx=1920 -resy=1080



  • @Reithur No success unfortunately :(