[AMD] Game Locks up entire PC (display driver crash?)



  • I can’t play more than 30 minutes before my game totally locks up my entire computer, which i have to turn off manually in that case. Its a shame because its a really fun game.
    I have an AMD 7870, Windows 7, and I did update my drivers and set framerate to uncapped.


  • Developer

    Glad you’re enjoying it Zombo. It might be worth trying to turn down shadow and effects quality to low if you haven’t done so already.



  • I was playing on all low settings (forgive me) for that high fps advantage :)



  • @zombojoe

    1. Go to Start > Run, or hit Windows Key +R.
    2. Type “dxdiag” into Run and press Enter.
    3. If you are prompted to check whether or not your drivers are digitally signed, you can select “No”.
    4. On the main page of the DxDiag that opens, click “Save All Information”.
    5. Save this to a text document. You can drag this text file into a forum post.


  • [0_1477076163579_DxDiag.txt](Uploading 100%)

    Says I dont have privileges to drag?
    I put it on pastebin
    http://pastebin.com/7Xxuxevt

    I also have a logfile from mirage

    [1020/161518:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/161518:WARNING:pref_notifier_impl.cc(27)] pref observer found at shutdown proxy
    [1020/161957:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/161957:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/162034:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/164206:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/164206:WARNING:raw_channel_win.cc(473)] WriteFile: The pipe is being closed. (0xE8)
    [1020/164206:WARNING:channel.cc(549)] Failed to send message to ack remove remote endpoint (local ID 2147483648, remote ID 2)
    [1020/164206:WARNING:channel.cc(315)] RawChannel write error
    [1020/164206:WARNING:pref_notifier_impl.cc(27)] pref observer found at shutdown proxy
    [1020/165021:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/185323:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/185323:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/201534:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/201534:WARNING:raw_channel_win.cc(473)] WriteFile: The pipe is being closed. (0xE8)
    [1020/201534:WARNING:proxy_message_pipe_endpoint.cc(50)] Failed to write enqueue message to channel
    [1020/201534:WARNING:proxy_message_pipe_endpoint.cc(50)] Failed to write enqueue message to channel
    [1020/201534:WARNING:proxy_message_pipe_endpoint.cc(50)] Failed to write enqueue message to channel
    [1020/201534:WARNING:pref_notifier_impl.cc(27)] pref observer found at shutdown proxy
    [1020/203652:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/203652:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/205545:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/205545:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/220321:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/220321:WARNING:pref_notifier_impl.cc(27)] pref observer found at shutdown proxy
    [1020/220321:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/220401:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/220401:WARNING:pref_notifier_impl.cc(27)] pref observer found at shutdown proxy
    [1020/221251:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
    [1020/221251:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty



  • @zombojoe Filesize could be too large, but thanks for the link & info.



  • Yeah I am having the same issue as well. I’ll set more graphics down as it is an older card but it runs smooth regardless. I have more or less the same setup as above. Win7 64 - 7800 series Radeon HD. I have today’s release on drivers but was getting the crash with the previous driver release as well.



  • I have the same issue on a r9 270x win 8.1 latest drivers.



  • So any suggested solutions here? The display driver is definitely crashing.



  • No definite fix yet as I know. Tis alpha though, I want to assume it’s a compatibility issue or could be related to UE4 and it’s new engine features. This is the first UE4 game ive played so I have nothing to compare to. I might rollback a release as it seemed to be a little more stable. I’m getting this crash almost every other match now. I will be testing this thoroughly tonight before the test run is over. I will cycle back driver releases and make other power/GPU changes and post here if I have success.

    We have 2GB cards and I’m assuming it’s maxing out the GPU instead of adjusting in the game to save crash. First thing to help as a Dev said turn settings as low as you can. Particles and postprocessing have a large pull on the GPU. I am testing power settings as well to rule out overload and I know for sure it’s not a heat issue. You can monitor your gpu with a handy program GPU-Z to watch for the cause of crash.
    Also just search for the error and follow some other fixes that work for other modern games (at your own risk!)

    Also in the GPU manager see if you can override the control and have it throttle down if it needs to. This might work as a good temp fix so we can just keep playing. Will post anything I find here!



  • So you think its hitting the hard cap for VRAM?

    I believe by default UE4 downscales textures if its going to exceed it. Maybe that’s been disabled.



  • I played a bot match and messed around with console commands, then I started playing online, I haven’t crashed in over an hour now.
    Heres the history of console commands I used, I suspect HistoryBuffer=r.Streaming.PoolSize 256 fixed it.
    [/Script/TBL.TBLConsole]
    HistoryBuffer=setbind ThumbMouseButton2 stab
    HistoryBuffer=stat streaming
    HistoryBuffer=open cp_Courtyard
    HistoryBuffer=stat streaming
    HistoryBuffer=stat streaming
    HistoryBuffer=stat streamingdetails
    HistoryBuffer=stat unit
    HistoryBuffer=stat net
    HistoryBuffer=stat STREAMING
    HistoryBuffer=r.Streaming.PoolSize
    HistoryBuffer=r.Streaming.PoolSize
    HistoryBuffer=r.Streaming.PoolSize 256
    HistoryBuffer=r.MotionBlur.Max 0
    HistoryBuffer=r.AmbientOcclusionLevels 0
    HistoryBuffer=r.OneFrameThreadLag false
    HistoryBuffer=r.OneFrameThreadLag true
    HistoryBuffer=r.OneFrameThreadLag false
    HistoryBuffer=addbots 20



  • Well I spoke too soon, still, I lasted 2 hours without crashing :P



  • Interesting maybe it helped a bit. I went for almost an hour before crash after some adjustments. If you don’t click ok on the error dialogue post crash it seems to help exit and reset driver quicker. I’m still logging my progress. Rolling back driver release didn’t fix it but it’s crashing less often.



  • Same trouble. Freezing and crushing videodrivers



  • Okay gents after a bit of research I had the game running smoothly at nearly max graphics.

    Kept crashing after driver changes and rollbacks.
    Crashed still after forcing help from the control center. No overclocking.

    This is from the technical support thread:

    AMD issues

    If you have an AMD Video Card, please update to the latest AMD drivers and/or set Framerate Smoothing to Uncapped in the game’s Settings > Video page
    Disable Raptr (also called AMD Gaming Evolved) in your AMD/Radeon settings

    " set Framerate Smoothing to Uncapped in the game’s Settings > Video page" - This solved the issue. I don’t run Raptr (AMD GE) and forcing smoothing from CC did not help the issue. After I set it to uncapped and cleared forced assistance from CC I could max out graphics and get ok framerate but high settings ran smoothly. It was late into the phase so I couldn’t test longevity but I got at least an hour with no crashes.

    Here’s the thread:
    http://forums.tornbanner.com/topic/24869/before-posting-in-technical-support



  • @ArtyPendragon I’m glad you were able to get it running eventually. Sounds like you’ll be ready for round 3!

    On a general update note, we’re still learning more about our AMD troubles and figuring out how to resolve them.
    Uncapping framerate in the game’s settings helps with low FPS & hitching.
    Updating to latest drivers and disabling Raptr helps reduce driver crashes.



  • Yes sir. Thanks for getting us AMD users back on track. I just wish I would have skimmed the technical posts earlier. Can’t wait to play again!



  • I can confirm the crash still happens on the latest build.



  • @zombojoe thanks for keeping us updated. Also heard from others that we’re having some cases where CPU usage spikes when you have an AMD card.