Possible Performance Solution for Laptops



  • Don’t know if this is known already, but here was my solution for bad performance: (posted the same on the steam forums)

    I had the problem that this game ran terrible on my laptop. Ok, I have only an Acer Aspire 5750g with 8 GB RAM and a Geforce GT 540m. But I only got 15 to 20 fps on 800x600 and everything on low, while other games run much better.

    The problem was that this game didn’t run on my Geforce 540m. It runs on the internal Intel graphic chip. I opened my nvidia settings and put a new configuration for the udk.exe (which you will find here: C:\Program Files (x86)\Steam\SteamApps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe) and set to run with my Geforce.

    Result: Great performance (30 to 40 fps) with 1366x768 and Details on high with AA, Dynamic shadows and lightning off.

    Don’t know if its the same with ATI Cards…

    TL;DR: Make a configuration in your nvidia settings to run this game (UDK.exe) with your Geforce!. Default was my internal graphic chip!



  • Awesome!
    Could you tell me the specs of your laptop? :)

    Thanks


  • Developer

    The other main issue we’re seeing with laptops is having a low power profile set.

    Open the Control Panel, open Power Options (or just open the start menu and type power options and open it from there), and switch it to High Performance; OR, left-click the battery icon in the system tray and click High Performance. This’ll keep the CPU running at full strength and stop it from scaling down while the game is running. Some desktops are having a similar issue, though in that case it may be a the power setting in the BIOS that’s throttling the CPU rather than the one in Windows.



  • @Magro:

    I opened my nvidia settings and put a new configuration for the udk.exe (which you will find here: C:\Program Files (x86)\Steam\SteamApps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe) and set to run with my Geforce.

    What exactly do you mean by “you set up a new config”? how exactly did you do this, for the less technically minded amongst us



  • @Hishan:

    @Magro:

    I opened my nvidia settings and put a new configuration for the udk.exe (which you will find here: C:\Program Files (x86)\Steam\SteamApps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe) and set to run with my Geforce.

    What exactly do you mean by “you set up a new config”? how exactly did you do this, for the less technically minded amongst us

    Open nVidia Control Panel. Select the Manage 3D Settings in the left side. Select the Program Settings tab in the main view. Click Add and find the UDK.exe from the path above. Then select High-performance NVIDIA processor for step 2 in the main view. Then apply and kill things in game!



  • Thank you for posting this.

    I have that same video card GT540 M.

    Did exactly as you said and now I am running 30-50 FPS in game where before I was like 10-20 FPS.

    Thanks!



  • @ReMixx:

    @Hishan:

    @Magro:

    I opened my nvidia settings and put a new configuration for the udk.exe (which you will find here: C:\Program Files (x86)\Steam\SteamApps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe) and set to run with my Geforce.

    What exactly do you mean by “you set up a new config”? how exactly did you do this, for the less technically minded amongst us

    Open nVidia Control Panel. Select the Manage 3D Settings in the left side. Select the Program Settings tab in the main view. Click Add and find the UDK.exe from the path above. Then select High-performance NVIDIA processor for step 2 in the main view. Then apply and kill things in game!

    Maybe I am just an idiot, but where exactly in the “High-performance NVIDIA processor” in the NVIDIA control panel in Manage 3D settings? I added the UDK.exe but can’t seem to find what you are talking about for step 2 in the main view. Thanks.



  • @obdula:

    Maybe I am just an idiot, but where exactly in the “High-performance NVIDIA processor” in the NVIDIA control panel in Manage 3D settings? I added the UDK.exe but can’t seem to find what you are talking about for step 2 in the main view. Thanks.

    See attached image [attachment=0:30lteqjb]nvidia.jpg[/attachment:30lteqjb]



  • Hmm, my NVIDIA control panel doesn’t have that pull down tab to select the GPU. While yours has 3 steps, mine only has 2. Is my control panel out of date? If so, can you link where to update it?



  • @obdula:

    Hmm, my NVIDIA control panel doesn’t have that pull down tab to select the GPU. While yours has 3 steps, mine only has 2. Is my control panel out of date? If so, can you link where to update it?

    Most likely out of date or your laptop does not support Optimus switching technology…

    http://www.geforce.com/drivers



  • Thanks for posting that, I shall now see If I can find the analogous process for ATI.


Log in to reply