Sudden and permanent FPS drop (120 fps -> ~30 fps) after few minutes of playing game.



  • I did research on this one, but I’m still stumped.
    I have tried at least dozen of recommended solutions (this forum, reddit.com, steam forums).
    I must have edited my UDKEngine.ini file at least hundred times in the last few weeks to no avail.

    Here’s my case:
    I start the game up. “stat FPS” - 120fps. All runs fine. I join the server - still fine. While I’m playing the game all of a sudden without a consistent trigger the fps drops down to 30 - 38 fps and it stays there until I restart the game. It takes a few minutes to happen, but it does eventually happen at some point.

    I tried:

    • turning video features off, and turning them down, none really helped: few of them I would like to mention, FPS smoothing, VSync, ragdolls, vignette, shadows, dynamic lights etc.
    • turning audio settings down
    • making sure nothing else is running while I’m playing the game; I have shutdown almost every other software and windows service possible
    • disabled nvidia HDMI sound drivers
    • tried few versions of nvidia drivers
    • tried running 32-bit version of the CMW executable
    • made sure to disable all power saving features to make sure that CPU runs always at 100%
    • ensured that no part is overheated - monitored temperature of CPU, GPU, MB - they all look reasonable when the game is running - all heatskink have been cleaned (GPU, CPU, MB ones), case is kept clean = no dust inside - airflow is pretty good there
    • check the integirty of the CMW files in Steam
    • used -dx11, -dx10 as a start-up parameter
    • I did try to re-install from scratch. Turned off the cloud. Un-installed CMW. Removed the \Steam\steamapps\common\chivalrymedievalwarfare folder after un-installing. Removed the configs.
      Re-installed the game. Same problem after 5+ minutes of FFA game with fresh install and vanilla configs.

    The last, but not the least are the specs:

    • Windows 10 Pro 64-bit
    • CPU: i5-4690
    • RAM: 32.0 GB (@1600)
    • GPU: nVidia 770GTX
    • Sound: Create SoundBlaster X-Fi Tiatanium
    • PSU: Seasonic 850W


  • @lewekleonek You’re not running Fraps or other recording software?

    If it helps, Chivalry on PC hasn’t changed in about 5 months. Did you make any system updates since end of June?



  • [0_1481148475724_DxDiag.txt](Uploading 100%)
    [0_1481148539710_Launch.log](Uploading 100%)

    I tried to attach DxDiag.txt and Launch.log files, but I got the following error while doing it:
    ERROR
    You do not have enough privileges for this action.



  • @lewekleonek Try putting them onto pastbin.com.



  • @Reithur
    No , I shut down the Xbox App built into Windows 10, I did not install nVidia’s GeForce Experience, so I don’t have their recording tool too.
    And I’m not running FRAPS or any other screen recorder.

    I have been experiencing this problem for while now. I was trying to resolve it on my own trying different things here and there.

    Launch.log - http://pastebin.com/QPSWhtyz
    DxDiag.txt - http://pastebin.com/UKEqVQ3e



  • @lewekleonek Are you experiencing this issue with other games at all?

    Are you overclocking your GPU or CPU?

    …And if I remember correctly, you play a brandi-guard?



  • @Reithur
    I’m not overclocking any of the components.

    Pretty good memory there - I do mostly play brandi-guard, but I kept on switching lately to be more “rounded”. I see the issue regardless of the played class (van, maa, archer, knight).



  • @lewekleonek I thought I recognized the name lol
    And your other games?



  • @Reithur - Now, that I think back, I do remember you.

    BF4 & Natural Selection 2 are just fine, but they use different rendering engine.

    I tested Dishonored and Batman Arkham Asylum - both unreal engine 3. I haven’t see an issue like that with other games. I mean FPS drops from time to time, but then it goes back up.

    I’d really hate to start doing low level debugging…

    BTW: nothing in the Windows Event Viewer I can correlate with the issue; also as you could see my Lanuch.log and DxDiag.txt look pretty usual.



  • @lewekleonek I’ll talk to the rest of the team and see if we can come up with anything.



  • @Reithur Thank you again for looking into it. Let me know if I should check/post anything else in my hardware/software set-up.



  • The network does not seem to be a factor. I was running through the tutorial and the same thing happened.
    Right after that I successfully played BF4 for more than an hour with 95+ fps.



  • Used DDU (Display Driver Uninstaller) to uninstall nvidia drivers in Safe Mode. After reboot I did clean install of 376.19 nvidia drivers.
    The issue still rear its ugly head after few minutes of play time.



  • Looks like my GPU is fine.
    Running “stat unit”, I see that when the fps drop issue occurs the Game time goes up so, it looks like the issue is in the game thread.
    An average Game time during “good” performance is 2 - 6 ms. When the bug occurs the Game time jumps to 30 - 34 ms.
    While Draw time stick around 3.5 - 5 ms and GPU 6 - 8 ms.



  • @lewekleonek have you tried using an unparking app? This may help; https://bitsum.com/parkcontrol/



  • @Reithur
    Thank you for all your suggestions again.
    No luck with Bitsum’s ParkControl (v1.1.8.2) either.
    I’ve applied their “Bitsum Highest Performance” power mode and I still have run into the FPS drop problem.
    I have disabled every power saving mode in my BIOS too.



  • Here’s the kicker: I’ve been playing DW for the last half an hour, because I was able to find a server with some players on it.
    I am running steady 60 FPS with no issues in Deadliest Warrior.

    Edit: Full hour of playing DW at 60 FPS steady, no issues, no glitches. What the heck was in the last patch for Chivalry that did not make it to DW?



  • It appears that lower the anti-aliasing setting makes the problem occur later. MLAA is the worst; FXAA Low seems to get me through about an hour of the game before the hardware lag kicks in.



  • @lewekleonek DW has never received an update; it’s completely separate from CMW.
    Are you opted into any betas on Steam or GeForce?



  • @Reithur
    No betas for Steam, CMW nor for GeForce. I’m currently running GeForce 376.19 WHQL driver without GeForce Experience.

    Also update regarding the anti-aliasing comment above. I think that lower AA settings have no bearing on this issue; it keeps on happening in spite of lowering the AA settings, so I’m back to square one.


Log in to reply
 

Looks like your connection to Torn Banner Forums was lost, please wait while we try to reconnect.