One Friend can't join (Private) Games, Public ones at fine.



  • Hey,

    So myself and three or so of my friends have been playing Chivalry for a while on private servers, as in the Create Game function. We had, iirc, slight joining issues at the start but otherwise were fine, but now another friend has joined in, and for a few months now has been completely incapable of joining, so we’ve always had to find an empty server from the server browser.

    We’ve tried everything suggested on the internet, opening from an IP address, reinstalling, using a different host, letting him host. Nothing has worked. We’re relatively sure his firewall, Norton, is not the issue but not 100%, turning it off was a bit of a struggle and not certain we succeeded. Similarly relatively sure we looked at port forwarding and found that alright. He has no problem with any other game, like Rocket League, for example.

    He gets no message upon attempting to join, like ‘server is not responding’ or anything, just nothing and stuck at the main menu waiting.

    When we allow him to host, for a few days it worked vaguely well, though we lost our customisation options when joining him, but since then it has never worked properly. It kicks us out to main menu after being in for about a minute, or when a second joiner joins, with the message ‘lost connection to the host’ and kicks him out with the same message, even though he is the host.

    Please please please if anyone can help, it would be amazing. This is a brilliant game, and it would be great if we could get around to playing it properly.