Game won't even load splashscreen (now fixed!)



  • EDIT: Now fixed… see below!

    Bought Chivalry earlier but can’t get the game to start!

    Bought from Gamersgate and installed through Steam, when I choose ‘Play’ it very briefly shows me as playing the game then stops (ie. my steam avatar border goes green then blue rapidly). No splash screen or anything appears, no errors either.

    The first time I tried it, it went through the installation of various files (direct x etc) with no errors.

    The game hasn’t created a profile for me yet, so there’s no chivalry folder in my documents.

    So what I’ve tried -

    Reinstalling game fully, verifying local files
    Removing directx files manually and letting the game reinstall them
    Removing x3daudio1_7.dll file and letting it reinstall it
    If I try and run UDK.exe directly I get an error stating “c:\windows\system32\D3DCOMPILER_43.dll is either not designed to run on windows or it contains an error”. I’ve removed D3DCOMPILER_43.dll and let the game reinstall it, but the error message still happens.

    Any ideas?

    Specs -
    Win7 64bit
    AMD FX-6100 6 core processor (3.3ghz)
    8GB Ram
    Ati Radeon 4800 512mb (VIdeo card drivers are fully up to date)

    Fixed! See below:

    Ok so this worked for me, no guarantee it’ll work for everyone -

    1. Double click UDK.exe. (for me it’s located Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32)

    2. take note of the error message, is it mentioning a direct x filename (something.dll) and a location?

    3. Are you on a 64bit OS or 32bit? (rightclick ‘my computer’ and look at system info)

    3a) 32bit OS, you can go to here (C:\Windows\System32) locate the file mentioned, rename it to something else (rather than delete)

    3b) 64bit OS, go to (C:\Windows\SysWOW64), locate the file mentioned, rename it to something else (rather than delete)

    1. Go back to the steam install location (\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Redist) and double click on UE3Redist.exe it should now reinstall your directx files. You should also notice it will replace the file you renamed just before.

    2. again double-click UDK.exe and see if another error message appears about a file not working. If so, rename the file and repeat the above process.

    3. Hopefully now it’s working…



  • Fixed it!!

    If I try and run UDK.exe directly I get an error stating “c:\windows\system32\D3DCOMPILER_43.dll is either not designed to run on windows or it contains an error”. I’ve removed D3DCOMPILER_43.dll and let the game reinstall it, but the error message still happens.

    The above error message was what gave me a clue. But it’s lying, because my OS is 64bit I needed to replace D3DCompiler_43.dll from inside the SYSWOW64 folder. Once replaced, the error changed to another dll file, so I replaced that one too and finally it’s working!



  • do you mind typing a step by step?…



  • I had the same problem and they fixed it, look for my thread, ‘Can’t start game’ or something likle that



  • My game won’t launch. When I try to launch from steam it will attempt for a split second, then nothing happens.

    Steam
    Win 7 Home Premius 64-bit
    AMD FX 4100 Quad-Core 3.6
    4 GB RAM
    AMD Radeon HD 6970

    -My Documents\My Games\Chivalry Medieval Warfare doesn’t exist
    -When I attempt to run UDK.exe I am told I need at least Windows XP service pack 3 (When I right click>properties>compatibility it is selected to run in XP service pack 2, and is greyed out so that I cannot change anything.)
    -I’ve renamed X3DAudio1_7.dll
    -I’ve tried re-downloading directX



  • Initially I had a hard time getting it to start as well. My video card is an nvidia. I downloaded the latest update from a couple days ago, and then rebooted and that seemed to fix it. I have had no more issues getting into the game.

    I was having similar issues with the Rekoil beta. They are both the same engine, and after updating my drivers I can get into both games.

    Running Win7 Pro 64bit, nVidia GTX 560, AMD Phenom 9850 (quad core) and 8 gigs of RAM.

    I strongly suggest people update and make sure they are running current drivers.


  • Developer

    @AudioClutch:

    -When I attempt to run UDK.exe I am told I need at least Windows XP service pack 3 (When I right click>properties>compatibility it is selected to run in XP service pack 2, and is greyed out so that I cannot change anything.)

    Click “Change settings for all users” (you need to be on an admin account), then uncheck compatiblity mode or change it to at least “Windows XP (Service Pack 3)”.

    Any idea how that got checked in the first place? Did Windows prompt you at any point to “reinstall with suggested settings” or anything weird like that?



  • @RufiO:

    do you mind typing a step by step?…

    Ok so this worked for me, no guarantee it’ll work for everyone -

    1. Double click UDK.exe. (for me it’s located Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32)

    2. take note of the error message, is it mentioning a direct x filename (something.dll) and a location?

    3. Are you on a 64bit OS or 32bit? (rightclick ‘my computer’ and look at system info)

    3a) 32bit OS, you can go to here (C:\Windows\System32) locate the file mentioned, rename it to something else (rather than delete)

    3b) 64bit OS, go to (C:\Windows\SysWOW64), locate the file mentioned, rename it to something else (rather than delete)

    1. Go back to the steam install location (\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Redist) and double click on UE3Redist.exe it should now reinstall your directx files. You should also notice it will replace the file you renamed just before.

    2. again double-click UDK.exe and see if another error message appears about a file not working. If so, rename the file and repeat the above process.

    3. Hopefully now it’s working…


Log in to reply