Dedicated Server Keeps Crashing



  • Randomly our server stops working every day with no rhyme or reason. Below is what’s in the console log for the last time it happened:

    [0003.03] Init: Version: 10246
    [0003.03] Init: Epic Internal: 0
    [0003.03] Init: Compiled (32-bit): Oct 12 2012 18:03:32
    [0003.03] Init: Command line:  "AOCTD-Darkforest_XL_p?steamsockets -seekfreeloadingserver -multihome=69.162.82.214 -forcelogflush -QueryPort=27015"
    [0003.03] Init: Base directory: C:\chivalry\Binaries\Win32\
    [0003.03] Init: Character set: Unicode
    [0003.03] Log: Executing Class Engine.ServerCommandlet
    [0003.03] Log: Initializing Game Engine...
    [0003.03] Warning: StaticLoadObject for ApexDestructibleDamageParameters UDK_APEXDamageMap UDKDamageMap couldn't find object in memory!
    [0003.03] Warning: Warning, Failed to load 'ApexDestructibleDamageParameters UDK_APEXDamageMap.UDKDamageMap': Failed to find object 'ApexDestructibleDamageParam
    eters UDK_APEXDamageMap.UDKDamageMap'
    [0003.03] Warning: StaticLoadObject for PostProcessChain PostProcessChain ChivPostProcess_noToneMap couldn't find object in memory!
    [0003.03] Warning: Warning, Failed to load 'PostProcessChain CHV_PPC_Pack.PostProcessChain.ChivPostProcess_noToneMap': Failed to find object 'PostProcessChain C
    HV_PPC_Pack.PostProcessChain.ChivPostProcess_noToneMap'
    [0003.03] Warning: StaticLoadObject for PostProcessChain PostProcessChain ChivPostProcess_noToneMap couldn't find object in memory!
    [0003.03] Warning: Warning, Failed to load 'PostProcessChain CHV_PPC_Pack.PostProcessChain.ChivPostProcess_noToneMap': Failed to find object 'PostProcessChain C
    HV_PPC_Pack.PostProcessChain.ChivPostProcess_noToneMap'
    [0003.03] Warning: StaticLoadObject for PostProcessChain PostProcessChain ChivPostProcess_noToneMap couldn't find object in memory!
    [0003.03] Warning: Warning, Failed to load 'PostProcessChain CHV_PPC_Pack.PostProcessChain.ChivPostProcess_noToneMap': Failed to find object 'PostProcessChain C
    HV_PPC_Pack.PostProcessChain.ChivPostProcess_noToneMap'
    [0003.04] Init: UEngine initialized
    [0003.06] Log: Steam Client API is unavailable (not required for servers)
    [0003.06] Log: Read config file: ..\..\UDKGame\Config\UDKEditor.ini
    [0003.07] Log: Read config file: ..\..\UDKGame\Config\UDKEditorKeyBindings.ini
    [0003.07] Log: Read config file: ..\..\UDKGame\Config\UDKEditorUserSettings.ini
    [0003.07] Log: Read config file: ..\..\UDKGame\Config\UDKEngine.ini
    [0003.07] Log: Read config file: ..\..\UDKGame\Config\UDKGame.ini
    [0003.07] Log: Read config file: ..\..\UDKGame\Config\UDKInput.ini
    [0003.07] Log: Read config file: ..\..\UDKGame\Config\UDKSystemSettings.ini
    [0003.07] Log: Read config file: ..\..\UDKGame\Config\UDKUI.ini
    [0003.07] Log: Read config file: ..\..\UDKGame\Config\WrangleContent.ini
    [0003.08] Warning: Warning, Failed to load 'Class None.': Failed to find object 'Class None.'
    [0003.08] Warning: Warning, Failed to find object 'Class None.'
    [0003.08] Warning: Warning, Failed to load 'Class None.': Failed to find object 'Class None.'
    [0003.08] Warning: Warning, Failed to find object 'Class None.'
    [0003.08] Log: Read config file: ..\..\UDKGame\Cloud\CloudStorage.ini
    [0003.08] Log: LoadMap: AOCTD-Darkforest_XL_p?Name=Player?Team=255?steamsockets -seekfreeloadingserver -multihome=69.162.82.214 -forcelogflush -QueryPort=27015
    [0003.13] Log: Game class is 'AOCTD'
    [0003.13] Init: WinSock: Socket queue 131072 / 131072
    [0003.14] Log: NetMode is now 1
    [0003.14] Log: Primary PhysX scene will be in software.
    [0003.14] Log: Creating Primary PhysX Scene.
    [0003.15] Log: Bringing World aoctd-darkforest_xl_p.TheWorld up for play (30) at 2012.10.21-10.09.03
    [0003.16] Log: Initializing Steam game server
    [0003.17] Log: Bringing up level for play took: 0.028952
    [0003.17] Log: ########### Finished loading level: 0.083056 seconds
    [0003.17] Init: Game engine initialized
    [0003.17] Log: Initializing Game Engine Completed
    [0003.23] Log: Flushing async loaders.
    [0003.32] Log: Flushed async loaders.
    [0004.44] Log: Steam game server UID: 90085434966010884
    [3394.67] Log: Steam game server UID: 90085434966010884
    [5156.45] Log: Steam game server UID: 90085434966010884
    

    It’s not being run as a service and it’s the only game instance we’re running on our box.



  • Bump.


Log in to reply