Server problems



  • After I’d been hosting server for 2 days, I met with such number of problems and bugs that I didn’t ever see in any other game.

    1. Dedicated server downloaded from “tools” section in steam doesn’t work. Well, it can start if it’s loaded from steam but nothing happens. Starting from server folder with any amount of magic crashes it in instant. BUT, If I start server using game executable, it works.
      2)http://puu.sh/1hcAK This is what I usually see in console. Server is working and people are playing, but that number of errors is making me sad. Is it have to be like this, or I’m doing something wrong?
    2. Today server have just stucked after round and couldn’t change map because of this http://puu.sh/1hbz2 so I have to change map manualy.
    3. If mistype a map name in Adminchangemap command, server will kick everybody and load…, well, actually, I have no idea what map it will load. It usually loads next map in map list.
      5)Autobalance swaps players while they are alive. Also, it can swap same player 3-4 time in a row. It’s annoying.
    4. I have no idea how does maplist work. Server seems to load maps in order of which they’re placed in maplist. but when it reaches the end, it starts to load map at pure random. Or not, I’m really not sure.
    5. Lack of commands, votes from console, no admin list, I think it was mentioned by people before me.


  • On point number 4, if you don’t get the name right it actually crashes your server. Your server probably crashed and restarted.

    I am also hosting a Chivalry server remotely. I’ve been hosting it for 3 days so far. Has your server crashed or frozen up at times when a lot of players are connected? I am currently having trouble with this. It seems like after a lot of players play on the server for an extended period of time, it freezes or crashes. It does this despite the server not actually being under heavy load.


  • Developer

    Which map, how many players? Can you post a log file from the server (the last, say, 100 or so lines is fine). We have noticed instability on Battlegrounds and possibly other TO maps with greater than 32 players.



  • I would love to give you all my logs, but the problem is: I don’t have any. As I mentioned before, dedicated server isn’t works for me. Btw, log:

    Log: Log file open, 10/20/12 15:42:48
    Init: FEngineLoop::PreInit Here
    Init:  ---- call app init here 
    Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
    Init: Call platform pre init
    Init: **** Pre InitSHAHashes() ****
    Log: Read config file: ..\..\UDKGame\Config\PCServer\PCServerSystemSettings.ini
    Log: Read config file: ..\..\Engine\Config\PCServer\PCServerSystemSettings.ini
    Log: Read config file: ..\..\UDKGame\Config\DefaultSystemSettings.ini
    Log: Read config file: ..\..\Engine\Config\BaseSystemSettings.ini
    Log: Read config file: ..\..\Engine\Config\BaseSystemSettings.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKSystemSettings.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKSystemSettings.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKSystemSettings.ini
    Log: Read config file: ..\..\UDKGame\Config\UDKLightmass.ini
    Log: Read config file: ..\..\UDKGame\Config\UDKLightmass.ini
    Log: Read config file: ..\..\UDKGame\Config\UDKLightmass.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer\PCServerInput.ini
    Log: Read config file: ..\..\Engine\Config\PCServer\PCServerInput.ini
    Log: Read config file: ..\..\UDKGame\Config\DefaultInput.ini
    Log: Read config file: ..\..\Engine\Config\BaseInput.ini
    Log: Read config file: ..\..\Engine\Config\BaseInput.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKInput.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKInput.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKInput.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer\PCServerUI.ini
    Log: Read config file: ..\..\Engine\Config\PCServer\PCServerUI.ini
    Log: Read config file: ..\..\UDKGame\Config\DefaultUI.ini
    Log: Read config file: ..\..\Engine\Config\BaseUI.ini
    Log: Read config file: ..\..\Engine\Config\BaseUI.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKUI.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKUI.ini
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKUI.ini
    Log: Read config file: ..\..\Engine\Config\ConsoleVariables.ini
    DevConfig: GConfig::Find has loaded file:  ..\..\Engine\Config\ConsoleVariables.ini
    Init: Version: 10246
    Init: Epic Internal: 0
    Init: Compiled (32-bit): Oct 12 2012 18:01:06
    Init: Changelist: 1340247
    Init: Command line: SERVER  
    Init: Base directory: D:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win32\
    Log: Read config file: ..\..\UDKGame\Config\PCServer-UDKEngine.ini
    DevConfig: GConfig::Find has loaded file:  ..\..\UDKGame\Config\PCServer-UDKEngine.ini
    [0000.23] Init: Computer: AIBOT-PC
    [0000.23] Init: User: Aibot
    [0000.23] Init: CPU Page size=4096, Processors=8
    [0000.23] Init: High frequency timer resolution =3.330117 MHz
    [0000.23] Init: Memory total: Physical=8.0GB (8GB approx) Pagefile=8.0GB Virtual=4.0GB
    [0000.23] Log: Steam Client API not initialized (not required for servers)
    [0000.69] Log: Steam Game Server API initialized 1
    [0000.71] Init: WinSock: I am Aibot-PC (192.168.1.101:0)
    [0000.71] Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 bytes.
    [0000.71] Init: Object subsystem initialized
    [0000.74] Log: Shader platform (RHI): PC-D3D-SM3
    [0000.77] Log: PhysX GPU Support: DISABLED
    [0000.80] Critical: appError called: Bad name index -1/810
    [0000.80] Critical: Windows GetLastError: The system cannot find the path specified. (3)
    [0000.93] Log: === Critical error: ===
    Bad name index -1/810
    
    Address = 0x76d9b727 (filename not found) [in C:\Windows\syswow64\KERNELBASE.dll]
    Address = 0x4656d1   (filename not found) [in D:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win32\UDKGame.exe]
    Address = 0x4bb474   (filename not found) [in D:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win32\UDKGame.exe]
    
    ```So I have to use game executable, and even with -log argument nothing happens. Any ideas?


  • -seekfreeloadingserver

    You have to add that to the commandline.



  • You won’t believe me if I say I tried it before, but it didn’t work, will you? Any way, thank you.



  • So does it work now? :P



  • Good news-server don’t crash. Bad news-nothing happens. Server console stays empty. http://puu.sh/1hOxy



  • That’s expected unless you’re using UDKLogging.exe



  • Okay, now dedicated server works and log isn’t empty. But now I have another problem http://puu.sh/1hOMV. This is getting ridiculous. Still using game executable for server.


Log in to reply