Lowend PC wanting to optimise for steady 60fps (SPECS INSIDE)

  • Now, even though the game warned me that my video drivers are outdated (which I’m well aware), I’m wanting to optimise the game enough to still run at 60fps. When all the settings are on low and the resolution set to 1280x720, in-game I only get 30fps average. (I’ve followed the pinned “Mirage Troubleshooting Guide” thoroughly and nothing has seemed to help. Plus it’s often the first thing I do with most of my modern games that I own when it comes to gaming.)

    There is a program I use with Skyrim that helped me run that game smoothly called HiAlgoBoost. I tried to get it to work with this game but it didn’t detect that the game was open.

    1. If anyone has used HiAlgoBoost before, could you tell me how I can get the program to detect that the game is open?
    2. If you know any other third party programs that help boost FPS similalry to what HiAlgo does, could you list them and what they do to help boost FPS as well as the pros and cons of using said third party software?

    Kind regards!

    Here are my specs for those wondering:

    Intel Core i7-870 Quad 2.93GHz

    ATI Radeon HD 5570 1024MB

    8GB DDR3 667MHz

    Win 7 64, 11

    Hard Drive
    Seagate ST31000528AS 1TB
    1TB - Total Storage Space

    LG 24MP48HQ-P 23.8inch

  • @TechnalCross said in Lowend PC wanting to optimise for steady 60fps (SPECS INSIDE):

    ATI Radeon HD 5570 1024MB

    Is that not DDR3 Ram on that video card, I run this game on low on my low spec old workstation some weeks
    at low settings but it has an Old Quadro slim 2000 65watts or lower thinks but its got DDR5 Ram a must for games imo.
    xw4600 hp very old workstation 775 socket cpu.

    I haven’t tried any of my existing DDR3 ram video cards except in chivalry on low GT730 low profile 1gb
    It’s suggested put this one down to the ram on your video card imo. Any card with 1gb of DDR5 ram should
    run it quite ok at low settings.

  • @TechnalCross Reducing BloodPools and Ragdoll Timers can strongly affect performance. You can also try reducing Resolution Scale and running in Fullscreen mode.

  • @Reithur I’ve lowered both of those already to the lowest they can possibly go. It still only gets me around 30-40fps, dropping slightly less but still making the game feel almost unplayable. And this is only in the Tutorial training section of the game. I dare not ask what the game would run like in actual multiplayer.

  • @TechnalCross There’s not much else I can suggest aside from updating your video drivers.

    Have you disabled Rptr / Gaming Evolved?

  • @Reithur Yes I’ve done that. But yeah sadly I guess I’ll have to update my drivers at a later date. Thank you for giving some advice, though :)