Odd/unreliable in-game loading times

  • Got the beta, installed the game. This occurs on both the last version (that shipped with the beta) and the current update.

    Launching the game takes some time no matter what (seems to be a feature of Unreal 3 & 4 at this point).

    After launch, all settings are automatically set to highest (ultra, I think it was), I only changed post-processing to low.
    I have no framerate issues, everything is pretty smooth, even when there is a lot going on.

    The game is installed on a healthy 7200 RPM hard drive and the initial map loading (when the game is launched after being freshly installed) is fast, any map loads within seconds, even for the first time after launch. Same thing after map change.

    The loading time problem starts when I launch the game after the PC was rebooted/powered back on after a shutdown:
    after launching the game, joining any server (with any current map) takes 3 to 5 minutes, with the loading screen just freezing/muting for the last minute (which I thought was a crash at first, but it still loads eventually).

    After the map finally loads and if I pick a team and class fast enough, some assets/textures are still visibly being streamed (this does not happen when freshly installed, even though the map loads so fast) and short freezes occur for a minute or so. On map change, the loading isn’t as slow (~1 minute), but still nowhere near as fast a on a fresh install.

    Within a couple of days like this, I just tried uninstalling/reinstalling through Steam after booting up without touching the config files (all my settings and bindings were saved) and it seemed to work, the loading times were back to being ridiculously fast.

    Then it was back to slow the next day, and reinstalling the game without rebooting fixed it again.

    Is this some kind of cache issue that the game creates after the first launch?

    Misc. notes:

    • Haven’t tried to restart Steam after reinstalling the game to see how the loading speeds are, yet.
    • Doesn’t seem to be a video driver issue, as a friend of mine has very similar hardware (with the same video card and current driver). While he doesn’t have the extreme loading speeds, they’re not as slow as mine either.
    • Nothing was installed/removed from the hard drive since I started installing/reinstalling Mirage

    My current OS/hardware:

    Win7 Ultimate x64 SP1
    i5 4690k @ stock speeds
    16 GB RAM (1600 MHz, dual channel)
    Gigabyte Geforce GTX 970
    1 TB WD Black (game is installed on this hard drive, separate drive from Steam)

  • @RaZ0R_R thanks for posting. I’ll pass your info to the team.

  • @RaZ0R_R After talking with the team a bit, these are known performance issues. As for the in-game performance, it looks like your game is not finished loading everything before you’re trying to play and this is affecting both your system performance and the visual quality of game assets.

    We are working to reduce load times and you should see an improvement when we update the beta later this week.

  • Great to hear, thanks.

  • This post is deleted!

Log in to reply