Can't start the game

  • Hello, I just bought the game trough Steam. When I start the game, it crash and the following error appears:

    “Failed to create the D3D9 Device! This can happen if the desktop is locked. Exiting…”

    I tried changing the resoluction in the file UDKSystemSettings.ini but it didnt work :(

  • I have the same error, when i back home post my PC spec.

    Processor : AMD FX™-8150 Eight-Core Processor
    Memory : 4096MB(Speed 1333)
    Mother Board : Crosshair V Formula
    Windows Version : Microsoft Windows 7 Home Premium Service Pack 1
    Installation Date : 2012-02-15
    Monitor : Monitor generico Plug and Play
    Video Adapter : ATI Radeon HD 5800 Series
    Mouse : Dispositivo di input USB
    Keyboard : Dispositivo di input USB
    Disk Drive : WDC WD50 00AADS-00S9B0 SATA Disk Device(465GB, IDE)
    Disk Drive : WDC WD64 00AAKS-65A7B2 SATA Disk Device(596GB, IDE)
    DVD/CD-ROM Drive : hp DVD-RAM GH40L SATA CdRom Device
    ------------------Operating System------------------
    OS Name : Microsoft Windows 7 Home Premium Service Pack 1
    OS Language : Italiano (Italia)
    OS Version : 6.1.7601<
    Registered Owner : Kevan
    Registered Organization : -
    Product ID : 00359-OEM-9800605-75574
    Product Key : BBB42-BFCB2-DX4FT-JQMWD-QVPMG
    OS Installation Date : 2012-02-15
    OS Root : C:\Windows
    Computer Name : KEVAN-PC
    User Name : Kevan
    Logon Domain : Kevan-PC
    Uptime : 6146sec( 1 Hours 42 Minutes 26 Seconds)
    Internet Explorer : 9.0.8112.16421
    Windows Media Player : 12,0,7601,17514
    DirectX :
    ------------------System Devices------------------
    Motherboard Name : Crosshair V Formula
    Motherboard Manufacturer : ASUSTeK Computer INC.
    BIOS Version : 0705
    System BIOS Date : 10/20/10
    Video BIOS Date : 03/11/10
    CPU Identification : AMD FX™-8150 Eight-Core Processor
    CPU Generic Name : x86 Family 21 Model 1 Stepping 2
    CPU Vendor : Advanced Micro Devices
    Serial Number : 0060-0F12-178B-FBFF-1E98-220B
    CPU Frequency : 3612 MB
    L1 Code Cache : 64K, 2-Way, 64 entrie
    L1 Data Cache : 16K, 4-Way, 64 entrie
    L2 Cache : 2048K, None, 64 entrie
    CPU Socket : AM3r2
    Core Per Package : 8
    Logical Per Core : 1
    Device Description : ATI Radeon HD 5800 Series
    Adapter String : ATI display adapter (0x6899)
    BIOS String : -
    Chip Type : ATI display adapter (0x6899)
    DAC Type : Internal DAC(400MHz)
    Driver Date : 2012/04/05
    Driver Version : 8.961.0.0
    Driver Provider : Advanced Micro Devices, Inc.
    Memory Size : 1024 MB
    Monitor Name : HP 2009
    Model : HWP2827
    Manufacture Date : 2009/36
    Serial Number : CNC9360828
    Max.Visible Display Size : (44 x 25) cm (19,9’)
    Gamma : 2,20
    1600 x 900 - 32 bit

  • UP

  • Developer

    (Edit: I’ve added the issue to viewtopic.php?f=69&t=3136 )

    There’s two possible causes for this.

    1) The game is trying to start in an unsupported resolution.

    Right click on the game in your Steam library. Click “Properties”. Click “Set Launch Options”. Add:

    -resx=1280 -resy=720

    (replace 1280 and 720 with your desktop resolution’s width / height)

    2) Some other software is stealing focus away from the game or otherwise interrupting it as it’s trying to go into fullscreen mode. You should be able to start in windowed mode, however:

    Right click on the game in your Steam library. Click “Properties”. Click “Set Launch Options”. Add:
    to the launch options, click OK, and try starting the game again.

    You can also set the game to borderless windowed mode, which should also be fine. We don’t have UI support for this right now, nor a command line option, so:

    Open Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKSystemSettings.ini



    change it to


    Also, find


    And edit the resolution to match your desktop resolution.

  • Developer


  • Thanks Crust,
    the first solution works for me, i tryed to change resolution from notepad but didn’t work.Tryed with your solution and works immediatly.

  • Thank you all, that was the solution.

Log in to reply

Looks like your connection to Torn Banner Forums was lost, please wait while we try to reconnect.