Release Hotfix 1 for Server Operators



  • Hey,

    Client Patch will be released at 9AM PST tomorrow (10/23/2012).

    We have been looking into the various issues you guys have been bringing up and we’ll keep you updated about them. The server files will be up for you to update to soon.

    Patch Notes are here: viewtopic.php?f=2&t=4137

    The most important change here is:

    • You will no longer able to able have more players than your advertised max limit

    Also, there is a mistake in the documentation regarding MaxPlayers.
    In the documentation we stated that you have to add -MaxPlayers=##. However, you actually have to do ?MaxPlayers=## after MAP_NAME?steamsockets.

    So an example:
    AOCTO-Test?steamsockets?MaxPlayers=24 -seekfreeloadingserver

    The documentation will be updated in the next patch.
    Also, we have fixed the issue where PCServer-UDKGame.ini and PCServer-UDKEngine.ini would be overwritten when you update.

    In the future, ideally, we’ll be sending these updates out via email so if you would like to receive a email notification about patches and changes please add your email address here:
    https://docs.google.com/spreadsheet/vie … c6MQ#gid=0

    As of 6:06PM PST the build is now up and you can download via the SteamCMD tool.
    Please wait until approximately 9AM PST to update your servers as the new server client is not compatible with the current client build.

    Thanks.



  • So does this mean that the maxplayers has been hard coded to 32? Or was this just addressing the bug where it would show, as an example, 24 max slots but more people could join? We have experienced that issue before so im just clarifying.



  • My bad, no. Sorry for the misunderstanding.
    Previously you could have up to 64 players in a server that was being advertised on Steam as 10 or 32 or whatever. This hotfix fixes that issue.



  • @b3h47pte:

    My bad, no. Sorry for the misunderstanding.
    Previously you could have up to 64 players in a server that was being advertised on Steam as 10 or 32 or whatever. This hotfix fixes that issue.

    That is what I figured you mean’t when I read over the post again. We had that happen with some of our servers. Glad you fixed it. :)



  • :) Np.

    As of 6:06PM PST the build is now up and you can download via the SteamCMD tool.



  • MY server keeps crashing now all the time when starting.



  • @b3h47pte:

    :) Np.

    As of 6:06PM PST the build is now up and you can download via the SteamCMD tool.

    got my server updated… but since i updated it says i cannot join the server since it has downloadedable content on it ;O



  • What command line are you running it with?
    Post My Documents\My Games\Chivalry MEdieval Warfare\UDKGame\Logs\Launch.log

    You still need -seekfreeloadingserver.

    The server is not compatible with teh current build. The client build will be updated at 9AM PST.



  • Well. I reinstalled the server completely and it works again.



  • @b3h47pte:

    What command line are you running it with?
    Post My Documents\My Games\Chivalry MEdieval Warfare\UDKGame\Logs\Launch.log

    You still need -seekfreeloadingserver.

    The server is not compatible with teh current build. The client build will be updated at 9AM PST.

    i m usuing the same command line since the first day AOCTO-Battlegrounds_v3_P?steamsockets -seekfreeloadingserver

    so its not compatible with teh current build :D… why releasing it before the build lol ;D



  • To give you guys a heads up. Or else we’ll be releasing a 9AM patch to no servers. That wouldn’t be fun now would it.



  • Thanks for the heads up!

    I moved our Chiv server over to my i7… updated and upgraded and am now eagerly awaiting the client patch for some 48 man FFA!

    God speed!



  • New patch is live. You should start to see users trickle over.



  • My server is displaying 51/24 players, despite nobody actually being connected. It’s remote hosted and has been updated to the newest version. I’m not sure if anyone is actually able to connect to it either.

    Any update on this issue?



  • Hi JakeLunn,

    It seems as though everybody is having these issues across the entire forum board. The servers are getting “Authentication failed” and “Lost connection to host” errors. Each time a player connects and loses the connection or fails to authenticate the server still shows that person playing on the server list.

    I’m sure the devs are well aware of the problem with the server browser and server browser tabs. As it was only a hotfix and not a full patch I am sure they are working on it as we post. 8-)



  • Thanks Bluefang, I must’ve missed those posts somehow. Maybe I need to peek my head outside of the Server Operator’s forum for once.



  • Sorry all!
    viewtopic.php?f=2&t=4240
    Thread for details.



  • @b3h47pte:

    Sorry all!
    viewtopic.php?f=2&t=4240
    Thread for details.

    Hey b3h47pte,

    The majority of the hotfix changes seem to be working. But I am still noticing issues with the server browser tabs (switching between Servers, Friends, Favorites). As well as issues in-game when the server is transitioning maps you sometimes get locked up and your UDK.exe crashes (client-side). The issue with servers reporting more players than there are actually in the server is still happening too. Not sure if this is you guys or Valve.



  • What about the crazy amount of connections?
    Have 3 servers running and see about 300-500 connections from them.


Log in to reply