Game not exiting properly



  • Whenever you close the game, the main UDK.exe process hangs around. Instead of killing it off, the game decides to leave it running. When you go into the task manager to end the process, it still stays there. No matter what you try, the only thing you can do to get rid of it is to restart the computer.

    It’s incredibly annoying, because the routine goes like this:

    1. Try to play the game
    2. Oh wait, no servers
    3. Quit game to try again
    4. Oh wait, game wants to be annoying so you have to restart the computer
    5. Have to close all the other work you have open and restart the computer…
    6. Try to play the game, after searching for and applying supposed ‘fixes’ (lies- they don’t work whatsoever)
    7. Oh wait, no servers
    8. Quit game to see if other fixes work (they don’t)
    9. Oh wait, game wants to be annoying so you have to restart the computer
    10. Have to close all the other work you have open and restart the computer…
    9. etc etc etc

    Thanks for developing a terribly coded game that doesn’t have the decency to exit properly when you quit, leaving you with 200MB clogging your ram, making it impossible to exit Steam and making you unable to start the game again either. I love being forced to restart my computer every time! I really appreciate the opportunity and don’t regret funding $75 during the Kickstarter campaign either.

    Posting this here seperately because bugs I’ve noted before have been ignored in other threads.

    Windows 7 Ultimate 64-bit
    Intel E8600
    Corsair Dominator-GT (8GB)
    Gigabyte EP45T-UD3LR
    Nvidia GTX 295



  • Can you go to your Steam\config folder and post your MasterServer2.vdf file.
    Also, can you post My Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs\Launch.log.

    Thanks.



  • Props for trying to look into this- I even wanted to name this “Stupid game not exiting properly” but I understand there’s a good game beneath all the bugs that make up more than half of it at this stage.

    Also, bloody hell… I decided to have a match with some bots instead and I got the infamous “UDK.exe” stopped working crash. If it helps, I was on that corpse cart pushing level- crashed in midair during a Vanguard rage jump. The interesting thing is that it ALSO refuses to exit properly as well. Now I have a 1GB UDK.exe process clogging up my ram because the game is so poorly coded.

    But anyway, sure, of course:

    The forum won’t let me upload the MasterServer2.vdf file, so I’ll post the contents here:

    “MasterServers”
    {
    “hl1”
    {
    “0”
    {
    “addr” “208.64.200.117:27011”
    }
    “1”
    {
    “addr” “208.64.200.118:27011”
    }
    }
    “hl2”
    {
    “0”
    {
    “addr” “208.64.200.39:27011”
    }
    “1”
    {
    “addr” “208.64.200.65:27015”
    }
    “2”
    {
    “addr” “208.64.200.52:27011”
    }
    }
    “rdkf”
    {
    “0”
    {
    “addr” “69.28.158.131:27014”
    }
    }
    “gms”
    {
    }
    }


    The Launch.log is attached.



  • Also having this issue. Only started earlier today. Before, didn’t have any sort of UDK.exe related errors.

    Hoping this gets corrected soon. Just bought the 4 pack so my friends and I could play, haha.

    “MasterServers”
    {
    “hl1”
    {
    “0”
    {
    “addr” “69.28.158.131:27011”
    }
    “1”
    {
    “addr” “72.165.61.149:27010”
    }
    “2”
    {
    “addr” “69.28.158.131:27012”
    }
    “3”
    {
    “addr” “69.28.158.131:27010”
    }
    “4”
    {
    “addr” “69.28.140.247:27010”
    }
    “5”
    {
    “addr” “68.177.101.62:27011”
    }
    “6”
    {
    “addr” “68.177.101.62:27010”
    }
    “7”
    {
    “addr” “68.177.101.62:27013”
    }
    “8”
    {
    “addr” “208.64.200.118:27011”
    }
    “9”
    {
    “addr” “208.64.200.117:27011”
    }
    “10”
    {
    “addr” “209.197.20.34:27010”
    }
    “11”
    {
    “addr” “69.28.151.162:27010”
    }
    }
    “hl2”
    {
    }
    “rdkf”
    {
    “0”
    {
    “addr” “68.142.72.250:27012”
    }
    “1”
    {
    “addr” “69.28.158.131:27014”
    }
    }
    “gms”
    {
    }
    }



  • While I absolutely abhor the attitude of the OP, I am also having this problem.



  • yep, when you quit the game , after the hotfix, udkengine is left running, i had to kill it manually in start task manager.



  • Ya, that’s the issue. You can’t kill it. Tells you that you don’t have access. Ending the process or ending the process tree yields the same results. Steam reports that you’re still in-game as well. Results in having to restart your computer. I wouldn’t mind it if say, I could join a match but since that isn’t a reality currently it has become a slight nuisance.



  • i was able to kill it within the task manager.



  • Wonder if they’ll actually do anything about this.


  • Developer

    We have a fix for one instance of this that will make it to the next patch, and we’re working to see if there are any other causes.


Log in to reply