Joining servers



  • Hello everybody,

    I’ve bought the game this week and it’s awesome. I trained my skills against bots and tried to play online.
    This didn’t work, however. I couldn’t see any servers at first but fixed it. But now the problem is that i cannot join ANY game at all. They do appear, a lot of them but either they are full or empty. When i join them the message says: ‘‘The connection to the host is lost.’’ The only ones that have a few people in them have a password.

    Please help!



  • It’s a bug that came with the hotfix. I think it’s because the servers are not properly updated with the client.


  • Developer

    It has nothing to do with the hotfix. This is a Steam issue that happened to start around the time we released the hotfix (according to some people it was apparently happening about an hour before, and then kicked up shortly after we patched). This is affecting other Steamworks games.

    Please refer to viewtopic.php?f=2&t=4240 in the News subforum


Log in to reply