Game will not launch



  • I downloaded the game via steam and I am having a huge problem. I downloaded my most recent graphics drivers, then started up the game. the splash logo came up, then a black screen. I let it sit for around 10 minutes and nothing came up. In task manager it said chivalry was not responding. I looked at the possible fixes for issues in this forum first, I changed the resolution in the base system settings . ini file to match my monitors resolution. I thought this would work because once I got the error failed to create d3d9. After changing the resolution the program still would not run, It just sits at a black screen unresponsive.

    pc specs
    Windows 7 professional sp1 32 bit
    4gbs ram
    intel core 2 duo 2.5 ghz
    Nvidia geforce 8600m

    I looked at other peoples launch logfiles and they are significantly longer than mine. The file I uploaded is from after I let it try to run for around 10 minutes. All my other launch logs are exactly like it



  • Looking at your log file I see that the errors at the end are identical to the ones I’m experiencing. See here: viewtopic.php?f=69&t=4270



  • Good thing I’m not the only one. Thanks for the reply



  • I have the same prob and I took a look at your launch.log and mine has a problem to loading up “PostProcessChain.” even though my computers requirments meet and exceed the minimum.

    Windows 7 professional Sp1 32 bit

    Intek Celeron D CPU 3.33GHz

    4.00GB (3.25GB usable)

    Radeon HD 5570



  • Hey guys, can we please get some attention to this issue? I see a lot of other problems being addressed and I know you’re busy putting out fires, but we have at least 3 players (if not more) experiencing the problem of not even being able to play the game at all after trying all the suggested fixes. I’m a big fan, have been around since the original AoC and went in for the 4 pack so that I could play with my 3 friends who are also long time devotees but I’m getting no help here. Here’s my original post detailing the problems I’m having with the game, which seem to be the same as the other two players in this thread: viewtopic.php?f=69&t=4270 Please help, I’ve owned the game for 3 days now and have yet to play it.


  • Developer

    First: try launching the game with -FORCELOGFLUSH in the command line (right click on it in Steam, click Properties, click Set Launch Options, add it in the window that comes up). Try launching the game and see if the log looks any different.

    If not, we really need a memory dump to see where exactly it’s crashing or freezing, since the log is being cut off. Because the game isn’t crashing through its crash handler for some reason, you need to get one manually:

    • Download Process Explorer

    • Open up Process Explorer

    • Open the game, let it freeze/crash

    • In Process Explorer, right click UDK.exe, click “Create Dump”, then “Create Minidump”. Save that somewhere, and post it here



  • Thanks for the reply after I get out of class I’ll send the file



  • I try to post my UDK.dmp and it gets done uploading but it doesn’t post.



  • Thanks for the help Crustacean. Ok, here’s the old log from a couple days ago:
    [attachment=1:3oekfeca]Launch-backup-2012.10.23-19.18.28.log[/attachment:3oekfeca]
    And the new one:
    [attachment=0:3oekfeca]Launch-10-25-12.log[/attachment:3oekfeca]
    I’m no programmer but looking at the new log file it seems like the intro movie is failing to load?
    I saved a UDK minidump for what it’s worth but I can’t read it. Whenever I try to open it I get the error message: “Invalid license data. Please reinstall.” Perhaps that’s part of the problem? I tried uploading it but had the same problem as indus. When I try to add the file the forum just wipes out my post and takes me to a new blank page.



  • I looked at Whiskey MacGhee’s newest launch folder and it looks like we have exactly the same problem.



  • I bought the game today in great anticipation, but I have the same problem. I launch the game, I see the splash screen then the fullscreen Torn Banner logo and then my desktop appears with the game minimized and its not responding.

    Tried reinstalling, tried -Novid, read these forums, but no fix or solution :(.

    I dont have a .log file as its not being made, even not with the -FORCE command. I could make a memory dump later, but I guess its the same thing as u guys. Does your game also minimize when it crashes?

    I have Windows 7 64bit, not the latest SP I guess. Havent had any problems with other games.
    My specs: 4gig, AMD phantom x4, ATI 6800 HD series.



  • Here’s the new launch log file, udk.dmp seems to be too big to upload. compressed to zip and rar and still couldn’t get it to upload. seeing the same problem with failing to load the intro movie…



  • Upload it to a site like mediafire.com and link it here.



  • udk.dmp file- http://www.mediafire.com/?pkj4ionr9qlbht9
    Worth noting that I’m unable to open it as I get the same error as when I try to run udk.exe, “Invalid license data. PLease reinstall.”



  • That seems to be a dump of Steam instead of the game.
    Can you go to My Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKEngine.ini and remove Suppress=DevOnline and then run the game again? Then post My Documents\My Games\Chivalry mEdieval Warfare\UDKGame\Logs\Launch.log



  • [attachment=0:23qre69i]Launch-10-26-12.log[/attachment:23qre69i]
    Latest log file after line removed per your request. I was worried that I didn’t catch the UDK dump in time. Problem is I can’t access process explorer once I start the game (or anything else for that matter) as my whole system freezes so I was having to close the program from the task manager then try to catch UDK before it disappeared from process explorer. Guess I wasn’t fast enough and caught Steam instead.



  • Can you trying downloading this and installing it?
    http://www.microsoft.com/en-us/download … x?id=14632





  • Go to My Documents\My Games\Chivalry Medieval Warfare\UDKGame\config\UDKEngine.ini find the line that says
    StartupMovies=SWF.####
    and delete it and try again?



  • So I was able to “fix” the problem of the game not starting and crashing to desktop and minimizing the game after the banner logo, by starting the UDK.exe direct instead of from steam. It works 4 out of 5 times now. Yet Now I dont see any servers and im replying in another topic about this. (Till now 1,5 hours fix time and still 0 play :()