"UDK.exe has stopped working."



  • Dev Team,

    Like a handful of other people, I have run into the UDK.exe error. I receive the same error whether I am launching the game from within steam, or simply double-clicking UDK.exe from within my game directory.

    My system specs are:
    CPU: Intel Q6600, 2.4GHz
    GPU: EVGA NVIDIA GTX 480
    RAM: 4GB
    OS: Windows 7, 32-bit, SP1

    As far as troubleshooting goes, I have tried the following:
    1.) Renaming “X3DAudio1_7.dll” and re-running “ue3redist.exe.” However, I receive an error message upon launching ue3redist.exe, which states the following, “You must have at least Windows XP Service Pack 3 installed. Installer will now exit.” This doesn’t make sense considering I have Windows 7, 32-bit.
    2.) Going into “BaseSystemSettings.ini” and changing FULLSCREEN to False. Tried both ways of launching the game, but still received the same UDK.exe is not responding error.
    3.) Then I tried wiping the game off of my local drive entirely, re-downloading from Steam, and re-installing everything from scratch. Upon first launch, I received the same UDK.exe error.

    Also, I’d like to say that I was able to play the game last night for about 4 hours and everything worked flawlessly. It wasn’t until I received the first hotfix/update that I received the UDK.exe error (weird). So, I’m not sure why, but it seems that the hotfix, at least for me, broke what didn’t need to be fixed.

    I have attached the log below for you all to review when you can. Thanks in advance for your steadfast reply.

    -Lt Dan



  • Update:

    Still not working.

    Though, After seeing a similiar post regarding UDK.exe not working (http://www.chivalrythegame.com/forums/viewtopic.php?f=69&t=4318), I attempted to follow the troubleshooting directions as outlined by b3h47pte. After attempting to “verify integrity of game cache,” it found that 4 files failed the check. Unfortunately, what I suspected as only being a minute to download 4 files, has actually turned into Steam re-downloading the whole game over again.

    Once it re-downloads for the second time now, I will attempt to run it. If I get the UDK.exe error again, I will try deleting “My Documents\My Games\Chivalry Medieval Warfare”, as per the instructions in that post.

    Additionally, a second post by b3h47pte stated to ensure that MotionBlur in the “UDKSystemSettings.ini” file was set to False. Before my game started re-downloading, I checked and that setting was already set to False, and so I have ruled that out as being a possible fix.

    I will post another update once the game re-downloads. In the meantime, if you can still review my .log to provide any further troubleshooting procedures, I would greatly appreciate it.

    Thank you.

    • Lt Dan


  • Let us know how the verify cache goes first :)



  • Alright, so the download finished and I was able to launch the game without any errors. I was able to play for about an hour, then I quit on my own. A couple hours later (just now), I went to play again and about 15 minutes into playing, I received the same “UDK.exe has stopped working” error as I did before, except this one was mid-game. So, I tried to re-launch the game from Steam to see if it was just a one time thing, but the game did not load, and just as before I received the UDK.exe error. I have attached the log that was generated when I received the error mid-game (“Launch-backup-2012.10.25-00.06.38.log”). The other log (“Launch.log”) is the most recent log that was generated when I tried to re-launch the game from Steam and received the error.

    I’d like to point out that the first Launch.log I posted looks identical to the most recent one. It looks like it just cuts off after “Read config file: …\UDKGame\Config”

    Please let me know what to try next.

    Thanks.


  • Developer

    Is there a .dmp file to go along with the crash log (the Launch-backup-2012.10.25-00.06.38.log one is most interesting, but a dmp for the other one would be nice too)?

    And just in case there’s anything creating an ongoing corruption issue, does anything happen when you Verify Game Cache again? (Nothing should happen, but I’d rather be sure, since something did somehow become corrupt the first time)



  • Attached is the .dmp file to go along with the mid-game crash .log.

    Subsequently, I went to Steam just now to verify integrity again, and it said 1 file failed to validate and will be reacquired. This time, the game was not entirely re-downloaded, and it took only 45 seconds to download. After sifting through the game’s directory, I located the 1 file that was re-downloaded: “Engine_MI_Shaders.upk”

    After the file downloaded, I launched the game from within Steam. It performed “first time installation” even though it technically wasn’t. The game launched successfully.

    Though, I am worried that the problem does not arise until after I’ve played the game 1 or 2 separate times. Then the unsightly “UDK.exe has stopped working” error rears it’s ugly head.

    Thoughts?

    PS. I appreciate you guys helping us out as fast as you do. The game is fantastic when I am able to play it. I also understand that every game has bugs (I used to design maps, avatar skins, and scripts for the Medal of Honor series, pre-Limited Edition) and that it’s only a matter of time until they are all worked out.



  • Update: I have not received the UDK.exe error so far after running the game about 8 times. Though, I am now running into the issue of the servers not populating. I’ve gone through the troubleshooting steps and they work, but only temporarily. What has been happening is, I will join a game and be playing for no more than 10 minutes and then a screen will appear as if I’m joining a server (you know, the screen with a game tip on it) and then that screen cuts off and I’m brought to the main menu. So, I go into the server list again and it’s empty. This has been my cycle for the last 3 times I’ve launched the game. This may be an issue on Steam’s end, but I would think that once a connection has been established to the server, Steam is sort of “out of the picture.” Though, I could be wrong (not sure if Steam’s inner workings).

    Unfortunately, because the game does not crash, no .dmp is generated. However, I have attached the log files for two separate times this has occurred.

    So for now, I can only play for a handful of minutes at a time, then I need to exit the game and restart Steam as a quick fix.

    Subsequently, I did a “verify integrity” check on Steam and 1 file failed, “CharTextures.tfc” located in the “Steam\steamapps\common\chivalrymedievalwarfare\UDKGame\CookedPCConsole” directory.



  • Gents, you can close this topic out if you want. I’ve run into the UDK.exe error a couple of times since my last post, but re-downloading the 1 or 2 files the somehow become corrupt off of Steam usually corrects the issue.

    Thanks for your quick replies!


  • Developer

    Yeah, I’d look at your memory (Windows 7 has a memory test built-in; punch “Windows memory diagnostic” into the start menu and try that) and hard drive for issues, and maybe do a stress test on your CPU (Prime95 or something) to make sure there’s no problems there. Sounds like it could be a nasty hardware issue that could end up corrupting something important eventually.


Locked