Dedicated Server Issue

  • Gday all, after reading through countless threads and trying different tips on how to fix dedi servers. I needed to post my own.

    Ok installed a dedi server on my local server box, as a test server (once tested we will get a pro hosted one) using steamcmd. All went fine and installed correctly. I then changed the ini’s to my prefered setup. Now the issue is launching the server.

    Im using a serverdoc to boot the server up, with the following command line.

    Run D:\cmew\Binaries\Win32\UDK.exe AOCTO-Battlegrounds_v3_P?steamsockets -seekfreeloadingserver

    The server console window does not even appear. I then tried using UDKGame.exe as suggested in another thread, still doesnt boot up. No console window whatsoever. I have also tried booting up the server not using a bat file, same results. I even updated the server box’s DX and .net’s to be safe.

    Any advice is welcome.

  • Hi M8

    I had a similar problem at first and it was the C++ libraries that was at fault. Further back I have posted a link for the vdesc files from Microsoft . It was the 2008 vdesc files that fixed mine and then I got the black console window.

    Just look back at my previous posts.

    Hope it helps


  • Thanks for that, but unfortunatly i had already done all that. Made sure ALL .net and c++ things were installed/updated.

    NOTE: I transfered all the dedicated server files to my personal PC to test.

    WITH UDK.exe, i got a console window, but it remained blank.

    WITH UDKGame.exe, the server booted fine.

    My personal PC is running Windows Vista 64-bit. And my server box is running Windows Server 2003 Enterprise Edition.

    NOTE 2: I thought id test another thing, and then transfered the dedicated server files to ALL PC’s in my house. Results.

    On ALL computers, UDK.exe does not work, console window stays blank. UDKGame.exe works fine.

    Computer 1: Windows Vista 64-bit

    Computer 2: Windows XP Pro

    Computer 3: Windows XP Pro

    Laptop 1: Windows Vista 32-bit

    Laptop 2: Windows XP Pro

    Server Box 1: Windows Server 2003 Enterprise Edition (This one doesn’t work at all)

    Anyone know why Windows Server 2003 wont boot the server at all? Because its odd. I am running alot of other test gaming servers on the same box without issue, some include,

    Killing Floor
    Age Of Chivalry
    Counter-Strike Source
    Half Life 2 Deathmatch
    Team Fortress 2
    Red Orchestra
    Modern Warfare 3
    Day Of Defeat

    And as i said, they all work fine without issue.

  • Developer

    The window coming up but remaining blank is normal.

    UDK.exe does not have logging enabled.

    UDKLogging.exe has logging enabled, and is otherwise the same as UDK.exe.

    UDKGame.exe is the release executable which is only any good for debugging crashes. It will have considerably worse performance than either UDK.exe or UDKLogging.exe.

    I’m not sure what’s causing the Server 2003 issue right now…

  • Firstly, thanks for taking the time looking at this post.

    Secondly, Right you are, i launched the server with UDK.exe on a win xp install, and sure enough its there in HLSW (what i track it from). It is just unusual to me that a console window remains blank after a server boot. NO OTHER server does that. It always fills with data.

    Anywho, It is a shame that you don’t have any clues for the server 2003 problem. But thanks for looking into it. Hopefully someone can come up with ideas. :)

  • Any ideas yet guys?

Log in to reply

Looks like your connection to Torn Banner Forums was lost, please wait while we try to reconnect.