Letter to the Devs/I am now a much happier camper than this

  • **I definitely foresee this being deleted, but whatever.



    Most important words emphasized down below yo.

    So far I have attempted every single fix that has been posted for the past two months now, I have reinstalled steam twice, hardwire my computer to the modem and uninstalled every single anti virus and firewall program on here. I even completely wiped and reinstalled my OS. Clean start, first things I did was remove the firewall and antivirus, download steam and install chivalry. Nothing. Didn’t work. I love how they instantly throw it at Steam the second they don’t know quite what to do.

    All I want is a working game. If you are unable to help me alright, whatever. Give me money back. I have spent well over 8 hours in the past few days attempting every thing I could possibly think of. The Devs have also stated in one of these threads that this isn’t something that really even needs a patch because the masterserver.vdk or whatever fixes it for most people and “its not that hard to do really.” Doesn’t matter, this was a very well known issue waaaaay back in the beginning of beta. I’ve seen countless posts on it. Why was it not patched? Why did they not spend a day out of the 40 since it was first mentioned trying to figure it out? You have sold me a broken, unfinished, falsely advertised game. This game is 100% unplayable with this bug, and yet you refuse to respond any help requests. In fact the only responses I have seen have been a copy pasted link to a sticky.

    The greatest thing is a couple of them have actually said they won’t even be patching this because the copy pasta masterserver list fix is sooper dooper easy and fixes the problem. So ya, if you’re one of the poor sods that it doesnt work for, NO GAME 4 YOU.

    Indie dev releases first game with a crippling bug that completely prevents the game from being played, and then refuses to actually put in a proper patched fix.

    PS: The only reason that they have such a huge lead in played time on steam stats vs WOTR is due to a bug that stops your game from fully shutting down. The UDK.exe or whatever in the taskmanager stay running for some odd reason, which causes Steam to view you as playing the game. I’ve apparently played 18 hours so far, when I’ve actually played maaybe 20 minutes, with an additional 40 added in from attempting to fix this game. I wouldn’t be surprised if they refused to patch this too, makes this steaming pile look like it actually works

    Edit! **This has been a known issue since early September. Let that sink in. They have know about a bug that literally prevents the game from being played, a month before they release the game, and they have yet to actually fix it. ONE MONTH.

    Dear Devs:**
    How can you justify releasing…nay, knowingly releasing a game with a crippling bug? I’d be completely understanding of not having a fix if this wasn’t a widespread well known issue. It doesn’t matter if there’s a workaround stickied, first it doesn’t work for everyone and second, that was posted while the game was in beta. There is absolutely zero reason that ANYBODY that purchases a fully released game should have to deal with a workaround for something that was discovered a month prior to release. Sadly, some people also do not possess the computer literacy to follow those instructions fully. Do they not get to play their game? I haven’t seen a reply from any of you for days, there isn’t any new on a fix on the horizon, nothing. Its like you’ve got your money and decided to tell your fans the get bent. I wonder how many Kickstarters contributors are currently cursing at their blank server browser? I guarantee there are at least a few of them. That’s pretty sad, these people go out on a limb to help a game get released and they’re absolutely pissed on my the development team. I don’t if you forgot this or not, but….
    Ignoring the people that put their money down for you without even a clue what the end product would look like is pretty damned saddening. Remember, crowd funding, right? What happens when you act like an asshole to the crowd that funds you? Oh right, you don’t have any crowd to fund you.

    Oh, I bought WoTR last night. Wanna know how that went? Well, I installed it, clicked play, clicked on multiplayer, then I clicked a server in the server browser and started playing! Amazing! Its like they actually made sure the game was playable! Isn’t that what beta is used for? For any of the faults that game may have, at least they don’t knowingly release games with crippling bugs. I’m very excited to see your next project so I can load the page, laugh, and close it, comfortable in the knowledge that I don’t support companies that pull this bullshit.

    good riddance, some shity excuse from the dev, its steams fault, you suck at computers, this games awesmum you idiot theyll totally get their next kickstarter, wtf you talking about, etc.

    And finally! We come to the end of this little rant of mine. I will leave you with one last message. People allllllreaaadddyyyy have found out about your refusal to fix game breaking bugs. Shit travels real quick on the internet. Have fun.

  • Bump. I would like to see a response as to why this bug hasn’t been fixed. Thats my ultimate goal. That, and either a refund or a functioning game.

  • Dear butt hurt WOTR fan boy,

    To fix your problems I would advise following these steps prior to your internet meltdown:

    Step 1: Contact the devs and ask for some assistance as their previously mentioned fixes are not working.

    Step 2: Realize that you don’t know jack shit about game development.

    Step 3: Understand that this is not a bunch of greedy assholes, but instead a dedicated team trying to bring their dream game to life. They run into issues just like any other game but lack the man power to tackle every bug every 5 seconds, so if its easily fixed on the client side in a solid minute, it’s clearly not a priority.

    Step 4: Sup?

  • I have played 3 matches of WotR and am the furthest thing from a fanboy. This games been in development around twice the time of WoTR and is by far the buggiest. Somewhere around 4 times as long if you include the original mod.

    1. I have been attempting to contact both the devs and Steam for the past three days for help on this and have not been helped in the slightest. All I get is either being sent to the other guys, or a copied link to a thread I’ve went through 10 times.

    2)I don’t need to know diddly fuck all about game dev to recognize that its a shitty thing to knowingly leave a game breaking bug in when you go full launch.

    3)This is not every bug every 5 seconds. This isn’t some minor little graphical glitch or clipping issue. This is a game breaking bug that has been known of for over a month. I am most definitely not the only one that is still trying to deal with this.


  • You should probably learn a bit of a diddly fuck seeing as how it’s not a game breaking bug. In fact, it appears you don’t know what a game breaking bug is. You seam to be an outlier which more than likely means what you think is a “quick fix they refuse to do” is in fact not and is related to something else entirely.

  • Its a bug that prevents a player from playing an online only game, online. I’d say its fucking broke.

    I find it quite neat that this account was created and then logged on less than a minute after b3h47pte logged out, and how you both have a highly similar style of typing and sentence construction. Probably just a coincidence.

    This is quite obviously not a client side problem either, or all these fixes would have fucking fixed it. If it was client side, there also wouldnt be a steam blame game. I’ve spent a very large amount of time carefully pouring over every single step over and over and over. Shits not working. The Steam blame also seems fishy, claiming their server issues are the cause of everyones problems, when every other game that uses the Steam Servers seems to run a-ok. I’ve yet to see a single dev say “Yes we are taking care of this, patch soon.” If you just do a quick google, you’ll find pages and pages of people wondering wtf is going on, stretching from a few months ago all the way up to a few hours ago. This is a widespread issue. This is what beta is for, so you have time to fix shit like this. There has been next to nothing done in regards to this “minor bug” for over a month.

    A pattern I’ve noticed is there is a distinct lack of accepting blame for problems. Its YOUR game, YOU designed it, YOU coded it, YOU are responsible to make it function correctly if you are going to sell it.

    EDIT: Grammar/Spelling

  • And if I am an outlier, with for some odd reason a broken whateverthefuckit that I cannot detect, fine. If they can’t either hot fix, patch, or show me some way to get this game functioning, it is most definitely not a a ridiculous request for a refund. I’ve been extremely patient with this and I’ve finally had enough. I have spent well over 8 hours now trying to get this game to work. 8 hours. I fucking wiped and rebooted my entire computer for fuck sakes. I have a right to be a bit upset, its also disheartening to watch three separate posts skipped over by mods/devs. Although I don’t believe that was intentional.

    Also, reading back, perhaps going so far as accusations of greed and money grubbing are a bit far. My apologies.

  • Yeah, so notamused, you’re a little rude in your post, but you’re rightfully pissed, I know how frustrating is it to try 7000 fixes to a game and have them all not work so w/e, just don’t accuse the devs, that won’t make them help you.

    Amused, you contribute nothing to the thread. Notamused has a problem, and he’s mad about it, and you come in and just throw insults back. Way to make the community look good. This is a small game and small communities need to be taken care of lest they fall apart. (See Section 8: Prejudice for a game that fall apart for numerous reasons including these).

    Mods pls don’t lock untill the guy has actually had his problem fixed.

  • May i ask what your computer specs are?

  • Developer

    Hello mate,

    Sorry to hear the game isn’t working well for you. Where did you make your purchase? (affects if a refund is possible or not)

    You are obviously upset and understandably so, if you have paid for something that doesn’t work. The problem in this case truly is that we don’t understand why it doesn’t work for you. Let me attempt to explain…

    The master servers list thing actually is a Steam Issue, we would never, ever blame them if we haven’t gotten a direct email from them admitting the issue. Also, our game works on Steamworks- which means we use Steam for our backend. I don’t want to get too technical, but basically not every steam game uses Steamworks (relatively few of them do actually), and so that is why not every game has this issue. We have determined that this fix is working for the vast majority of people having issues not being able to see servers- that is why we link to it so often.

    That issue in and of itself is actually also effecting only a small group of users and has actually already been identified and fixed by Steam if you are running the Steam beta client (although they have yet to rollout the update to everyone else for reasons unknown).

    So hopefully that explains why we chose to release the game knowing about an issue that effected a small group of people and was in Steam’s hands to resolve. Now, of course that doesn’t really do any good in helping you, so let’s look at that.

    Here is perhaps a crude, temporary help in the meantime to help you at least be able to play:

    http://www.game-monitor.com/search.php? … rf&num=100

    Get to the main menu, open the console with the ~ key, and type: open ipaddress . That should at least let you play.

    And as much as you hate being linked to this sticky, we just updated it with a new fix, so its worth a shot trying the new one:


    We will continue to update that sticky with all possible known solutions, if the solutions there somehow don’t work for you, then hopefully we will find another solution soon. We are trying to help, but unfortunately for some reason you are having a very specific issue if those listed fixes aren’t helping you. We’re still working on fixes and doing what we can though, so apologize for the inconvenience for you I know it must be a very frustrating experience, we are trying to help but there are a lot of variables in what could be going wrong that makes it a particularly tricky issue to troubleshoot.

  • My sincerest apologies, I came across extremely rude. I’ve never had to jump through so many hoops to get into a game, and after over 8 hours, well I just was not a happy camper. I do want to play this game, honestly. Even from the bot battles I feel like it is a more engrossing game than WoTR. I’ll give those a shot in the morning, hopefully they work. If not, well then I guess I wait.

    I will admit I allowed my pride to better me, so far this is the only game that I haven’t been able to fix myself. I really really really want to play it, or I wouldn’t have put that much effort into it!

    I’m legitimately surprised to hear such polite kind words, even after I stepped all over you. I forgot that you aren’t a big huge money hungry corporation in my anger, rather a group of guys with a dream for an awesome game. You guys are a fairly small team that came from a mod, dealing with this many bugs and issues must be overwhelming. I was also misunderstanding the Steam server issues, my apologies again.

    I do hope you forgive my lapse of judgement, all the best. I’ll be over here facepalming.

    This here is my computer, just purchased last month
    http://ca.msi.com/product/nb/GT70-0NC-0 … cification

    I will patiently wait, hopefully when this is figured out it can be of some help to you guys. If you would like any info from me, just ask and you shall receive.

  • Tomorrow I’m also going to do a fresh install of Steam and Chivalry and patiently work my way through each fix. In my anger, I may have been making foolish mistakes.

    I just want to say that you guys have really astonished me. I never would have expected such a polite and helpful response to what basically amounted to a public attempt at shaming.

  • Third and final reply for the night. I quickly attempted the quick crude fix, and nothing. The game does nothing after the command is entered. This leads me to believe that for some reason, I cannot think why, Chivalry has absolutely no access to any internet connection. I’ve tried firewall/virus stuff already.

    Any ideas?

  • Hi Notamused,

    I am certainly not insulting your intelligence as you did claim to have tried all fixes on the forums, but just to confirm have you tried all steps here on this thread (Also present in the compilation of fixes/solutions that Tibberius provided a link to in his post): http://www.chivalrythegame.com/forums/viewtopic.php?f=69&t=2075

    I am more than sure that the developers can understand and emphasis with how you are feeling, a lot of stress and frustration can build up. I am also very positive that they will do what ever they can to help you.

    Best regards

  • Can Totally understand <notamused>frustration! But also appreciate the replies from devs. I’ve got the same issue and am a developer myself, hope you guys can sort that stuff out soon so we can all enjoy this game. I’ve got a few mates thinking of buying this as well and the only thing that’s stopping them is the fact that I’ve mentioned this bug/issue to them. So hopefully you’ll get this fixed up, afterall - happy players bring more happy players</notamused>

  • Confirmed as following all suggestions on this thread, and on the relevant stickies. Even the “crude fix” direct connect with the console commands doesn’t work. I type in the command, hit enter and nothing, No connection, no response from the program, nothing.

  • Developer

    No worries, we all let emotions get the better of us sometimes. Especially when money and computer issues are involved.

    The fact that you can’t even join by ip address is very strange, can you paste me an example of exactly how you are inputting that just so I can double check?

    When you launch the game, does your steam friends display you as playing the game?

  • tl;dr. its probably just you. when it comes to computers, I always blame the user. then again I work in IT and got massive experience with idiots who claims they didn’t do anything wrong. afaik the majority plays Chivalry just fine. its a minority that struggles…

  • I have tried the following:
    open xx.xx.xx.xx:xx
    /open xx.xx.xx.xx:xx
    \open xx.xx.xx.xx:xx
    open: xx.xx.xx.xx:xx
    /open: xx.xx.xx.xx:xx
    \open: xx.xx.xx.xx:xx

    In all cases I get

    connect xx.xx.xx.xx:xxx<<<
    As a response.

    My steam list is displaying that I am online and in game with Chivalry.

    I went through the sticky another time, reinstalling both Steam and Chivalry prior to each fix, and all failed.

    I went into the Resource Monitor and can confirm that Chivalry/UDK is neither connected nor attempting to make a connection. I tested with Torchlight 2, CS:S and Warband and can confirm that they are all able to connect. Steam is also connected.

    And it may be me, who knows. I’ve spent 8 hours attempting to follow 5 fixes that are extremely simple to follow. I’m not IT professional, but I have been building and fixing computers for a number of years. Everyone makes mistakes though.

    EDIT: Mistakes made. I tried open ipaddress xx.xx.xx.xx:xxxx and I was greeted with a “Connect to the host has failed.” message when I exited the console. I have tried this on 4 servers so far, and am receiving the same message

  • I’m not sure if this will help any, but this is a screenshot of the monitor with Torchlight 2 in-game and Chivalry launched sitting at the empty server browser.


Log in to reply