How to set up a visible listen server



  • I have read through all I could find, and can get a listen server to run, and I can connect to it. I can login as admin, add bots, restart the map, etc. I have no idea though if the server is visible on the server list. Would I be able to see it if I am playing on the machine that is hosting the game? I also commented out (with a smeicolon) all of the maplist in DefaultGame.ini except the one map I wanted the server to run (AOCFFA-Arena3_P), but when the match ends, it proceeds to another map.

    Would (should?) the setup I have outlined here start up a listen server that is visible to the outside world in the game’s server list? As of the writing of this post, the listen server has been running for at least 10 minutes, and has not shown up for me on the game’s server list or on http://www.game-monitor.com. Also, how do you set up a map rotation, since the one in DefaultGame.ini doesn’t seem to work? (even though the file contains a maplist!)

    I currently have a shortcut to UDK.exe on my desktop with the following target line:

    "C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe" server AOCFFA-Arena3_P?listen -port=7777 -QueryPort=27900
    

    Both of the ports are opened in my firewall, and, for the heck of it, I put my machine as the DMZ.
    I changed the server name and MoTD, and added my admin password in the DefaultGame.ini file, and have no way of knowing if the server name worked.

    For the benefit of others, I added the following to my DefaultGame.ini file, and have confirmed that GamePassword and AdminPassword work:

    [Engine.GameReplicationInfo]
    ServerName=MY_SERVER_NAME
    MessageOfTheDay=MY_MESSAGE
    
    [Engine.AccessControl]
    GamePassword=My_GAME_PASSWORD
    AdminPassword=MY_ADMIN_PASSWORD
    

    Opening the console with the ` key, I can do the following:
    Connect to the game by entering

    open 127.0.0.1?password=MY_GAME_PASSWORD
    ```Login as an admin by entering
    

    adminlogin MY_ADMIN_PASSWORD

    Add bots by entering (where # is a number, not a symbol)
    

    Admin addbots #

    My goal is to be able to host a small-ish game for my friends and I, or a small to medium public game on occasion.
    Thanks!


  • Hey so I was having the same issue somewhat. No one could join behind my firewall. I added the multihome line to my startup cmd line.

    "C:\Program Files (x86)\Steam\SteamApps\common\chivalry_ded_server\Binaries\Win32\UDK.exe" AOCLTS-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015 -multihome=192.168.1.125
    

    I then went to Steam->View->Servers and I saw my server up and running under the lan tab. Then I added my server to favorites by external IP and it showed up fine. After leaving it running for a few mins it got loaded into the ingame server list. Make sure 7777, 7778, 27015 are open.

    About the map rotation I had the same issue. I commented out all the variables except arena in defaultgame.ini. I just discovered there is a maplist in PCServer-UDKGame.ini so I’m going to try with that one now. Good luck.



  • @stacks:

    Hey so I was having the same issue somewhat. No one could join behind my firewall. I added the multihome line to my startup cmd line.

    "C:\Program Files (x86)\Steam\SteamApps\common\chivalry_ded_server\Binaries\Win32\UDK.exe" AOCLTS-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015 -multihome=192.168.1.125
    

    I then went to Steam->View->Servers and I saw my server up and running under the lan tab. Then I added my server to favorites by external IP and it showed up fine. After leaving it running for a few mins it got loaded into the ingame server list. Make sure 7777, 7778, 27015 are open.

    About the map rotation I had the same issue. I commented out all the variables except arena in defaultgame.ini. I just discovered there is a maplist in PCServer-UDKGame.ini so I’m going to try with that one now. Good luck.

    Awesome, thanks for the reply! I was under the impression that multihome was only necessary when there was more than one server being run on the network. Maybe it is needed if there is more than one DEVICE on the network? I’ll add that to my shortcut’s target line and give it another shot tonight. I’ll update with the results.



  • It’s possible it’s not even needed. I was trying everything guess and test style until I got it working. This finally got it working.

    Before I added the multihome line my server would only show up in the lan tab, I couldn’t see it by my external IP. After adding it I was able to see my server through the external IP.

    On my router the ports are open and forwarded to that specific IP address 192.168.1.125. They aren’t open for all the computers behind firewall.

    Good luck and post back to let us know if you have success.



  • Using -multihome, I cannot connect to the server at all. Just to be clear, I am attempting to run a server on the same PC I am playing the game on. Back to the drawing board…



  • @Eclipse:

    Using -multihome, I cannot connect to the server at all. Just to be clear, I am attempting to run a server on the same PC I am playing the game on. Back to the drawing board…

    Leave out the -multihome switch, I also used it and it caused more trouble for me than anything else.

    Here is my coop (bot server) command line I use:

    AOCFFA-Arena3_p?lan?numplay=16 -port=18000 -QueryPort=27023 -seekfreeloadingserver
    

    I run two servers at the moment, a multiple gametype mode server and a co-op server with bots on the same machine, using the same IP address. Both of them are visible in the server list and myself and others can join them without problems.

    There are two differences between my normal and coop server.

    a) The port and queryport numbers that are different from each other
    b) For the coop server I use the ?lan switch as you can see above, whereas the normal one says dedicated with an additional ?steamsockets switch too.

    If you use my command line above, with your relevant port numbers (also open them in your firewall) then your listen server should be visible in the server browser, no problem ;)



  • @StoneCold:

    @Eclipse:

    Using -multihome, I cannot connect to the server at all. Just to be clear, I am attempting to run a server on the same PC I am playing the game on. Back to the drawing board…

    Leave out the -multihome switch, I also used it and it caused more trouble for me than anything else.

    Here is my coop (bot server) command line I use:

    AOCFFA-Arena3_p?lan?numplay=16 -port=18000 -QueryPort=27023 -seekfreeloadingserver
    

    I run two servers at the moment, a multiple gametype mode server and a co-op server with bots on the same machine, using the same IP address. Both of them are visible in the server list and myself and others can join them without problems.

    There are two differences between my normal and coop server.

    a) The port and queryport numbers that are different from each other
    b) For the coop server I use the ?lan switch as you can see above, whereas the normal one says dedicated with an additional ?steamsockets switch too.

    If you use my command line above, with your relevant port numbers (also open them in your firewall) then your listen server should be visible in the server browser, no problem ;)

    So I guess the Unreal UDK.exe guide I found on Google was outdated, it said to use ?listen, not ?lan.
    Are you able to host and play on the same PC? That is my goal with all this. Thanks for the reply!

    Also, as an add-on, what is the deal with the ?parameter vs. parameter??
    Never mind, found a much better guide!
    udn.epicgames.com/Three/CommandLineArguments.html



  • i was able to create server with password and play on it at the same PC

    UDKLogging.exe" AOCFFA-Arena3_p?steamsockets -seekfreeloadingserver -port 9987
    

    i dont know why but with UDK.exe i was unable to make visible server….
    only with udklogging.exe it work

    then i just launch game and join my server with friends… dont know if that help you somehow



  • Hey man my setup is to play and run off the same pc.

    So try my line without the multihome command. Once you have your server up and running log into steam go to
    view->servers->lan and see if yours shows up. Click refresh. I was able to get mine showing up here from the beginning without messing with ports etc. It was when I wanted friends to be able to see it I had to add the multihome line and open ports.



  • Can you please try with this line exactly.

    "C:\Program Files (x86)\Steam\SteamApps\common\chivalry_ded_server\Binaries\Win32\UDK.exe" AOCLTS-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015
    

    I had my server start with this line and I was able to see it from my lan tab in steam locally. Try to get it working like this, then if we get it working you can start changing stuff around. Let me know if it works.



  • @stacks:

    Can you please try with this line exactly.

    "C:\Program Files (x86)\Steam\SteamApps\common\chivalry_ded_server\Binaries\Win32\UDK.exe" AOCLTS-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015
    

    I had my server start with this line and I was able to see it from my lan tab in steam locally. Try to get it working like this, then if we get it working you can start changing stuff around. Let me know if it works.

    I want to be able to see it in-game, not in Steam’s server browser, if that makes a difference. Trying it though, I’ll update this reply with the results.



  • @stacks:

    Can you please try with this line exactly.

    "C:\Program Files (x86)\Steam\SteamApps\common\chivalry_ded_server\Binaries\Win32\UDK.exe" AOCLTS-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015
    

    I had my server start with this line and I was able to see it from my lan tab in steam locally. Try to get it working like this, then if we get it working you can start changing stuff around. Let me know if it works.

    It WORKS!! Shows up in the game’s browser and in the Steam list, and I can join! The only thing that I had different when I had it at least running and letting me in was the port number. Apparently the Query Port, even though I had the switch set to 27900 in the target line, was still being set to 27015 by the game. Must be an .ini file that trumps the startup parameters.

    THANKS FOR THE HELP!!! Hopefully others can actually join, lol



  • I think the listen port is set in the pcserver-udk file.

    Glad to see it is working. If it’s showing up in the game server list the firewall sound like it’s all setup proper. Good stuff man!!!



  • @Eclipse:

    @stacks:

    Can you please try with this line exactly.

    "C:\Program Files (x86)\Steam\SteamApps\common\chivalry_ded_server\Binaries\Win32\UDK.exe" AOCLTS-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015
    

    I had my server start with this line and I was able to see it from my lan tab in steam locally. Try to get it working like this, then if we get it working you can start changing stuff around. Let me know if it works.

    I want to be able to see it in-game, not in Steam’s server browser, if that makes a difference. Trying it though, I’ll update this reply with the results.

    Yes I understood that. However IMO its best to get it working stable locally so you can see it on the lan tab. After than you can make the changes you need to have it accessible from users outside your lan. Glad it is working for you and sorry I answered these last 2 posts in the wrong order lol.



  • @stacks:

    I think the listen port is set in the pcserver-udk file.

    Glad to see it is working. If it’s showing up in the game server list the firewall sound like it’s all setup proper. Good stuff man!!!

    Yeah man, all working. Edited the PCServer-UDK.ini file, changed the server name, maplist, teamdamage, maxplayers, started it up, then went to play somewhere else. Checked it in the server list in-game after a while and it had 3 people in it, so I hopped in and played. All is well. Hopefully more of my buds will pick this game up and I actually end up having a use for the server, lol.

    Thanks again!



  • And how u connect to your server after add this line to .exe?

    When i try connect it say “lost the connection with the host”



  • @Yogh:

    And how u connect to your server after add this line to .exe?

    When i try connect it say “lost the connection with the host”

    I either connect through the in-game server browser or with the following console command which connects you to your own PC:

    open 127.0.0.1
    ```If you or others can't connect, there is some other issue, maybe your firewall is blocking the ports?


  • Ok, so I tried to launch a server using this command added to the shortcut and it just loads the game in a tiny minimized window. I thought this might have been a dedicated server so I tried to load a second copy of the game to connect but it won’t let me. Am I missing something?



  • @TorQueMoD:

    Ok, so I tried to launch a server using this command added to the shortcut and it just loads the game in a tiny minimized window. I thought this might have been a dedicated server so I tried to load a second copy of the game to connect but it won’t let me. Am I missing something?

    same here

    I added inbound outbound rules in firewall for 7777,7778,27015
    I enabled them as virtual servers in router, I added them in port triggering also and in DMZ I added my PC which is 192.168.1.100

    but still I can see my listen server only in LAN not on internet in Steam server browser

    I am noob in server/LAN things
    if anyone can write simple instructions how to set visible listen server so anyone can join me, pls help



  • Are you sure your server is using the 27015 port? Or the 7777 port?
    It might be using one above it.
    Setup TCPView on the pc running the server and use it to check what ports are used.


Log in to reply