Game is nearly unplayable



  • Was there a hotfix or patch that created a new bug? 1/3 of my rounds are ruined because I either can’t use my primary weapon or my character can’t do ANYTHING but WASD, the arms get frozen in position and I’m helpless for the entire round.



  • Are you using a shield and trying to equip fists?



  • Noticed it the most playing archer using warbow/cudgel, never tried to pull out fists.

    I also noticed it a bit with javelins and when i was playing knight, not sure if I was switching to a shield but it happened plenty when I was just swinging or sometimes in the middle of a sprint.

    Just happened on LTS Arena, I spawned, sprinted to the gate, tried to draw my bow and my character got locked. Couldn’t switch weapons, use Z shouts, kick, etc



  • I have only had it happen with the javelin, which is already known to be buggy and already in the works for a patch that should be coming in the next couple weeks, according to the devs. In the meantime, I just don’t use the javelin. They’ve already committed to fixing it in the next patch, so chances are they already have it done but, of course, are bundling it with many other fixes. Hopefully this patch sorts all the little wonky issues out. Good luck on your issue, see you on the battlefield :)



  • happens to me on archer, I like to run around trying to whack people in the back with daggers and sometimes when I switch back to whatever bow or xbow I have equipped it just freezes and is unsable just like this,


Log in to reply