Server Ports [Server only showing up in "Lan" tab]



  • Hi There,

    I’ve been trying to set up a server for some time now but I can’t get it to work properly.
    The Problem boils down to this: The Server is up and running - no errors appear in the log files.
    I can connect to the server via “open 127.0.0.1” or “open 192.168.0.2” (my local IP).
    However I am unable to connect via “open” followed by my external IP.

    The problem is mirrored in the steam UI: The server is listed in LAN but not in Internet.
    Adding my external IP to my Favorites results in a dead Server Entry i can’t connect to.

    I’m guessing there is something wrong with my port forwarding.
    I’ve forwarded 27015,7777 and 7778 which are set in my ini files accordingly.
    To be sure i forwarded both TCP and UDP.

    I’ve tried serveral command-line options (including none and starting the server via steam) and nothing has resolved this issue so far.
    The multihome parameter is mentioned often but the way I see it this is only useful when dealing with multiple interfaces on the same machine (which is not the case for me) and has nothing to do with your external IP like stated in some posts.

    My current configuration looks something like this:

    AOCTD-Moor_p?steamsockets?maxplayers=16 -seekfreeloadingserver -Port=7777 -QueryPort=27015
    

    I am working on a Windows 7 Professional x64 machine with other servers running just fine (ts3 / http).
    I’ve got no clue what might be causing this problem but any help is appreciated. Are there any ports I’m missing?!

    Thanks!



  • Update: Most people seem to be able to join my server both via steam and ingame.
    However a few remain unable to see and/or connect to my server.

    I changed nothing, still I can only see the server as a LAN server (which might be caused by trying to play on the same machine the server is hosted on).



  • Are you running the server from the game’s executable or the dedicated server files executable? Also, do you have all 3 ports open in your firewall (7777, 7778, 27015)? These two things, along with the target line for the executable posted below, work for me:

    "C:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win32\UDK.exe" AOCFFA-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015
    ```With this setup, my server shows in the Steam server list under the LAN tab, and also in the in-game browser, and, to my knowledge, there are no issues with people not being able to join.
    
    Keep in mind that the browser in-game has issues, and a complete rebuild will apparently be in the next patch due in roughly a week or so.
    
    Good luck, and thanks to all who helped me with mine!


  • I don’t even have a firewall except the one build into my router which is forwarding all 3 ports.
    The in-game browser is bugged - that’s for sure. But it confuses me that I’m still not able to view my server in the steam online servers section.
    Anyhow, most people are able to join the server (i am able via "connect 127.0.0.1) so it seems to be kinda working :D

    Thanks for the help!


Log in to reply