Servers hang shortly after joining them. [fixed?]



  • When I try to join a server today I can get in OK, I spawn, then the server hangs. I can move about but all the players stop moving. I’ve tried more than a dozen servers all the same problem.

    I had this occasionally yesterday but I could usually find a reliable server. Today nothing. They all hang after less than a minute joining.

    EDIT: OK, problem solved. I installed an auto update for NET framework, and it seems to be working fine now. 8-)



  • i got the same problem, im gonne try the NET framework and see if it works.



  • @mr_Suicide:

    i got the same problem, im gonne try the NET framework and see if it works.

    It looks like I spoke too soon. I just tried 3 servers and all of them locked up on me. The two I had working seemed like flukes.



  • Having the same issue :<



  • I’m having the same problem or i get when trying to join in duplicated UID …. really wish i could get my money back…



  • Is this actually a .NET issue though???



  • I don’t think so. I just happened to do a .NET update, the next two servers I joined worked. Then most of the servers after that didn’t so it looks like coincidence.



  • hmm, same here, sometimes it hangs and people keep running inplace, at first i though the .NET update fixed it, but as said above, after a few games it happend again.

    I think i found a temporary fix to it, everytime i boot up the game i first delete the Masterserver file in the steam folder.(Steam/config) and that kinda helps. it seems random tho…



  • Port forwarding seems to work. I’m not very technical so I don;t know if any of what I did is redundant. Can anyone with connection problems test to see if they get the same results?

    I disabled all port forwarding for other games.

    I set up forwarding for these ports for chivalry:
    TCP 27015 - 27015
    UDP 27015 - 27015
    TCP 9989 - 9989
    UDP 9989 - 9989
    TCP 1000 - 4999
    UDP 1000 - 4999

    Without forwarding went through over 20 servers and 10 of them locked up. All of them seem to have a lag spike after I spawned.

    With forwarding I went back to the servers that lagged out and they all worked, no lag spike, no lockup.

    I tried 15 other servers as well earlier with forwarding, no problems.



  • TCP 1000 - 4999
    UDP 1000 - 4999

    Any particular reason you opened that massive range of ports?



  • Yup, because the servers use a massive range of ports.



  • I’d honestly suggest closing 1000-4999, or least close them and try the game without them and see if you don’t lock up anymore. The majority of servers will start at 7777 and your router will generally automatically open those ports.



  • Sure, I’ll try that tomorrow.

    I was trying the nuclear option since I wasn’t sure what would work.



  • I have a fix that works for me every time. I used to use it for RO2 when I had similar problems.

    Connect to any server, wait for the connection problem and everyone to lag out, then open the console and type reconnect and enter. After reconnecting it works fine. It’s a pain but it works.



  • With the port forwarding I don’t seem to get any lag problem when I join.

    Don’t know if it’s worth mentioning but the half a dozen servers that I checked the ports for were all in the range 1000-4999.

    Also I found this in the steam forums:

    http://steamcommunity.com/app/219640/di … 253971815/



  • I disabled port forwarding for ports 1000 - 4999 and the game started freezing again.

    Enabled forwarding for that range of ports and it started working. So it looks like it’s all or nothing.

    I had a look at the telnet fix, but at the moment I can’t connect to my router from the cmd prompt so I’ll have to crawl through google.

    I’m using a BT router incidentally.

    EDIT: Going by what I’ve read I can’t use the Telnet fix because the BT home hub won’t allow Telnet to connect to it. So it is either port forwarding or reconnecting from the console from my point of view.


Log in to reply