AoC Crash Error? Client.dll Init() in library client failed.



  • Client.dll Init() in library client failed.

    Not sure how to fix it so if anyone has some advice, It would be appreciated.



  • I just retried to install the mod and I still get the engine error.



  • How long have you had this issue? Have you been able to play AOC before?



  • Edit: I think my Age of Chivalry folder was corrupt and caused the problem so I deleted the folder and and copied over my brothers and It seemed to have fixed the issue. I think a server I tried joining was requiring me to dl a lot of files so I quit out during the download so I think it corrupted my folder and was causing the errors.



  • http://www.dll-files.com/dllindex/dll-f … tml?client

    The solution to your problem lies in the above link. Try it and it will solve the issue.



  • Hello, i finally managed to find this game, played it when i was a kid. I downloaded it from steam, but when i launch it in get the client.dll crash error. And the post above^ , where do i put the client file? Please answer soon, i wanna play the game 8-)



  • I had the exact same issue and I solved it without downloading any .dll files. Simply shut down Steam and start it up while running it as an administrator!

    (Kinda old post, I know - but it may help other players with the same problem(s))



  • SOLVED Try this, as this has proven to fix quite a few issues with Steam. Go to your Steam folder and delete a folded called CFG or Config then restart Steam. Steam will rebuild the folder. You will have to manually log in to Steam. You can also delete your ClientRegistry BLOB file as steam will also rebuild it. Both of these have worked in fixing problems that occur after new steam updates that mess with the mods config. Good luck


Log in to reply