Game lags out a few seconds after joining [fixed?]



  • About 10-30 seconds after I join a server every player stands still and does the running animation (sometimes they just continuously run forward). This happens with every server I join.

    I have tried re installing Net Framework and this fixes the problem for about an hour and then the bug repeats itself (I have also tried upgrading and downgrading Net Framework)

    I have also tried lowering my steam ping in steam settings to 250 but this does nothing.

    Any advice would be appreciated.



  • This happens to me very often as well. I would keep joining different servers and eventually, i’ll be able to play normally.

    No idea why this happens and is annoying the hell out of me!! I only have time to play in short bursts and this wastes a lot of time!!!



  • Hopefully the issue gets resolved soon so I can go back to decapitating peasants



  • Heres a fix posted by a user on the steam forums

    This is an age-old problem with Thomson manufactured routers and not the game. The port that Steam uses to look for servers triggers a faulty rule on the router and disconnects any connections made within 60 seconds of it being triggered. They aren’t interested in fixing it. A lot of ISPs use re-badged Thomson routers. You’ve got a few options:

    1. When you time out open up the console with the ’ or ` key and type reconnect. You should reconnect to the server and be able to play fine.
    2. Wait longer than 1 minute after refreshing the server list to join the game.
    3. Join on friends through Steam.

    Credit goes to Morello



  • @Pale:

    Heres a fix posted by a user on the steam forums

    This is an age-old problem with Thomson manufactured routers and not the game. The port that Steam uses to look for servers triggers a faulty rule on the router and disconnects any connections made within 60 seconds of it being triggered. They aren’t interested in fixing it. A lot of ISPs use re-badged Thomson routers. You’ve got a few options:

    1. When you time out open up the console with the ’ or ` key and type reconnect. You should reconnect to the server and be able to play fine.
    2. Wait longer than 1 minute after refreshing the server list to join the game.
    3. Join on friends through Steam.

    Credit goes to Morello

    I am also using a Thomson router, good find. I will try solution soon.



  • But I have been able to play it just fine when the game first game out. This problem just surfaced within these 2 weeks.



  • Pale Steel’s solution worked for me.

    Video instructions http://www.youtube.com/watch?feature=pl … 8YiopTocPk

    You can skip to 3:20


Log in to reply