[Bug] right mouse click



  • My right mouse click make a hudge move of camera even i dont bind it.
    despite i want to use it i can’t and you are the only game that does this kind of thing
    my mouse is a Nexus 8500



  • NEED ANSWER THX



  • I’d love to help you in any way I could, but I really don’t understand you… could you maybe explain it clearer? or use google translate to translate your problem in your first language?



  • when i use right click it’s make me look up sky or down well it makes my view move also, even if don’t move mouse so i can’t bind anything because when i parry for example i can’t choose where to parry cause it moves at each click



  • Did you try resetting the controls to their default settings?

    If that fails, try removing the chivalry folder under my documents and restarting the game. That should revert all settings to their default.



  • done not changing anything



  • Sure your mouse isn’t broken?



  • new and only this game is not working fine



  • i love to pay a game that so fukin bugged that i can’t play …
    no one read this forum because those people don’t give a fuck about your pb
    never seen so much bug inside with so poor answers
    i m pissed 3 days no parry !! deal with it can’t play anything



  • Tried binding the block to another mouse button?

    Also as a last resort you can bind the block key to a keyboard key.



  • Have you tried a different mouse to see if the mouse you’re using isn’t faulty? It seems like you are the only person with this problem at the moment.



  • what do i do with right mouse click wich is instinctivly used in all game ?
    and why don’t fukin fix it ?
    in all games that i play none have this bug so why they just don’t read this forums ?
    i m pretty sure it’s only a line to correct in the code
    and even i play parry on a keybord do you find it easy to pary and move as it were on your mouse ?



  • Yes. Using a computer is instinctive. Not learned.



  • i binded it to a keybord so you find it usefull as right button to parry ?
    and why the support never here to listen the customers that payed the game for playing at least with no bug of that kind i admit a game can be bugged but that much that’s not taking care of us, and why they can’t fix it , are they even read the post here ? …
    no clue… i uninstalled it and dl it again i change mouse, i try to go for changing to older driver etc… nothing change so it’s theyr side that they have to improve the game



  • So you are saying you tried a different mouse and you have the exact same problem?

    You could try plugging the mouse in another port.

    Also, something I would try is reversing the binding for the left and right mouse buttons, so you are blocking with the left button and attacking with the right button, and see if the problem crops up if you use the right button to attack.



  • I really, really think you should learn how to explain yourself better mate…



  • Sounds like a hardware problem. Last time I had a problem like this it was the mouse that was broken. Pressing the right button would make the cursor skip across the screen.



  • This is not a hardware issue, as I am having an identical problem. The OP just failed to explain it very well. This is also occurring with middle click for me, but since middle click is not utilized in Chivalry its not as much of an issue.

    When you right click, regardless of bindings, the camera will jump to a seemingly random direction. This makes using parry a pretty masochistic act, unless you rebind it to the keyboard instead (which is incredibly inconvenient and takes forever getting used to).

    When right click and middle click is completely unbound to all commands, it will still do the same when clicked. Resetting all key bindings doesn’t solve it. I have 3 mouses of different brands, all of which acted the same. Changing the USB port didn’t help either. What is especially peculiar is that I have not had this issue the last time I had played this game about a week ago.

    Tried doing full screen, tried 3rd person mode, none of it is fixing this problem.

    Seems to be a very uncommon issue, but nice to see that I’m not the only one suffering from it, meaning it deserves some degree of attention.


Log in to reply