Can't play the game



  • We all know the steam autumn sale just came around. I thought why not buy the game while its on sale? So I went ahead and bought it. I go through the download process and click play. After a few minutes, without me even seeing anything but the banner, the game turns to a black screen and stays that way. I have an ATI Radeon HD 2600 XT running windows 7 64 bit. According to a site that checks if hardware works with certain games, my driver works with chivalry. So why do I keep getting a black screen? Any help would be great.



  • Make sure that your drivers are the latest.

    If you set the launch property to “-windowed” in Steam without the quotes, does it work? Right click Chiv in your game list, click properties, click Set Launch Opetions, and type in “-windowed” without the quotes.



  • I still got a black screen. My driver can’t be updated anymore. I even tried switching to the beta of the game with no luck. Any further help would be greatly appreciated.



  • @goldenness:

    I still got a black screen. My driver can’t be updated anymore. I even tried switching to the beta of the game with no luck. Any further help would be greatly appreciated.

    Can you attach the log file in case it says anything useful in there and a DxDiag.txt?

    “My Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs\Launch.log”

    Hmmm, what if you change the .ini settings to start the game at a lower resolution? By default it pumps it way up. Try something small like 1024x768. There are multiple resolution attributes. I believe that you just need to change the first ones that you find under the “SystemSettings” heading.

    “My Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKSystemSettings.ini”

    ResX=1024
    ResY=768
    

    Edit:
    Try reinstalling DirectX. Uninstall it completely and rerun the redistributable installer that came with Chiv.



  • Hello, really appreciate the help. The launch file has been attached. Can’t seem to find the DxDiag.txt though. About to try the .ini settings technique, and the uninstalling DirectX technique. Will update with results.
    Thanks again.



  • @goldenness:

    Can’t seem to find the DxDiag.txt though.

    Click start menu, type in “dxdiag” without quotes, and run the app the shows up. After the little green progress bar finishes loading, click the button to save all the information. That will generate the DxDiag.txt.



  • Thank you. Attached the DxDiag file. However, I can’t seem to find DirectX in my control panel to uninstall it.



  • @goldenness:

    Thank you. Attached the DxDiag file. However, I can’t seem to find DirectX in my control panel to uninstall it.

    Neither can I. Seems that I have made a mistake. I guess it would make sense that you cannot uninstall it in Windows 7 since the aero interface uses it… :|

    Edit:
    Looks like your graphics driver is indeed out of date (unless I’m reading it wrong). The DxDiag says your driver is from 2009 when the latest for your card is 7/2012. Grab the new driver here and report back if it fixes it.

    http://support.amd.com/us/gpudownload/w … sta64.aspx



  • Still no fix I’m afraid. It said all my drivers are up to date.



  • @goldenness:

    Still no fix I’m afraid. It said all my drivers are up to date.

    Just for sanity’s sake, have you tried uinstalling the video drivers (completely uninstalling catalyst control center) and reinstalling?



  • There’s a “Catalyst Install Manager” in my control panel. Should I try uninstalling that, or is there something else I should be uninstalling?



  • @goldenness:

    There’s a “Catalyst Install Manager” in my control panel. Should I try uninstalling that, or is there something else I should be uninstalling?

    Sounds like uninstalling that should do it… follow along here: http://support.amd.com/us/kbarticles/Pages/GPU57RemoveOldGraphicsDrivers.aspx



  • Sigh…tried uninstalling and reinstalling without luck. It would now seem that another game I own, dungeon defenders is giving me the same issue. I know for a fact that game worked like a charm yesterday. Any other ideas?



  • @goldenness:

    Sigh…tried uninstalling and reinstalling without luck. It would now seem that another game I own, dungeon defenders is giving me the same issue. I know for a fact that game worked like a charm yesterday. Any other ideas?

    Okay. I assume that you rebooted in between uninstalling and reinstalling.

    Let’s keep trying. I found someone with a similar problem who had to go into their UDKEngine.ini and set bInitializeShadersOnDemand=True.

    You can find that file here: Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKEngine.ini



  • @ReMixx:

    @goldenness:

    Sigh…tried uninstalling and reinstalling without luck. It would now seem that another game I own, dungeon defenders is giving me the same issue. I know for a fact that game worked like a charm yesterday. Any other ideas?

    Okay. I assume that you rebooted in between uninstalling and reinstalling.

    Let’s keep trying. I found someone with a similar problem who had to go into their UDKEngine.ini and set bInitializeShadersOnDemand=True.

    You can find that file here: Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKEngine.ini

    I can’t seem to find bInitializeShadersOnDemand in the file. However, I did not reboot between the uninstall and the re-install. Trying that now.



  • @goldenness:

    I can’t seem to find bInitializeShadersOnDemand in the file. However, I did not reboot between the uninstall and the re-install. Trying that now.

    Okay, let us know if that works.

    It looks like this on my computer.

    [Engine.ISVHacks]
    bInitializeShadersOnDemand=False
    DisableATITextureFilterOptimizationChecks=True
    UseMinimalNVIDIADriverShaderOptimization=True
    PumpWindowMessagesWhenRenderThreadStalled=False
    

    Edit:
    Something that I’ve noticed from your DxDiag.txt, it looks like you have a single core CPU (AMD Athlon 64 3500+). Chiv is known to not work with single core CPUs. To quote a dev:

    @CrustaceanSoup:

    There’s a bunch of different issues flying through this thread, it’s hard to keep track of them.

    Yes, if the OP is using a single-core CPU (I think the Semprom likely is?), it will not work. No, current UE3 is no longer exactly the same as the UE3 that UT3 shipped on, and I’m not aware of any config options that will make single core CPUs work. We may be able to get them working in the future, however note that our minimum requirements specify a dual-core CPU and this is part of why.

    Read through this thread here: viewtopic.php?f=69&t=4751



  • Well, it would seem the game won’t be working on my computer. Really appreciate the efforts though.



  • @goldenness:

    Well, it would seem the game won’t be working on my computer. Really appreciate the efforts though.

    Sorry that I couldn’t help more :(

    I think that Steam offers a 1 time refund that you can inquire with them about.



  • Hello, me again. I recently contacted steam support about the refund. After a few messages back and forth, they said they couldn’t refund the game and I quote “Please continue to work with them as they will be able to resolve this issue. If they cannot, please reply to this support ticket”. That being said, do you possibly have any other tips for me?



  • @goldenness:

    Hello, me again. I recently contacted steam support about the refund. After a few messages back and forth, they said they couldn’t refund the game and I quote “Please continue to work with them as they will be able to resolve this issue. If they cannot, please reply to this support ticket”. That being said, do you possibly have any other tips for me?

    I’m afraid not. :(

    The game crashes or hangs on my computer with a single-core CPU
    The game does not currently support single-core CPUs, hence the minimum requirements including a dual-core CPU.

    Your graphics card is also a generation behind the minimum requirements :(