Help! new keybinds menu has stopped me from playing!



  • I am a lefty so I use custom controls. For example i use the arrow keys for movement instead of WASD
    , but with the new keybind menu now i don’t seem to have any way from preventing turn left and turn right from being bound to the left and right arrow keys. I have move left and right bound to their respective arrow key, but those keys now make me both strafe AND turn and there is no way to change the binding for turn left/right so my movement is completely broken! I suggest adding keybinds for turn right/left as a fix of sorts. Please fix this quickly as i love this game and playing righty is just too hard :(



  • @OutlawStar:

    I am a lefty so I use custom controls. For example i use the arrow keys for movement instead of WASD
    , but with the new keybind menu now i don’t seem to have any way from preventing turn left and turn right from being bound to the left and right arrow keys. I have move left and right bound to their respective arrow key, but those keys now make me both strafe AND turn and there is no way to change the binding for turn left/right so my movement is completely broken! I suggest adding keybinds for turn right/left as a fix of sorts. Please fix this quickly as i love this game and playing righty is just too hard :(

    Two friends of mine bought the game today, same problem.
    I always play with WASD but they can’t, they’re very attached to their arrow keys.
    If anyone has a solution, please.



  • As a temporary solution, try removing the following lines from either UDKInput.ini or UDKGame.ini in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config. I’m not entirely sure which file will work for you, because there’s so many files all containing the same thing now.

    Bindings=(Name="Left",Command="GBA_TurnLeft")
    Bindings=(Name="Right",Command="GBA_TurnRight")
    


  • @Martin:

    As a temporary solution, try removing the following lines from either UDKInput.ini or UDKGame.ini in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config. I’m not entirely sure which file will work for you, because there’s so many files all containing the same thing now.

    Bindings=(Name="Left",Command="GBA_TurnLeft")
    Bindings=(Name="Right",Command="GBA_TurnRight")
    

    It was UdkInput.ini.
    But unfortunately, it didn’t work.



  • What the… bear with me while I try it myself.



  • @Martin:

    What the… bear with me while I try it myself.

    Ok, I’ll wait :|



  • Ok, sorry, it’s turned out to be UDKGame.ini.

    Ensure Name=“Left” and Name=“Right” read as:

    Bindings=(Name="Left",SecondaryKey=,Command="GBA_AOCLeft",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag="KBFlag_Movement",FriendlyName="MoveLeft")
    Bindings=(Name="Right",SecondaryKey=,Command="GBA_AOCRight",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag="KBFlag_Movement",FriendlyName="MoveRight")
    


  • @Martin:

    Ok, sorry, it’s turned out to be UDKGame.ini.

    Ensure Name=“Left” and Name=“Right” read as:

    Bindings=(Name="Left",SecondaryKey=,Command="GBA_AOCLeft",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag="KBFlag_Movement",FriendlyName="MoveLeft")
    Bindings=(Name="Right",SecondaryKey=,Command="GBA_AOCRight",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag="KBFlag_Movement",FriendlyName="MoveRight")
    

    Thank you, I’ll try this right now. (Sorry I lost track of time, watching a Chivalry vid)

    EDIT: Works Perfectly!

    Thanks a lot for your help and patience, you rock :)



  • need to the up and down bindings as well the left and right worked please !!! martin/ algerian please



  • Fixed it. Thx for your help !!!



  • Ooh thanks for your help telling us where to locate it Martin. I changed some lines to make it so I can finally use my lefty numpad + arrow keys config and all is well now!



  • Thanks a ton for the help martin, but now i have a new issue since i edited that udkgame.ini.
    Apparently the keybind options for primary,secondary,tertiary attacks as well as feint and block have mysteriously disappeared from the list, so i tried changing them in the udkgame.ini and nothing happened. I use right click as alt fire and middle mouse as parry so this is very frustrating!



  • This might be an easier solution
    viewtopic.php?f=69&t=6078


Log in to reply