Unlocks and Keybind issues.



  • Hello everyone! I seem to have quite the issue.
    The latest patch seems to have bugged my client in very strange ways unfortunately.

    My key bindings were reset (which was no real issue), the issue being that many of the important binds once available now are no longer present. I can no longer assign these following commands;

    (1.): Strafing movement. [This is incredibly important as you may know]
    (2.): Shoving.
    (3.): Secondary and tertiary attacks.

    Stranger still, sometimes even trying to access the key binding menu causes some commands cease to show up, and some are duplicated with incorrect names.

    It even seems like I was given someone’s preferences, as my resolution was very incorrect, and quite random (having been set as “1440x990” instead of my native, and windowed oddly to boot)]

    On that note, my class unlocks are also very strange, as I had unlocked the following weapons yet I no longer possess them;
    (1): All spear-type weapons [Fork - Brandistock ]
    (2): All Greater swords [Claymore - Zweihänder ]
    (3): The Second Javelin [Light javelin I believe?]
    (4): All Mace-type weapons [Morning star - Holy water sprinkler ]
    (5): The Maul

    Though A few weapons I had unlocked prior were unaffected. Such as;
    (1): The Poleaxe
    (2): The Sword-of-war

    Here is where it gets really strange, weapons I have that I had never unlocked yet I now possess;
    (1): The second and last crossbow
    (2): The Norse sword (Awesome sword, but definitely not one I unlocked)
    (3): the Sabre

    I’m not sure what the rest of the patch has changed, as the aforementioned issues with my bindings have prevented me from playing unfortunately.

    I love this game, and am currently awaiting some form of hot-fix eagerly, regardless of that however, does anyone have a Temporary work-around for the binding issues?



  • I wish I knew D:.



  • Because of the Keybinding issue:
    Check the other threads already openend.



  • Same issue with the keybinds, I did what EFFECT said above me and it worked :

    @Effect:

    Several threads already openened with this issue.
    In Short:

    • Verify your Steam Cache
    • Delete Chivalry Folder in the Folder My Games in My Documents
    • Set all the binds
    • When in Game verify if they work, if not set again
      –> Should work

    Thank you very much.

    However, I had unlocked EVERYTHING for every class except the bow and crossbow.

    Now I lost 80% of my unlocks, I have to re-do everything…



  • You mean you did what PedroFromHell said. viewtopic.php?f=69&t=6078
    Sneaky Effect taking the credit ;)



  • @PedroFromHell:

    You mean you did what PedroFromHell said. viewtopic.php?f=69&t=6078
    Sneaky Effect taking the credit ;)

    lol, didn’t know, thank you too as well

    But I will blame you for the unlock lost since I didn’t lose them before doing the change :P



  • After restarting Steam I got my unlocks back



  • @teweedo:

    After restarting Steam I got my unlocks back

    Unfortunately that is not the case for me. I’m still having all these issues despite having tried all present workarounds.

    Suppose I won’t be playing much for a while.


Log in to reply