FIX: Missing Keybinds/Keybinds Conflicts



  • Hello all,
    I’m seeing many threads popping up addressing this issue. Instead of having 7 different threads, I thought we could have just the one. Perhaps a mod could sticky this?

    In order to fix the missing keybinds or keybind conflict bug, try the following:
    First verify your Stream Integrity Cache
    Then
    Delete your “Chivalry Medieval Warfare” folder inside “my games” in your personal documents and run the game again
    Finally
    Do not press the “Reset” button in the Keybinds menu and try to rebind all your keys in one go
    Deleting the .ini files alone does not seem to fix it, nuke the whole folder, it will be generated again when you run the game.

    This has worked for me in two seperate machines with two seperate copies of the game suffering from the same issue.
    From a couple of threads where I have submitted this, the response I get is that it seems to work.
    This will also fix the FPS drop to 2-5 FPS you get when pressing the R button, and T and Y bringing up “say” and “team say” in the console instead of the chat box.

    Please bear in mind that some binds are supposed to be multiple for the same key as default. For example, default right click should parry, feint, and zoom in depending on the context. C should Battle Cry and Mobile Battle Cry depending on whether you are sprinting or not. This is normal default behaviour intended by the devs after the patch.

    Please share if this fix worked for you or if it didn’t. If we compile it all into one thread, we’ll have a better chance of fixing it for everyone.



  • If you dont verifyed your Stream Integrity Cache first you are level 8 after doing this! You can fix it by restoring the folder. (I tested it twice or is this bug only for me?)



  • Unfortunately this did not solve my problem.
    Stranger still, when I try to strafe left or right I turn left heavily and strafe left slightly at the same time, and vice versa for the right.

    It also makes erroneous duplicates in my keybinding menu of other binds.
    Trying to clear the binding from the duplicate (or the actual bind) just results in both setting back to
    what they were assigned beforehand ( I.e Left / Right )



  • Bind the keys again. After deleting the folder I set up my binds; But they were screwed in game; Then I set them again (was quite hard though because some Strings were screwed up again) and it worked!



  • Jimmeh, if that didn’t work then I suggest you uninstall and reinstall, and make sure to delete the folder mentioned above so your configurations aren’t transferred.
    I’m bumping this thread because I still see a bunch of new keybind issues threads being made.



  • If you deleted your folder then you will lose all the ranks if you did that then:
    viewtopic.php?f=69&t=6108



  • The
    “Steam integrity” + “Delete Folder” Trick didnt work for me - every keybind reseted after that yes, but arrows keys still messed up after changing them.

    Here is how i fixed it from strafe+turn camera to strafe only (so i can steer with the arrow keys)

    Open UDKGame.ini in C:\Users\blabla\Documents\My Games\Chivalry Medieval Warfare\Config

    Goto text [UTGame.UTPlayerInput]
    below there are the text lines:
    Bindings=(Name=“Left”,SecondaryKey=,Command=“GBA_AOCLeft” …
    Bindings=(Name=“Right”,SecondaryKey=,Command=“GBA_AOCRight” …

    Make sure the Bindings Command for Left and Right only says “GBA_AOCLeft” or “GBA_AOCRight” and delete the |GBA_Turn if necessary e.g. “GBA_AOCLeft|GBA_TurnHamster” to “GBA_AOCLeft”



  • Guy,

    just a quick tip… I also add keybind conflict …I’m using a French keyboard and to move foward i’m normally using Z but despite I changed it in the keys configuration, it remained on W… no way to change it…

    I tried all the tips above (delete the line…etc…)… and I did a very stupid thing but it actually works !.. I just opened the UDKgame.ini and change the W by Z and vice versa…

    works perfectly… problem solved :P



  • Have recently bought the game and as an arrow key user, was pleased to see an option to configure them …… however it went badly wrong with duplicate key binds being added by the programme (as mentioned above) and unable to bind the arrow keys for movement.
    I uninstalled the game and the extra key binds were removed but even using the second option set up, unable to bind the arrow keys correctly.
    Great game that could have a future but little (seemingly simple things) like being unable to chosoe a key layout, does put off investing further in the game i.e expansion packs or DLC.

    Please help those with fat fingers who cant use WASD ;)


Log in to reply