PhysX running in software on CPU vs in hardware on GPU?



  • Since I’ve been staring at .log files all morning, I’ve noticed this in all log files:

    Primary PhysX scene will be in software.
    

    I’m not too up to date on PhysX these days, but doesn’t it make sense that we should be running it in hardware on our GPUs if we have GPUs that are capable instead of in software on CPUs? Is this possible the reason for poor performance for some people?

    It kind of makes sense… for example, a friend of mine has a beefy new laptop and a beefy desktop with GPUs that are almost comparable. Chiv runs infinitely better on his desktop and he keeps claiming that it is CPU bound (where his desktop CPU is infinitely better than his laptop CPU). If PhysX is running on the CPU, that would explain why he gets much better performance with his desktop CPU when the two GPUs are almost comparable.

    Just thinking out loud.



  • Thanks for this post!

    So I had those issues you mentioned, I thought I had tried every thing.

    Now I finally got playable fps and almost no lag at all, what did I do?

    Nvidia control panel and changed from automatic by program to force PhysX through my GPU, shazaam!

    It is obviously not optimized then and it is not perfect smooth, but game is now playable and running decent enough for me to be satisfied.

    8-)

    Now if they could optimize it I would get more than 60fps in fights.

    I still tun into the problem with alt tabbing capping cpu does decreasing games performance, which seems to be intentional for some reason?!

    So please optimize this game running through GPU devs, I guess that would be the answer.



  • Sweet! Good to know! Now if we can get other people with the lag to try it out and report back…



  • @ReMixx:

    Sweet! Good to know! Now if we can get other people with the lag to try it out and report back…

    I posted it in a reply to the thread in support as well.

    Obviously this is done with a nvidia card so no idea about other or even different model, mine is a GTX 560 card, processor is an i7 hitting somewhere above 3ghz in turbo boost.

    Still game is not optimized since I get almost same fps with all settings max vs all settings at the lowest.

    It wuld also be nice to have a 64bit client.



  • @labia:

    @ReMixx:

    Sweet! Good to know! Now if we can get other people with the lag to try it out and report back…

    I posted it in a reply to the thread in support as well.

    Obviously this is done with a nvidia card so no idea about other or even different model, mine is a GTX 560 card, processor is an i7 hitting somewhere above 3ghz in turbo boost.

    Still game is not optimized since I get almost same fps with all settings max vs all settings at the lowest.

    It wuld also be nice to have a 64bit client.

    It’s odd because I also have a GTX 560 ti and an i7 but I’m not getting this lag that every speaks of. I didn’t set anything to force physx on GPU either.



  • @ReMixx:

    @labia:

    @ReMixx:

    Sweet! Good to know! Now if we can get other people with the lag to try it out and report back…

    I posted it in a reply to the thread in support as well.

    Obviously this is done with a nvidia card so no idea about other or even different model, mine is a GTX 560 card, processor is an i7 hitting somewhere above 3ghz in turbo boost.

    Still game is not optimized since I get almost same fps with all settings max vs all settings at the lowest.

    It wuld also be nice to have a 64bit client.

    It’s odd because I also have a GTX 560 ti and an i7 but I’m not getting this lag that every speaks of. I didn’t set anything to force physx on GPU either.

    Hmm, what OS and is it 64 bit or 32? SLI or single card? hmm what else. In nvidia control panel under PhysX settings, automatic, gpu or cpu is set?

    Also what refresh rate, what screen? I read there is known issues with 120hz screens and I use that since I got nvidia 3d also.

    PS: not alt tabbing once keeps my fps stable throughout all game session, if I alt tab once, it is better to restart client. Window mode solves this though.



  • @labia:

    Hmm, what OS and is it 64 bit or 32? SLI or single card? hmm what else. In nvidia control panel under PhysX settings, automatic, gpu or cpu is set?

    Also what refresh rate, what screen? I read there is known issues with 120hz screens and I use that since I got nvidia 3d also.

    PS: not alt tabbing once keeps my fps stable throughout all game session, if I alt tab once, it is better to restart client. Window mode solves this though.

    Windows 7 Pro 64-bit
    Single card GTX 560 TI
    Core i7 920 @ 3.5 Ghz
    60 Hz on a Sceptre X22HG
    PhysX on auto-select



  • @ReMixx:

    @labia:

    Hmm, what OS and is it 64 bit or 32? SLI or single card? hmm what else. In nvidia control panel under PhysX settings, automatic, gpu or cpu is set?

    Also what refresh rate, what screen? I read there is known issues with 120hz screens and I use that since I got nvidia 3d also.

    PS: not alt tabbing once keeps my fps stable throughout all game session, if I alt tab once, it is better to restart client. Window mode solves this though.

    Windows 7 Pro 64-bit
    Single card GTX 560 TI
    Core i7 920 @ 3.5 Ghz
    60 Hz on a Sceptre X22HG
    PhysX on auto-select

    Only thing noticeable is the screen, since this game is capped at 90fps and I have read by several that 120hz causes issues with the game.

    Still, dx9 32bit client these days must cause issues as well and it does show to not be optimized if you tinker with the graphical options a bit.

    Also game does not utilize anywhere near max of the gpu.

    Anyway, I can play the game now and I hope with time they will optimize it further.



  • @labia:

    Thanks for this post!

    So I had those issues you mentioned, I thought I had tried every thing.

    Now I finally got playable fps and almost no lag at all, what did I do?

    Nvidia control panel and changed from automatic by program to force PhysX through my GPU, shazaam!

    It is obviously not optimized then and it is not perfect smooth, but game is now playable and running decent enough for me to be satisfied.

    8-)

    Now if they could optimize it I would get more than 60fps in fights.

    I still tun into the problem with alt tabbing capping cpu does decreasing games performance, which seems to be intentional for some reason?!

    So please optimize this game running through GPU devs, I guess that would be the answer.

    When you do this, what sort of a framerate do you get when you enable visualization of the collision meshes using the console command “nxvis collision” ?

    When the physx is performed on cpu, enabling “nxvis collision” tanks the framerate to ~1fps; I’m wondering if the impact of visualizing it is lessened if the physx simulation itself is performed on the gpu.

    (I’m on amd hardware, so can’t test it myself)



  • does not matter, without any changes on my end, game has now reverted to shit fps again…

    makes no sense, was just 60fps in combat, now back to slideshow.

    fuck this!



  • You sure the desktop and laptop GPU’s are comparable? A GTX 670M is totally not the same as a GTX 670 for example (the 670 is about 3x faster).

    Anyway, my opinion about physx is that is just a trick from nvidia to steal customers from amd. I know only one game where physx added some awesomeness to a game and that is borderlands 2. And i have read some posts on other forums from people who had no difference in CPU usage when they ran physx on GPU or CPU. Which could mean that nvidia’s physx doesn’t even run on the GPU but is just done on the CPU.



  • ReMixx you deserve many thanks.You are always very helpful,I haven’t seen any moderator helping anyone and everyone like that…You should be one.You are one of the most important persons in this community.I’ve watched your activity in support section and you are always willing to help showing patience with everyone’s problem.

    Keep up the good work! 8-)



  • I have been playing with this as well and have been reading up on this with the UDK engine. Some of the problem is that there is a new version of Physx that really does allow for better CPU compatibility but that the Devs would have to code it better for it. That said, I have not really noticed much difference other than the CPU setting seems to lag a little more overall where as the GPU tends to spike lag more. FPS seems overall lower on the CPU than the GPU but I have no concrete way to really prove this other than watching my FPS in game over time. I am sure I could set up an exacting test but it seems miniscule. If one works better for you than the other, by all means go for it.



  • @johnk17:

    ReMixx you deserve many thanks.You are always very helpful,I haven’t seen any moderator helping anyone and everyone like that…You should be one.You are one of the most important persons in this community.I’ve watched your activity in support section and you are always willing to help showing patience with everyone’s problem.

    Keep up the good work! 8-)

    Awwww thanks! Heart.



  • if anyone want 120 fps online with this game do this -

    go to my game - chivalry medieval warfare - udkgame - config

    open up udkengine.ini and edit this line -

    MinSmoothedFrameRate=22
    MaxSmoothedFrameRate=62

    change the second value to 122

    :)



  • Thanks sire, I have no problem with this game when it was on ‘Automatic’ for PhysX, however when I record footage with DX-Tory, it lags like a son of a. I want to see how it runs now…



  • @Sir:

    if anyone want 120 fps online with this game do this -

    go to my game - chivalry medieval warfare - udkgame - config

    open up udkengine.ini and edit this line -

    MinSmoothedFrameRate=22
    MaxSmoothedFrameRate=62

    change the second value to 122

    :)

    That does’t mean that people will get 120fps all that will do is unlock the FPS cap but the engine is set for a max FPS of 90 I believe or so I have read so it is a false FPS. SO if players are already having FPS drops down to the 30s or less, unlocking the cap will do nothing but allow FPS to count to be higher if the hardware can do it.



  • Could it be that, since PhysX is running in software on CPU instead of using GPU, it’s the reason why my CPU is always overheating when playing Chiv? I had to disable turbo boost and underclock the CPU by 20% in order to play. This I get a constant 40 FPS; but at 100% I get 60 before it start to overheat.
    I never had to do something like that even on games that are way more hungry on specs.

    Btw, those who have low FPS, if you lower all the graphics and it changes nothing, it normally means that it’s a CPU related problem, not GPU (obvious I know but for some people it’s not).



  • @unholy:

    Could it be that, since PhysX is running in software on CPU instead of using GPU, it’s the reason why my CPU is always overheating when playing Chiv? I had to disable turbo boost and underclock the CPU by 20% in order to play. This I get a constant 40 FPS; but at 100% I get 60 before it start to overheat.
    I never had to do something like that even on games that are way more hungry on specs.

    Btw, those who have low FPS, if you lower all the graphics and it changes nothing, it normally means that it’s a CPU related problem, not GPU (obvious I know but for some people it’s not).

    What CPU you running? Was it at default clocks before underclocking it?



  • Thanks for this post!
    now my 60 fps are back=) (dropped down to 45 in combat)